2011 XC60 P0420 Code

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
Post Reply
xyourobob
Posts: 44
Joined: Fri Oct 07, 2016 7:02 am
Year and Model: 2004 XC90, 2011 XC60
Location: Maryland, USA
Been thanked: 1 time

2011 XC60 P0420 Code

Post by xyourobob »

Happy New year to everyone. My 2011 XC60 T6 with 150K miles threw a P0420 code, my hand OBII wouldn't clear the code so I hooked up VIDA and sure enough the ECM fault code "Catalyst System Efficiency Below threshold (bank 1)" was there. Funny enough I was not able to delete the code using VIDA, most times a failing O2 sensor will throw this code and you can clear it and then the code will come on again somewhere in the imminent future but I can't understand why I can't clear it? When I click Erase All I get a communication fault message, car not responding? I'm assuming I will have to purchase a new downstream o2 sensor but can anyone shed any light on why I cannot clear the code?

xyourobob
Posts: 44
Joined: Fri Oct 07, 2016 7:02 am
Year and Model: 2004 XC90, 2011 XC60
Location: Maryland, USA
Been thanked: 1 time

Post by xyourobob »

Buzz!!!!

xyourobob
Posts: 44
Joined: Fri Oct 07, 2016 7:02 am
Year and Model: 2004 XC90, 2011 XC60
Location: Maryland, USA
Been thanked: 1 time

Post by xyourobob »

I ordered a new sensor for less than $100. It was fun removing the old one, heating it up with a propane torch did the trick. After installing the new sensor I disconnected the battery for 10 minutes to clear the code and so far so the engine light has remained off.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post