IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Just bought 2007 S80 3.2 121K

Help, Advice, Owners' Discussion and DIY Tutorials on the third generation Volvo V70 wagon and XC70 crossover, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

Skymongrel
Posts: 45
Joined: Thu Apr 16, 2015 7:10 am
Year and Model: XC70 2006, S80 2007
Location: Rochester, NY
Has thanked: 11 times
Been thanked: 2 times
United States of America
Skymongrel

Just bought 2007 S80 3.2 121K

Post by Skymongrel » Thu Mar 12, 2020 4:05 pm

I've been looking for a car for my son and found a 2007 Volvo S80 3.2 with 121k. I was encourage to buy it due to great online repair support here.

I purchased a carfax report and it looks like the two previous owners did regular maintenance. The reseller revealed that they put in a new power steering pump and that the dealer he bought from had put in a water pump. (neither item in carfax).

A test drive didn't reveal any negatives. Ride is nice and has decent engine performance. A couple troubling items are that the fresh air hose from the front grill was missing, (air box seems loose so maybe I'll find hose at the bottom of engine), the complicated hose from air box to throttle body has a little squarish appendage that had RTV on it. So keeping an eye on these issue (ordered new fresh air hose to grill).

From post by PGill I'm alerted to possible thermostat issues and will watch that. I did see fro Carfax where it was serviced for a "noise" and had coolant hoses replaced, but that was back around 87K.

Wish us luck, pick it up tommorow!

Skymongrel
Posts: 45
Joined: Thu Apr 16, 2015 7:10 am
Year and Model: XC70 2006, S80 2007
Location: Rochester, NY
Has thanked: 11 times
Been thanked: 2 times
United States of America
Skymongrel

Re: Just bought 2007 S80 3.2 121K

Post by Skymongrel » Sat Mar 14, 2020 10:56 am

Well...found my first problem with new used S80. Windshield Washer doesn't work! I have some fluid leaking from reservoir, but my headlight washers do work!

If you done this let me know. Meantime I'll do some searching...so far no luck.
Thanks!

User avatar
MoVolvos
Posts: 2385
Joined: Sun Jan 15, 2012 6:47 pm
Year and Model: 03S80T6~08C30T5
Location: NC
Has thanked: 29 times
Been thanked: 70 times
United States of America
MoVolvos

Re: Just bought 2007 S80 3.2 121K

Post by MoVolvos » Sat Mar 14, 2020 12:41 pm

Skymongrel wrote:
Sat Mar 14, 2020 10:56 am
Well...found my first problem with new used S80. Windshield Washer doesn't work! I have some fluid leaking from reservoir, but my headlight washers do work!

If you done this let me know. Meantime I'll do some searching...so far no luck.

Thanks!
If the reservoir is cracked use a hot glue gun after thoroughly fine sanding and cleaning with 90+ percent alcohol. Make sure the hot glue is very hot and used liberally. This worked for the coolant overflow reservoir (not expansion tank) on my 03 Odyssey, going on 3 years. Good size hole as it sat on the serpentine belt while running after a radiator replacement. Forgot to put the reservoir back into the mount when I went on a test drive.
These users thanked the author MoVolvos for the post:
Skymongrel
Blessings,

BKM

1998 S70 T5 - Donated
2003 S80 T6
2003 GS300
2003 Odyssey
2008 C30 T5
2019 Atlas SE 4 Motion

User avatar
pgill
Posts: 275
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 23 times
Been thanked: 42 times
United States of America
pgill

Re: Just bought 2007 S80 3.2 121K

Post by pgill » Sat Mar 14, 2020 6:24 pm

Congrats on the S80 purchase

My Son is driving the 2010 S80 that I bought for him.

I do get to fix it. (although it doesn’t require much fixing)

Back to the problem at hand

First Roberts suggestion is an excellent starting point.

I looked on FCP and it seems that there are two pumps one for the windshield and another for the headlights.

https://www.fcpeuro.com/products/volvo- ... 35#fitment

https://www.fcpeuro.com/products/volvo- ... 38#fitment

My 2009 Audi has a similar configuration and the pump failed and leaked.

I haven’t fixed this part on my Volvo

Don’t forget to get new grommets too

https://www.fcpeuro.com/products/volvo- ... et-8678424

https://www.fcpeuro.com/products/volvo- ... t-30655139

Good luck

Paul
These users thanked the author pgill for the post:
Skymongrel

Skymongrel
Posts: 45
Joined: Thu Apr 16, 2015 7:10 am
Year and Model: XC70 2006, S80 2007
Location: Rochester, NY
Has thanked: 11 times
Been thanked: 2 times
United States of America
Skymongrel

Re: Just bought 2007 S80 3.2 121K

Post by Skymongrel » Sun Mar 15, 2020 7:09 am

Is the best way to repair this the front bumper removal or can it be done through the fender liner?
Thanks!

Also, perhaps I should post another topic as I find issues with our new ride...but the front exhaust hanger is rusted off. Position on car is just aft of the front seats underneath. I've searched online and can only find rear hangers.

Thanks!

User avatar
pgill
Posts: 275
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 23 times
Been thanked: 42 times
United States of America
pgill

Re: Just bought 2007 S80 3.2 121K

Post by pgill » Sun Mar 15, 2020 1:27 pm

Take a look at this video

It’s for a XC70 but I suspect it’s similar to the S80

If it is similar then one of the pumps is accessible by removing the liner from the wheel well

But the other one doesn’t seem to be



Thanks

Paul

PS is you want to watch fun Volvo repair videos then the guy I posted the link too is good but MoVolvo also has many interesting videos
These users thanked the author pgill for the post:
Skymongrel

User avatar
MoVolvos
Posts: 2385
Joined: Sun Jan 15, 2012 6:47 pm
Year and Model: 03S80T6~08C30T5
Location: NC
Has thanked: 29 times
Been thanked: 70 times
United States of America
MoVolvos

Re: Just bought 2007 S80 3.2 121K

Post by MoVolvos » Mon Mar 16, 2020 3:02 pm

Skymongrel wrote:
Sun Mar 15, 2020 7:09 am
Is the best way to repair this the front bumper removal or can it be done through the fender liner?
Thanks!

Also, perhaps I should post another topic as I find issues with our new ride...but the front exhaust hanger is rusted off. Position on car is just aft of the front seats underneath. I've searched online and can only find rear hangers.

Thanks!
According to these folks no bumper removal was necessary. Not sure of your setup so take a look at the diagrams.
.
http://volvospeed.com/vs_forum/topic/17 ... reservoir/
.
I took a quick look but didn't find the windshield washer system. They sometimes list parts diagram in one year but not another though it's the same model year run.
https://www.volvopartswebstore.com/cars ... parts.html
These users thanked the author MoVolvos for the post:
Skymongrel
Blessings,

BKM

1998 S70 T5 - Donated
2003 S80 T6
2003 GS300
2003 Odyssey
2008 C30 T5
2019 Atlas SE 4 Motion

Skymongrel
Posts: 45
Joined: Thu Apr 16, 2015 7:10 am
Year and Model: XC70 2006, S80 2007
Location: Rochester, NY
Has thanked: 11 times
Been thanked: 2 times
United States of America
Skymongrel

Re: Just bought 2007 S80 3.2 121K

Post by Skymongrel » Tue Mar 24, 2020 6:37 am

Regarding the best way to get to the windshield washer pump;

I was able to remove the flat plastic bumper apron (called a protection plate located under the bumper) to get to the washer pumps. I removed about 8 screws and three large plastic clips to remove this part. Be careful the washer electrical connector is attached to the plastic apron with a removable connector.

Once removed I had clear view of the washer reservoir and pumps. Everything looked in order, no crimping of fluid lines or corrosion of connectors. I pried loose the windshield washer pump by carefully pulling it out and apply 12v to the contacts. The pump didn't respond so I believe it is the problem. I've order a new one and should have it soon. I should mention that the rubber grommet (which also acts as a debris screen) although intact on removal, disintegrated in my hands.

Skymongrel
Posts: 45
Joined: Thu Apr 16, 2015 7:10 am
Year and Model: XC70 2006, S80 2007
Location: Rochester, NY
Has thanked: 11 times
Been thanked: 2 times
United States of America
Skymongrel

Re: Just bought 2007 S80 3.2 121K

Post by Skymongrel » Thu Mar 26, 2020 4:09 pm

Installed my new windshield washer pump and rubber bushing/screen today. I now have working windshield washers! Yay!
I purchased a after market pump at a reasonable price but did notice that it had problematic electrical connectors. I read a review warning about this so I was careful. The pin are easily misaligned within the connector so if the connector doesn't seat readily, tweak the pins a bit!

Now that washers are working I discovered a cracked t-connector at my washer spray nozzle! Oh boy..so much fun!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post