IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Horn Not Doing the Horn Thing. Help!

Help, Advice, Owners' Discussion and DIY Tutorials on the third generation Volvo V70 wagon and XC70 crossover, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

Post Reply
PowerChordAficionado
Posts: 1
Joined: Thu May 14, 2020 8:52 am
Year and Model: 2008 C30 and XC70
Location: Atlanta, GA

Horn Not Doing the Horn Thing. Help!

Post by PowerChordAficionado »

My wife's 2008 XC70's horn suddenly stopped making any noise. I've deployed the minimal knowledge I have and have scoured the internet for advice but I've hit a dead end and am hoping for some Volvo-specific advice before giving up and taking it into the mechanic.

Here's what I have done (and how I did it):

*Checked the 15A horn fuse: looks good and multimeter shows continuity
*Checked the horns for sound: They both honked when I fed them from the battery
*Checked the horns for impedance: Low note read 2.3 ohms and high note read 0.7 ohms (is this normal?)
*Checked the wiring harnesses: both displayed battery voltage (~12v) when pos and neg harness terminals connected to multimeter
*Inspected the steering wheel switches (I didn't know what to look for but there were no loose/cracked wires)
*Tested voltage when pressing horn button: Voltage dropped from ~12v to ~11v when pressing the horn button, indicating something was passing through the signal to the connector

I have read there is no horn relay on these cars and that the CEM essentially controls the sending of the horn signal. CEM repair looks quite costly and as there are no other electrical issues I'm hoping this is not the culprit. Any advice on what else I can do (or advice on what I did wrong) to test the circuit would be much appreciated!
MazdaDude
Posts: 4
Joined: Wed Jun 10, 2020 7:59 am
Year and Model: 2008 S80
Location: Lexington, KY

Re: Horn Not Doing the Horn Thing. Help!

Post by MazdaDude »

Hopefully I don’t come off as stupid my first post on here!

I don’t know much about Volvo’s, name checks out, but, if the horn sounds when 12v is directly applied, it’s not the horn. It must be the connection somewhere between the steering wheel, the computer, and the physical horn.

I will say, IF it turns out to be a computer issue, if the expense is too much, you could very easily tap into the horn’s wire before it goes to the computer, install a relay in the fuse box, and run it to the horn with a direct 12 from the battery to fuse. As a bypass. I had to install a relay in the wifes S80 because the SiriusXM receiver in the trunk has a phantom drain, so when she turns the car off it disconnects the satellite receiver. Same principal, just activating when she completes the horn circuit.

Other than the computer issue, You’ll have to check the wiring from the horn to the computer, do resistance checks to make sure the wire is damaged somewhere. Same for the wiring leaving the computer to the horn.

I hope I helped some at least! If you need any help installing a relay, just let me know and I can walk you through it better.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post