IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2000 S40 ABS Brake faults - reoccurring after ABS sensor repair

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.

1996 - 2004 S40
1996 - 2004 V40

tsteenka
Posts: 1
Joined: Thu Feb 09, 2017 9:27 am
Year and Model: 2000 S40
Location: Maryland
Has thanked: 0
Been thanked: 0
United States of America
tsteenka

2000 S40 ABS Brake faults - reoccurring after ABS sensor repair

Post by tsteenka » Mon Mar 06, 2017 9:12 am

I've seen a number of threads regarding the failures of Bosch ABS sensors on this model. This S40 has 150k and had the classic symptoms, ABS, Brake lights on, speedometer not working. Researched a few of the repair sites for the Bosch unit and went with BBA Reman as it is closer to my location.
Reinstalled unit, it worked for about 20 minutes and then same symptoms reappeared. Intermittently it would decide to work again, usually on the first start of the day. Sent it back to them for verification, which they subsequently claimed passed all their tests. Reinstalled unit and again it worked initially only to fail within the first day. Very frustrating. Unable to communicate with unit for diagnostics. What am i missing?

  • Similar Topics
    Replies
    Views
    Last post