IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Volvo S40 T4 low boost

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.

1996 - 2004 S40
1996 - 2004 V40

Nywack
Posts: 3
Joined: Wed Apr 11, 2018 11:42 am
Year and Model: Volvo S40 T4 2002
Location: Sweden
Has thanked: 0
Been thanked: 0
Sweden
Nywack

Volvo S40 T4 low boost

Post by Nywack » Wed Apr 11, 2018 12:07 pm

Hi! So I recently got myself a Volvo S40 T4 2002, 160.000km.
When I test drove the car everything was fine, making 1.0 - 1.2 bar of boost, no stuttering or anything like that.
Once I was making my way home with the car it started stuttering etc and died once I engaged the clutch.

The problem with the stuttering was fixed by replacing the ignition coils and cleaning the sparkplugs (both ignition coils was cracked).
The random dying also stopped by replacing the idle control valve.
But sometimes the car wouldnt boost up to 1.0 - 1.2 bar ( it's stage 2 ) but stay at around 0.2 - 0.4 bar, this was fixed by a few restarts or letting the car sit for a while.

But now, the car will NEVER go over 0.2 - 0.4 bar, it's like stuck at that rate from 2000rpm to redline.
I honestly don't have a clue what it could be and wish someone here had any ideas. Also if anyone has a vacuum routing diagram for the s40 t4 2002 don't be shy to post it! :)

So this is what I've replaced / done so far :
*Replaced Ignition coils
*Replaced Idle Control Valve
*Replaced Mass Airflow Sensor
*Replaced Sparkplugs


I don't get any kind of engine codes or anything like that, nor anything stored.
I have access to Vida Dice.. but nothing shows.

So if anyone has a theroy or any sort of tips I'd be really glad if you could post.

Thanks! :)



jwalker275
Posts: 7
Joined: Mon Nov 19, 2018 5:10 pm
Year and Model: 02 s40
Location: PA
Has thanked: 0
Been thanked: 0
United States of America
jwalker275

Re: Volvo S40 T4 low boost

Post by jwalker275 » Mon Jul 15, 2019 5:46 pm

man, nobody at all replied to you in over a year ???
dang....
at any rate, i know a very common low boost issue is the small hose from the inter-cooler to under the throttle body....

gimme a minute i will give you a part number too....( i just replaced that hose on mine within the last week......

ÜRO PARTS 30637166

just take off the uro parts part and you can order it through autozone ( i am in the usa, btw .....

most parts places can get it that way, with that part #

also, you have the same ignition coil connector issues that they all seem to get ????

if so,i made a different post to another user about that.......



Post Reply