IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Difficulty during cold starts - 02 v40

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.

1996 - 2004 S40
1996 - 2004 V40

Post Reply
creamedpossum
Posts: 3
Joined: Sat Jul 20, 2013 7:31 pm
Year and Model: v40 2002
Location: atlanta ga

Difficulty during cold starts - 02 v40

Post by creamedpossum »

Currently having an issue with a 2002 V40.

Only happens on cold starts. As key is turned engine turns over quickly and starts but idles very rough and misses. If you give it just a little throttle and bring up the RPMs slowly to 1500-2000 it smooths right out and is fine. It continues running and can go on your way. No issues on hot starts.

Only codes that have popped up are misses on cylinders 1-3. I've replaced the coils, plugs, and wires. But hasn't fixed the issue. I also turn the key on and let fuel pump run till it stops (3-4) seconds, then crank, but still same issue.

What should I be looking for next? My searching the various forums is bringing up fuel pressure regulator, Idle air control, and MAP sensor. Any way to test to which it could be rather than just replacing parts as a guess?
User avatar
alschnertz
Posts: 643
Joined: Fri Apr 29, 2011 9:25 am
Year and Model: 1995 854T
Location: Connecticut
Has thanked: 2 times
Been thanked: 9 times

Re: Difficulty during cold starts - 02 v40

Post by alschnertz »

How many miles? How often has it been serviced?

I'd start with cleaning the Idle Air Control Valve (IAC), the Mass Airflow Sensor (MAF) very carefully with MAF sensor spray cleaner - do not scrub the wires with anything and then the throttle body.

My suspicion is that you have a dirty IAC and throttle body.
'60 PV544, '68 220, '70 145S, '86 745T, '95 854T, '01 S40
'84 Prelude
'06 MPV
'13 Ford Focus SE
creamedpossum
Posts: 3
Joined: Sat Jul 20, 2013 7:31 pm
Year and Model: v40 2002
Location: atlanta ga

Re: Difficulty during cold starts - 02 v40

Post by creamedpossum »

It's got 115k on it. It's been gone through and had all the seals, timing belt, and water pump replaced in the past year or so. I'll check those out in the morning and see what I can find.
creamedpossum
Posts: 3
Joined: Sat Jul 20, 2013 7:31 pm
Year and Model: v40 2002
Location: atlanta ga

Re: Difficulty during cold starts - 02 v40

Post by creamedpossum »

So I went through and cleaned the IAC and the MAF sensor. Bother were pretty clean already, didn't notice any buildup or anything that looked alarming. This had zero change on the startup. Couple other things I've noticed. If I turn the key on and let the pump run till stops, and then give another 5-6 seconds, it seems like the problem is milder.
Also, codes p0351 and p0352 have come up. I noticed that when changing out the coils the wires (not the ones to the spark plug, the ones on the ECM side) that plug into the coil have had the insulators inside of them deteriorate over the years, so they contacts move around inside the socket. Is it possible to get the harness for this to replace? or can I buy the connectors and rewire myself?
jwalker275
Posts: 7
Joined: Mon Nov 19, 2018 5:10 pm
Year and Model: 02 s40
Location: PA

Re: Difficulty during cold starts - 02 v40

Post by jwalker275 »

i actually created my account just to help you and answer your question

" davebarton.com "

don't honestly know if i am allowed ( or not allowed ) to post a website recommendation
but i had to get my wires ( coil connectors from the ecu side under the black trim covers ) which feed my coils
the site above is where i was able to find the connectors i bought.
i think ( if i am remembering the purchase correctly ) i paid somewhere around $40 ish ( might have been less )

edit : just looked : kit is $30 plus $8.00 shipping
$38.00 total i believe
hope this is a help to you

also, if any moderators happen across this, it would be helpful to put this into a sticky in the faq section as i know it's a very common failure point with a hard to find resolution to.

also as another note here, the other volvo ( 5 cylinder models ) use a direct " coil on each plug " style, and these connectors are easier to find.

just my .02 cents worth
Post Reply
  • Similar Topics
    Replies
    Views
    Last post