MVS Moderator donation week is here! Show the moderators you appreciate their help.
IPD sale Volvo Parts

Dimly lit message light/no high beams

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
Post Reply
Headsup
Posts: 9
Joined: Sat Jan 20, 2018 8:57 am
Year and Model: 2003 v70; 2001 v70;
Location: Ontario
Canada

Dimly lit message light/no high beams

Post by Headsup » Tue Dec 04, 2018 7:56 pm

Hi again,
Like my previous post, I have searched and read but have not found much on another issue with my more than faithful long time driver 2001 v70 non turbo.

Upon start up, it takes a moment for the dash lights to come on, however, the lower message lights are very dim and I cannot activate high beams. (Yes I know about the switch position).
Here's the rub- once in a while the message light WILL operate as they should (and can be seen) and at that time I CAN activate the high beams.
Yes intermittent stuff.
Just thought I'd see if anyone around here might have any insight regarding this or my previous post-no they are not related.

User avatar
shiloh51933
Posts: 818
Joined: Fri Mar 05, 2010 7:12 pm
Year and Model: 04 XC70/'98 V70XC
Location: New York
Has thanked: 3 times
Been thanked: 2 times
United States of America

Re: Dimly lit message light/no high beams

Post by shiloh51933 » Fri Dec 07, 2018 8:22 am

Sounds like you dash cluster needs to be replaced possibly but obviously you need to check out wiring back of cluster to power source/ground. Have you verified that high beam aren't physically working? I mean get out the car and check, just because high beam icon isn't illuminated on dash doesn't mean it doesn't work.










]
If U Wanna Play U Gotta Pay!!

Headsup
Posts: 9
Joined: Sat Jan 20, 2018 8:57 am
Year and Model: 2003 v70; 2001 v70;
Location: Ontario
Canada

Re: Dimly lit message light/no high beams

Post by Headsup » Fri Dec 07, 2018 9:50 am

Thanks much, As I mentioned it's intermittent .
and yes when I drive at night I can usually tell when Hi beams are on, in this case I have to hold the lever when the issue is present.
And I suspect a weird ground short some-where as well.
It's a tad cold to go looking for it, so I suspect I'll just tough it out for now.
No biggie for sure, thanks again.

User avatar
shiloh51933
Posts: 818
Joined: Fri Mar 05, 2010 7:12 pm
Year and Model: 04 XC70/'98 V70XC
Location: New York
Has thanked: 3 times
Been thanked: 2 times
United States of America

Re: Dimly lit message light/no high beams

Post by shiloh51933 » Fri Dec 07, 2018 6:43 pm

Headsup wrote:
Fri Dec 07, 2018 9:50 am
Thanks much, As I mentioned it's intermittent .
and yes when I drive at night I can usually tell when Hi beams are on, in this case I have to hold the lever when the issue is present.
And I suspect a weird ground short some-where as well.
It's a tad cold to go looking for it, so I suspect I'll just tough it out for now.
No biggie for sure, thanks again.
Check high beam relay and dash headlight knob.
If U Wanna Play U Gotta Pay!!

Post Reply

Who is online

Users browsing this forum: LOB and 35 guests