Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

Bad Alternator?

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive P2 platform cars sold as model years 2001-2007 (North American market year designations).

2001 - 2007 V70
2001 - 2004 V70 XC (Cross Country)
2004 - 2007 XC70 (Cross Country)
2001 - 2009 S60
2003 - 2007 S60 R
2004 - 2007 V70 R

Post Reply
User avatar
Biggertuna
Posts: 27
Joined: Mon Mar 16, 2020 5:27 pm
Year and Model: 2003 V70 2.4
Location: TX
Has thanked: 12 times

Bad Alternator?

Post by Biggertuna »

Hi everyone - I have an issue with my '03 V70 NA (180K miles) that I'm hoping is just the alternator.
While driving today, A/C shutoff, speedometer stopped working, and both ABS and battery lights illuminated on the dash. After 20 seconds, A/C came back, ABS light shutoff, speedometer started to work, but battery light stayed illuminated. Message on the dash read: "EL. Powersystem, Service Required".

Recently replaced the battery about 3 months ago (previous was 7 years old and started to smell like sulphur). OBD shows no fault codes and quick battery test showed ~12.5 V on the battery after starting. Belt and tensioner look ok as well (both replaced about 5 months ago).

This all leads me to believe it's the alternator (which is the original). Is there anything else I should check before starting this replacement?
Thanks in advance.

Blacklab467
Posts: 321
Joined: Tue Aug 09, 2016 4:25 pm
Year and Model: 2003 xc 70
Location: Calgary, AB
Has thanked: 14 times
Been thanked: 28 times

Post by Blacklab467 »

I just had that problem in my '03. Test the alternator voltage at the B+ terminal on the back of the alternator, you can reach it with a multimeter probe. Should be 14 - 14.5.
I would replace with an OEM unit either new or from an autowrecker depending on your budget. Don't buy an aftermarket part and expect it to work for long. It's pretty east to change, look up a video on YouTube. Remove the radiator fan and pull it out the top.
2003 XC 70, 2007 Duramax LBZ.

User avatar
Biggertuna
Posts: 27
Joined: Mon Mar 16, 2020 5:27 pm
Year and Model: 2003 V70 2.4
Location: TX
Has thanked: 12 times

Post by Biggertuna »

Multimeter came back with a reading of 11.97V from the B+ terminal. Bad alternator indeed.

User avatar
oragex
Posts: 5329
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 102 times
Been thanked: 336 times
Contact:

Post by oragex »

Yes, if that's voltage with the engine running it means the alternator does not charge and you are only reading battery voltage. Be sure to get your correct regulator number, look up on youtube and Fcpeuro

User avatar
Biggertuna
Posts: 27
Joined: Mon Mar 16, 2020 5:27 pm
Year and Model: 2003 V70 2.4
Location: TX
Has thanked: 12 times

Post by Biggertuna »

Correct, that was the reading with the engine running.

Contacted FCPEuro since I could only find the voltage regulator model (8676498) on my alternator.
Based on my VIN, my vehicle requires the140A (36050262) alternator

Georgeandkira
Posts: 835
Joined: Tue Apr 07, 2009 8:24 am
Year and Model: 2007 V70 base
Location: Hudson & Champlain Valleys, USA
Has thanked: 27 times
Been thanked: 56 times

Post by Georgeandkira »

FYI: I didn't need to remove the fan to get my '02's alternator out. It was straightforward and relatively easy.

A local rebuilder fixed me up.

Post Reply