IPD sale Volvo Parts

Blower motor or resistor (controller) bad? RESOLVED

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
Post Reply
kjhiggins
Posts: 37
Joined: Wed Sep 02, 2009 2:14 pm
Year and Model: XC70 2004, V70 1998
Location: Boston

Blower motor or resistor (controller) bad? RESOLVED

Post by kjhiggins » Sat Sep 11, 2010 4:17 pm

I have a 2004 XC70 and the blower stopped working suddenly last week. I've seen many posts here about this problem but none that address how exactly to test whether it is the motor or the resistor/controller (it has ECC). I've removed the motor and controller pack following instructions here and when I connected the motor directly to the battery in my other car and it seemed to work just fine. When I reconnected the controller to the four prong plug under the dash and check the output to the fan at the two prong connector I get a steady 12 V regardless of whether the fan switch is on or not, and even if the key isn't even in the ignition. If I then plug the fan back into the controller it doesn't spin and I get 0 V at the fan terminals. I suspect it is the controller that is bad but I'd like to be certain before I go out and get a new one. Any suggestions as to how to definitively test it? Thanks.
Last edited by kjhiggins on Tue Sep 14, 2010 7:39 pm, edited 1 time in total.



ed7
Posts: 205
Joined: Fri Sep 03, 2010 3:32 am
Year and Model: V70XC 2001, 1998
Location: Lansing, Michigan
United States of America

Re: Blower motor or resistor (controller) bad?

Post by ed7 » Sat Sep 11, 2010 8:47 pm

I gotta say it... did you check the fuse?
Three fuse boxes confuses things a bit, I know.
I think it's #26 on the left end of the dash.
I've found the fan will work on High only if the resistor's bad.
Also the ground point behind the passenger side kick panel could be bumming.
You've conclusively ruled out the fan. Onward...
ED7



kjhiggins
Posts: 37
Joined: Wed Sep 02, 2009 2:14 pm
Year and Model: XC70 2004, V70 1998
Location: Boston

Re: Blower motor or resistor (controller) bad?

Post by kjhiggins » Sat Sep 11, 2010 10:34 pm

Thank you for the response. Yes, I did check the fuse and it looked good but I replaced it with the spare anyway. The fan doesn't work on any setting in the car, either on 'auto' or manually adjusting the fan speed. Does anyone know how the fan output from the controller varies with fan speed setting? As I mentioned, with the fan disconnected I get a steady 12 V measured across the two prongs of connector on the controller, and it doesn't matter if the ignition is on or if the key isn't even in the ignition.



kjhiggins
Posts: 37
Joined: Wed Sep 02, 2009 2:14 pm
Year and Model: XC70 2004, V70 1998
Location: Boston

Re: Blower motor or resistor (controller) bad? RESOLVED

Post by kjhiggins » Tue Sep 14, 2010 7:40 pm

Turns out it was the power unit/resistor that was bad, as suspected. It's all back together and running fine.



goldmandan
Posts: 189
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Sweden

Re: Blower motor or resistor (controller) bad? RESOLVED

Post by goldmandan » Sat Aug 30, 2014 8:54 pm

Where is the power unit/resistor located on the 04-05? how does it look like? I would like to know so I can resolve my fan motor running on high all the time

Dan



DGM
Posts: 459
Joined: Thu Dec 23, 2010 5:20 am
Year and Model: V70 2.4i 2005
Location: Quebec, Canada

Re: Blower motor or resistor (controller) bad? RESOLVED

Post by DGM » Sun Aug 31, 2014 5:11 am

goldmandan wrote:Where is the power unit/resistor located on the 04-05? how does it look like? I would like to know so I can resolve my fan motor running on high all the time

Dan
Read the following, it will answer your questions.

http://www.matthewsvolvosite.com/forums ... =9&t=21343


V70 2005 2.4i 195,000km, sold
S70 1998 T5 355,000km, sold
960 1994 80,000km, sold
760 1990 Turbo 265,000km, sold

Thames
Posts: 23
Joined: Tue Oct 04, 2011 7:07 am
Year and Model: 2007 V70, 2005 XC70
Location: Quebec, Canada

Re: Blower motor or resistor (controller) bad? RESOLVED

Post by Thames » Tue Jan 13, 2015 10:00 am

HI guys, having the same issue here on a 2005 XC70. Can we test the resistor pack ?

Moreover, about 10 days ago, I removed the blower to give it a good cleaning (blower was noisy). It worked flaslessly until today...


Now member of the Wagon Mafia!
V70 '07 "The V"
XC70 '05 "Grizzly"
----------------------
S70 '99 LPT "Blackie" -- departing soon
S70 '98 NA "Pearly" -- SOLD
740 '90 B230F "Rusty" -- SOLD
and some Gibson, Fender, Marshall,... but it's another thing... !!

adrian22
Posts: 104
Joined: Fri Jul 16, 2004 4:29 pm
Year and Model: s60 2006
Location: florida
Aruba

xc 70 2006 Blower motor or resistor/relay (controller) bad?

Post by adrian22 » Fri Aug 12, 2016 8:03 am

XC70 2006 blower motor is not working when I started the car after one week in the garage.
1. checked fuse #3 on the LH dashboard- is good
2 checked fuse #10 Instrument panel, climate system, power driver's seat-is good
Question :do you know if there is Volvo xc70 Blower Motor Relay or other fuse responsible for blower motor?
I know the motor has included in the same unit a speed controller but if I understand correctly if the controller is bad the blower will make some move or noise/hum?


adrian22

Post Reply

Who is online

Users browsing this forum: mrbrian200 and 33 guests