IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

05 S60 2.5T AWD: P0700 "Transmission Control System (MIL Request)", P0600 "Serial Communication Link", P0503 "Vehicle Sp

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

psamanni
Posts: 5
Joined: Sat Dec 12, 2015 4:39 pm
Year and Model: 2005 S60 2.5T AWD
Location: USA
Has thanked: 0
Been thanked: 0
psamanni

05 S60 2.5T AWD: P0700 "Transmission Control System (MIL Request)", P0600 "Serial Communication Link", P0503 "Vehicle Sp

Post by psamanni » Sun Jan 10, 2016 4:11 pm

Hi all, if you remember from a previous thread, I previously had a set of warning and error messages thrown at me ("immobilizer, see manual", "transmission service required", "engine system service required"), on a dying battery. I was fine until last night, when, as I downshifted to 4th gear, I got "Anti-skid service required", immediately followed by the RPM counter falling to 0, and "Transmission service required". At that point, the transmission was stuck in 4th, then I got the "-", before the transmission got back to "D" 5mn later, and the Check engine light came up.

Over the last few months, the "Anti-skid service required" and "Brake assist service required" warnings have come on and off, intermittently. I had figured changing the right front half-CV axle in October would take care of this, and it seemed to for a while, but no. The car drives perfectly fine.

The error codes I got from my Android app are: P0070 "Transmission Control System (MIL Request)", P0060 "Serial Communication Link", P0503 "Vehicle Speed Sensor Intermittent/Erratic/High".

Any idea/suggestion is highly appreciated, thanks!

psamanni
Posts: 5
Joined: Sat Dec 12, 2015 4:39 pm
Year and Model: 2005 S60 2.5T AWD
Location: USA
Has thanked: 0
Been thanked: 0
psamanni

Re: 05 S60 2.5T AWD: P0700 "Transmission Control System (MIL Request)", P0600 "Serial Communication Link", P0503 "Vehicl

Post by psamanni » Sun Jan 10, 2016 4:13 pm

Hi all, if you remember from a previous thread, I previously had a set of warning and error messages thrown at me ("immobilizer, see manual", "transmission service required", "engine system service required"), on a dying battery. I was fine until last night, when, as I downshifted to 4th gear, I got "Anti-skid service required", immediately followed by the RPM counter falling to 0, and "Transmission service required". At that point, the transmission was stuck in 4th, then I got the "-", before the transmission got back to "D" 5mn later, and the Check engine light came up.

Over the last few months, the "Anti-skid service required" and "Brake assist service required" warnings have come on and off, intermittently. I had figured changing the right front half-CV axle in October would take care of this, and it seemed to for a while, but no. The car drives perfectly fine.

The error codes I got from my Android app are: P0070 "Transmission Control System (MIL Request)", P0060 "Serial Communication Link", P0503 "Vehicle Speed Sensor Intermittent/Erratic/High".

Any idea/suggestion is highly appreciated, thanks!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post