IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

ECM-400C Three-way catalytic converter efficiency

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Pittsjock
Posts: 14
Joined: Sun Dec 13, 2015 6:39 am
Year and Model: 2007 XC70
Location: NJ
Has thanked: 0
Been thanked: 0
United States of America
Pittsjock

ECM-400C Three-way catalytic converter efficiency

Post by Pittsjock » Sun Apr 03, 2016 5:46 am

Gents:

The wife took her 2007 XC70 (195k) to get inspected and failed to mentioned to me prior that the CEL had just gone on. The car failed. :shock:

The car has had recent PCV service, a cleaned oil pan/sump and runs nicely. Gas mileage is reasonable for use at around 22 (mostly short trips at less than 50 mph). Gas mileage pops up to 23-24 on highway. The car has a little oil leak that I am chasing, but I don't think burns much oil.

I pulled the codes with VIDA and got ECM-400C Three-way catalytic converter efficiency, bank 1, Signal too high. There are no other codes on the car.

Both oxygen sensors are giving readings and based on my research, seem to be within spec. The front is ranging from around 1 to 15 and the rear is cycling between about .16 and .99.

Anyone have any suggestions for the next level of diagnostics? The car is pretty high mileage at this point - 195k, so I guess the catalytic converter could be toast, although this does not seem to be a common failure.
2007 XC70 w/195k/owned since new (#1)
2007 XC70 w/140k/owned since 129k (#2)
Texan in the Peoples Republic of New Jersey

JRL
Posts: 9351
Joined: Tue Nov 22, 2005 2:07 pm
Year and Model: Several
Location: 19333
Has thanked: 0
Been thanked: 12 times
United States of America
JRL

Re: ECM-400C Three-way catalytic converter efficiency

Post by JRL » Sun Apr 03, 2016 7:46 am

Read my reply on XC70.com
2000 V70R Black, 144,000 miles Wife's R.
2007 V70 2.5T White/Oak 111,000 MILES. Polestar tune, IPD bars, rear spoiler, dark grey Thors, DWS 06, HU850, sub.

Contact info for purchases: [email protected]

User avatar
abscate
MVS Moderator
Posts: 20447
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 284 times
Been thanked: 896 times
Trinidad & Tobago
abscate

Re: ECM-400C Three-way catalytic converter efficiency

Post by abscate » Sun Apr 03, 2016 7:56 am

Clear code, drive for a week, res test and pass. Unless the code comes on back in 200 or fewer miles, use this to pass smog until car EOL
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Pittsjock
Posts: 14
Joined: Sun Dec 13, 2015 6:39 am
Year and Model: 2007 XC70
Location: NJ
Has thanked: 0
Been thanked: 0
United States of America
Pittsjock

Re: ECM-400C Three-way catalytic converter efficiency

Post by Pittsjock » Sun Apr 03, 2016 8:02 am

Thanks Abscate, but the code comes back too quickly because some test is not completing. I think this points to a sensor/wiring/circuit type issue...?
2007 XC70 w/195k/owned since new (#1)
2007 XC70 w/140k/owned since 129k (#2)
Texan in the Peoples Republic of New Jersey

User avatar
abscate
MVS Moderator
Posts: 20447
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 284 times
Been thanked: 896 times
Trinidad & Tobago
abscate

Re: ECM-400C Three-way catalytic converter efficiency

Post by abscate » Sun Apr 03, 2016 8:20 am

If it can't complete the O2 sensor test ,I would check wiring and for 12 VDC on the heater

This should show up as a different code than cat efficiency though
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Pittsjock
Posts: 14
Joined: Sun Dec 13, 2015 6:39 am
Year and Model: 2007 XC70
Location: NJ
Has thanked: 0
Been thanked: 0
United States of America
Pittsjock

Re: ECM-400C Three-way catalytic converter efficiency

Post by Pittsjock » Sun Apr 03, 2016 8:23 am

No other codes...???? I will check wiring.....TY!
2007 XC70 w/195k/owned since new (#1)
2007 XC70 w/140k/owned since 129k (#2)
Texan in the Peoples Republic of New Jersey

JDS60R
MVS Moderator
Posts: 3531
Joined: Sat Feb 21, 2009 7:52 pm
Year and Model: 2007 S60R 2007 S60
Location: Mount Juliet, TN
Has thanked: 0
Been thanked: 0
United States of America
JDS60R

Re: ECM-400C Three-way catalytic converter efficiency

Post by JDS60R » Sun Apr 03, 2016 4:15 pm

front is an A/F sensor -little diff from O2 but same principals apply.

The front s happy at 1 I am assuming you meant 1.5 vs (15) in your post. If it is 15 we have an issue. (should never go over 5) Would also like to know it goes below 1 every once in a while. If VIDA says sig to high and you are seeing 15 then you know what to replace. Sensors are on sale on ebay amazon FCP right now for about $86. I always buy and install both front and rear as they both add to controlling fuel trim

The rear should run .6 on level ground ,steady state ( like 45 mph on flat road with cruise control on.
Masterworks Complete Auto Services
Volvo Spoken Here !!!
100 Park Circle
Old Hickory, TN 37138

Pittsjock
Posts: 14
Joined: Sun Dec 13, 2015 6:39 am
Year and Model: 2007 XC70
Location: NJ
Has thanked: 0
Been thanked: 0
United States of America
Pittsjock

Re: ECM-400C Three-way catalytic converter efficiency

Post by Pittsjock » Sun Apr 03, 2016 4:58 pm

JDS60R wrote:The front s happy at 1 I am assuming you meant 1.5 vs (15) in your post. If it is 15 we have an issue.

The rear should run .6 on level ground ,steady state ( like 45 mph on flat road with cruise control on.
Thanks JDS. So, I did mean 15....mostly it is hovering between 1 and 5, but if you run the engine up to 2.5 to 3k rpms, and then let off the throttle, it will spike up and then return to the lower numbers.

If you watch the rear sensor in VIDA, it goes from .1 to .9 or so in a pretty steady up and down. From what I read, this is normal?

I inspected both the front and rear sensors and did not see anything particularly abnormal. For some reason, the code cleared and the CEL went off this afternoon. It also cleared in VIDA and the DTC test came up green.

I need to do a bit of maintenance on this car anyway so it sounds like new O2 sensors (front and back) are in order.

Thanks again for the help!
2007 XC70 w/195k/owned since new (#1)
2007 XC70 w/140k/owned since 129k (#2)
Texan in the Peoples Republic of New Jersey

Post Reply
  • Similar Topics
    Replies
    Views
    Last post