IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Stereo Static on a loop

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Post Reply
melbaz
Posts: 8
Joined: Tue Jun 14, 2016 12:45 pm
Year and Model: 2007 S60 T AWD
Location: seattle

Stereo Static on a loop

Post by melbaz »

Hi Guys ,
I just bought a 2007 S60T awd . I'm trying to fix a problem with the sound system. There is a static loop on the stereo , it cuts out whatever is playing for like a second , it does it even when the stereo is turned off and it does it at very regular intervals, maybe every 10 seconds.
I pulled the amp out from underneath the passenger seat , i was going to just buy a new one and replace it but wanted to see what you guys think / suggest

Thanks a ton !
nsjames
Posts: 115
Joined: Fri Jan 29, 2016 8:50 am
Year and Model: 04 XC70
Location: ohio

Re: Stereo Static on a loop

Post by nsjames »

does it play cleanly and then cut out?
I'd suspect a mosfet that fails and then comes back to life.
melbaz
Posts: 8
Joined: Tue Jun 14, 2016 12:45 pm
Year and Model: 2007 S60 T AWD
Location: seattle

Re: Stereo Static on a loop

Post by melbaz »

yeah it plays fine then cuts out at very precise intervals , i plan on replacing the amp first n see if that fixes it
melbaz
Posts: 8
Joined: Tue Jun 14, 2016 12:45 pm
Year and Model: 2007 S60 T AWD
Location: seattle

Re: Stereo Static on a loop

Post by melbaz »

Okay , So I tried replacing the amp and it did not work. I finally replaced the HU 850 I have in it and that seemed to fix it.
However the bummer is that it seems the new HU 850 does not support my AUX input , does anybody know how to fix/solution for that ? When i scroll through the sources AUX is not in the list.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post