IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

V70 Crankshaft Position Sensor Problems

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

thefryeguy
Posts: 10
Joined: Tue Aug 24, 2010 7:51 am
Year and Model: 2003 V70
Location: Kansas
Has thanked: 0
Been thanked: 0
United States of America
thefryeguy

V70 Crankshaft Position Sensor Problems

Post by thefryeguy » Thu Sep 29, 2016 3:53 pm

As long as I have been a lurker in the forums, learning as I go, now I need to solicit some direct advice. I have a 2003 V70 with the 2.4T. I bought the car with about 148k on it and it has about 171k now. Besides the thing nickle and diming me on bulbs and spring seats, I have had pretty good luck with it in the two years I've owned it.

Months ago, it started to occasionally be hard starting, usually when hot. Sometimes the tach would jump wildly while cranking. I lived with it until last week when it got more regular and worse. I figured it was probably related to the crank position sensor, so I went to remove it. When I started to undo the nut, the bracket disintegrated (it might have actually been broken already). I ordered a new Volvo bracket (30637803) and installed it.

I installed the old crank position sensor and and tried to start the car. It started right up, but ran rough as hell. I shut it down and double checked all my connections. I also charged up the battery fully just in case that was related. The P0337 code was set. So, I ordered a new crank position sensor, a Beck Arnley 180-0492, and installed it.

With the new sensor in place and codes cleared, the car again started right up. This time it did not immediately run rough or set a code. I pulled out of the driveway for a test drive, but when I got above 1500 rpm the lights went off again for reduced engine performance, P0337. I drove around for a while and the car ran reasonably well with the trouble light resetting itself if I idled around long enough. But, if I got on it again at all it would set off the triangle.

I have checked over about everything I can think of and it will keep setting the code. I even tried the sensor off my my wife's 2005 XC90, but it behaved the same as the 'old' sensor from the V70. It seems odd to me that the old OEM Denso sensors both make it run really badly, but the new Beck Arnley only exhibits part of the problem.

I have noticed that in park or neutral, as I press the accelerator up the tach rises smoothly until about 1500 rpm. Above that, it kind of jerks/bounces up irregularly.

I would appreciate any and all advice or ideas. I spent a good amount of time with the parts and service departments at my 'local' Volvo dealer (3 hours away), to no avail. This is the fifth Volvo I've had, but this problem is new to me!

beigg
Posts: 691
Joined: Sun Sep 22, 2013 9:07 am
Year and Model: 850 97
Location: Est. Mi
Has thanked: 0
Been thanked: 0
Uruguay
beigg

Re: V70 Crankshaft Position Sensor Problems

Post by beigg » Thu Sep 29, 2016 4:36 pm

make sure you dont have a sensor meant for an 01' . Pretty sure 02 and 03 only interchange.
ugh smh 850 Turbo fridge

thefryeguy
Posts: 10
Joined: Tue Aug 24, 2010 7:51 am
Year and Model: 2003 V70
Location: Kansas
Has thanked: 0
Been thanked: 0
United States of America
thefryeguy

Re: V70 Crankshaft Position Sensor Problems

Post by thefryeguy » Thu Sep 29, 2016 4:43 pm

That's an interesting thought. But wouldn't one of the two OEM ones work still? Thanks for the input.

beigg
Posts: 691
Joined: Sun Sep 22, 2013 9:07 am
Year and Model: 850 97
Location: Est. Mi
Has thanked: 0
Been thanked: 0
Uruguay
beigg

Re: V70 Crankshaft Position Sensor Problems

Post by beigg » Thu Sep 29, 2016 4:50 pm

oem XC used for a V70 replacement? i wouldnt rely on that testing.
ugh smh 850 Turbo fridge

thefryeguy
Posts: 10
Joined: Tue Aug 24, 2010 7:51 am
Year and Model: 2003 V70
Location: Kansas
Has thanked: 0
Been thanked: 0
United States of America
thefryeguy

Re: V70 Crankshaft Position Sensor Problems

Post by thefryeguy » Thu Sep 29, 2016 4:54 pm

That's a good point, but it's the same identical sensor as the OEM Volvo one from the V70. So, shouldn't ONE of them work? Legit idea though. That's why I'm here because there could be something obvious I'm missing.

Timbo959
Posts: 3
Joined: Fri Sep 29, 2017 6:51 pm
Year and Model: 02 zc70
Location: Michigan
Has thanked: 0
Been thanked: 0
United States of America
Timbo959

Re: V70 Crankshaft Position Sensor Problems

Post by Timbo959 » Fri Sep 29, 2017 7:03 pm

Freyeguy
Did you ever resolve the crank sensor issue
I have an xc70 that exhibits the same Condition as yours
Did you ever figure it out
I would appreciate your thoughts

thefryeguy
Posts: 10
Joined: Tue Aug 24, 2010 7:51 am
Year and Model: 2003 V70
Location: Kansas
Has thanked: 0
Been thanked: 0
United States of America
thefryeguy

Re: V70 Crankshaft Position Sensor Problems

Post by thefryeguy » Sat Sep 30, 2017 9:15 am

I DID figure it out. The mounting bracket for the sensor was not seating correctly. I had trouble getting it cinched down because of the difficult location and in doing so got it maybe a 1/16" off kilter. Once I cleared room to get a better look and took my time getting it tightened down perfectly, the problem went away.

Timbo959
Posts: 3
Joined: Fri Sep 29, 2017 6:51 pm
Year and Model: 02 zc70
Location: Michigan
Has thanked: 0
Been thanked: 0
United States of America
Timbo959

Re: V70 Crankshaft Position Sensor Problems

Post by Timbo959 » Sat Sep 30, 2017 12:58 pm

Wow good for you
I will check this out

Timbo959
Posts: 3
Joined: Fri Sep 29, 2017 6:51 pm
Year and Model: 02 zc70
Location: Michigan
Has thanked: 0
Been thanked: 0
United States of America
Timbo959

Re: V70 Crankshaft Position Sensor Problems

Post by Timbo959 » Sat Sep 30, 2017 7:38 pm

Fryeguy
I can't thank you enough but it appears to be fixed
I did the same as you unbolted sensor and bracket, reset and it works
Plan to out car back together in a few days and drive it
Thx very much

thefryeguy
Posts: 10
Joined: Tue Aug 24, 2010 7:51 am
Year and Model: 2003 V70
Location: Kansas
Has thanked: 0
Been thanked: 0
United States of America
thefryeguy

Re: V70 Crankshaft Position Sensor Problems

Post by thefryeguy » Sat Sep 30, 2017 11:30 pm

Great! I hope that turns out to be a fix for you!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post