IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Henning2710
Posts: 5
Joined: Mon Jan 02, 2017 9:12 pm
Year and Model: 2001S60
Location: Holland, MI
Has thanked: 0
Been thanked: 0
United States of America
Henning2710

Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Henning2710 » Tue Jan 03, 2017 7:43 am

Hello Forum Members,

I searched the forum to find a solution, but no such luck, so if after reading the following you remember someone else posting a similar problem, please let me know.

I have a 2001 S60 with the base 2.4i engine. Over the last year or so the car started to idle rough and stall occasionally when the engine was warm. Since I really only drive this to work and back (about 6 miles each way) the engine most of the time did not get hot enough to have the issues for the longest time.

In November it finally started showing this behavior before I could make it to work or home, so after reading through the forums I decided to replace the ETM. I used a re-manufactured ETM from Volvo that I bought through a dealership.

After replacing the ETM the engine would run much better, but still stall when the car was stopped and I applied throttle to go again. I managed to drive it to the nearest Volvo dealership where they checked it over and read the codes. After updating the software on the ETM all they kept getting was a fault code for the MAF.

I bought a Denso MAF and put it in in the dealerships parking lot. When I started the car it ran just fine and seemed to correctly decrease RPMs as the car had been running for a moment. Thinking that everything was fine I set off. At the first turn after about a minute of driving the car stalled when I wanted to start going after sitting at a red light.

I made it home and disconnected the battery in the hope of the ECU resetting and solving the problem. No such luck. When I started for a test drive I didn't even make it down my driveway before the car stalled when I stopped after I backed out of may garage to turn around.

With the ETM and MAF replaced, the engine still goes rev hunting just to eventually die without any input from me. It also stalls when applying throttle after a standstill or when put into park after stopping. I'm all out of ideas at this point and thankful for any helpful comments.

Thanks,
Henning

Vovo_merz
Posts: 140
Joined: Mon Dec 08, 2014 10:32 am
Year and Model: 2007 s60R
Location: ohio
Has thanked: 0
Been thanked: 0
Ukraine
Vovo_merz

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Vovo_merz » Fri Jan 06, 2017 5:26 am

if possible to run the codes again do that if it still comes back as MAF, check your wiring for the sensor. its also possible you got a defected MAF sensor
hope this helps
1995 - 850 1st
1995-97 - 850 R 3 Black, Red, Yellow
2000-04 - $40 (4)
2005-06 - $80 (8)
2001-09 - $60 (38)
2005 xc90 (2)
2001 xc70 (wifes first car)
2001-07 v70 (5)

2007 $60R (2)
2008 XC90 sport V8
1998 Merz $500 custom
2009 Merz $550
2013 chevy 2500HD

Henning2710
Posts: 5
Joined: Mon Jan 02, 2017 9:12 pm
Year and Model: 2001S60
Location: Holland, MI
Has thanked: 0
Been thanked: 0
United States of America
Henning2710

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Henning2710 » Fri Jan 06, 2017 7:06 pm

Thanks for the tip. I'll get it back to the dealership when the roads are clear and have them read the codes again. I'll ask them for a printout this time.

Henning2710
Posts: 5
Joined: Mon Jan 02, 2017 9:12 pm
Year and Model: 2001S60
Location: Holland, MI
Has thanked: 0
Been thanked: 0
United States of America
Henning2710

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Henning2710 » Fri Jan 06, 2017 7:08 pm

Also, I noticed it now has the same problem when the engine is cold as well.

User avatar
abscate
MVS Moderator
Posts: 21538
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 337 times
Been thanked: 1037 times
Trinidad & Tobago
abscate

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by abscate » Sat Jan 07, 2017 4:16 am

You've got a large vacuum leak somewhere based on symptoms. You either remove all the hoses to inspect or smoke test the engine to find it.

When were plugs and coils last serviced? Are they as old as Noah's toes?
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

enriquepr21
Posts: 51
Joined: Tue Nov 15, 2016 8:58 pm
Year and Model: 2003 S60
Location: Guatemala
Has thanked: 0
Been thanked: 0
Guatemala
enriquepr21

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by enriquepr21 » Sat Jan 07, 2017 1:31 pm

My car was also stalling randomly when braking to a stop (2003 S60 base engine) it turned out the hose on the map sensor was disconnected from the engine vaccum point, and it doesn't stall now plus it runs much better. Might be worth it to check vaccum leaks

Henning2710
Posts: 5
Joined: Mon Jan 02, 2017 9:12 pm
Year and Model: 2001S60
Location: Holland, MI
Has thanked: 0
Been thanked: 0
United States of America
Henning2710

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Henning2710 » Mon Jan 16, 2017 6:13 am

I did bring it back to the dealership Last week. Just before I got there the CEL came on. It died several times on the way; every time had to stop.

I told them no rush, so I haven't heard anything yet. I'll give an update when I have anything to report. Thanks for the help so far!

Henning2710
Posts: 5
Joined: Mon Jan 02, 2017 9:12 pm
Year and Model: 2001S60
Location: Holland, MI
Has thanked: 0
Been thanked: 0
United States of America
Henning2710

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by Henning2710 » Thu Jan 19, 2017 7:09 am

The Volvo is back and running great. Turns out one of the vacuum hoses had come loose (abscate and enriquepr21 called it) and the ECM programming was all messed up according to the service manager. Also the ETM that they had flashed the correct software on last time had the old software on it again, so they fixed that as well (I assume they must not have done that correctly last time). No charge last time, total bill this time $71. Not bad at all for a Volvo dealership.

User avatar
abscate
MVS Moderator
Posts: 21538
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 337 times
Been thanked: 1037 times
Trinidad & Tobago
abscate

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by abscate » Thu Jan 19, 2017 9:22 am

IMG_2029.jpg
IMG_2029.jpg (59.79 KiB) Viewed 2234 times
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

enriquepr21
Posts: 51
Joined: Tue Nov 15, 2016 8:58 pm
Year and Model: 2003 S60
Location: Guatemala
Has thanked: 0
Been thanked: 0
Guatemala
enriquepr21

Re: Experienced Stalling and Rough idle, Replaced ETM and MAF, still stalling when warm

Post by enriquepr21 » Thu Jan 19, 2017 10:37 am

Glad we were able to help!!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post