IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2002 XC70 reduced power mode - not ETM

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

KeithA
Posts: 20
Joined: Tue Jan 24, 2017 3:31 pm
Year and Model: 2005 XC70
Location: Morristown, TN
Has thanked: 0
Been thanked: 0
United States of America
KeithA

2002 XC70 reduced power mode - not ETM

Post by KeithA » Tue Jan 24, 2017 4:03 pm

OK, for about a week, I have been trying to fix this issue.
Codes are ECM - 903C permanent fault, 9150,9160,9170 permanent fault.
I replaced ETM, drove a few days and all was well.
Back to limp home mode and same codes.
relaced it again, checked connector plug and added very small amount of dielectric grease.
drove to work fine this morning, limp home mode coming home.
Today when it did it, I was on highway and hit a bump and went into limp mode. Don't know if bump had anything to do with it.
Freeze frame data had some weird numbers, coolant temp 87F, RPM 2080 (correct),speed 92mph, short,long fuel trim bank one 0/3, bank two 99/99. I had been driving about 10 minutes on highway at 60mph.
Live data shows everything working like it should. I don't see any faults as I watch it live.
Clearing codes, then it runs fine again. Though on the way home from work, it went into limp mode rough idle, I cleared the codes, smoothed out, but no power and would not go above 2000rpm, but ran smooth. If you touched the brake, accelerator pedal would do nothing when in gear.
Battery checks good, but has very little reserve. When car is running, voltage is in the 13 volt range. One one freeze frame, it showed 10.41 when it went to limp. Todays freeze frame showed 13.45.
Really scratching my head and need to get the car fixed. Any and all advice is appreciated.
I plan to check breather system tonight, I saw a service bulletin about it.
Does the replacement ETM need to be calibrated? I installed and it ran perfect.

I don't have history of the car. Bought it at auction late November and been getting it ready for my daughter. She flipped her 2006 XC70 and totaled the car, but not a scratch on her!! Volvo safety!!!

Keith
2001 V70 T5, 2002 XC70, rolled 2006 XC70, 2008 XC90, 2004 V70 sold, 2005 XC90 sold, 2003 S60 sold 1999 S70 sold, 1996 850 wagon that started it all, sold with 355K and running strong (lots of spare parts in the garage)

chrism
Posts: 997
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Has thanked: 0
Been thanked: 22 times
chrism

Re: 2002 XC70 reduced power mode - not ETM

Post by chrism » Tue Jan 24, 2017 7:51 pm

When it goes into Limp mode does it display "Reduced Engine Performance"?

KeithA
Posts: 20
Joined: Tue Jan 24, 2017 3:31 pm
Year and Model: 2005 XC70
Location: Morristown, TN
Has thanked: 0
Been thanked: 0
United States of America
KeithA

Re: 2002 XC70 reduced power mode - not ETM

Post by KeithA » Mon Jan 30, 2017 7:29 pm

Yes, it does. Sorry, I did not get a notice this was posted and had not seen your reply. Thanks.

chrism
Posts: 997
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Has thanked: 0
Been thanked: 22 times
chrism

Re: 2002 XC70 reduced power mode - not ETM

Post by chrism » Tue Jan 31, 2017 12:55 pm

I went through this nightmare with my wife's 2005 S80 2.5T. After cleaning the throttle module, inspecting the connector, and REPLACING the throttle module ($350), the problem turned out to be the connector underneath the ECM. Unlatching the ECM and reseating/relocking it fixed the problem.

KeithA
Posts: 20
Joined: Tue Jan 24, 2017 3:31 pm
Year and Model: 2005 XC70
Location: Morristown, TN
Has thanked: 0
Been thanked: 0
United States of America
KeithA

Re: 2002 XC70 reduced power mode - not ETM

Post by KeithA » Sat Feb 04, 2017 2:14 pm

Thanks, will check that too. I replaced the battery with new one and I found a tracking/immobilizer device under the dash. It was tied into ignition. I guess the finance company had it on there. I removed it. Driven a week now with it running perfect. Thanks for the replies! If the low power comes back. I'll continue the post.

precopster
Posts: 7475
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 108 times
Australia
precopster

Re: 2002 XC70 reduced power mode - not ETM

Post by precopster » Sat Feb 04, 2017 4:52 pm

Definitely reseat the ECM and clean the contacts with a toothbrush and contact cleaner.
Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post