IPD sale XeMODeX - Experts in Volvo Electronics Volvo modules repair and programming
Please use the MVS Amazon link when you buy anything at all! It helps this site. Thanks very much!

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Bamm
Posts: 10
Joined: Fri Mar 10, 2017 3:41 pm
Year and Model: 2002 V70
Location: Virginia

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by Bamm »

Strictly this issue. No other electrical gremlins have raised their heads yet. I apologize that I have thrown information around. Here's the clearest way I can give it to you.
All 2002 V70's.
Blue one, Green one, Silver one (parts donor), Black one (Parts donor).

Blue one - original dash works great. Green, Silver, Black dash clusters all fail.

Green one - Blue dash works great, all others fail.

Silver one - Silver dash works perfect. No others tested.

Black one - Black dash works fine. No others tested.
Bamm
Posts: 10
Joined: Fri Mar 10, 2017 3:41 pm
Year and Model: 2002 V70
Location: Virginia

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by Bamm »

Thank you all again for the thought/time helping me with this.
chrism
Posts: 1060
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Been thanked: 26 times

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by chrism »

I've been told that besides the part numbers needing to match, the donor car and receiver car need to be the same year. Not sure if like years are compatible if the transferred DIM was ever "rebuilt".

What we do know is that Bamm's car and his wife's car are the same year. Also, his DIM fails in both his car and his wife's car. Conversely, his wife's DIM performs well in both her car and his car. This tells me both cars' CEMs are OK and Bamms DIM is faulty.

My guess is that the donor DIM won't work in Mrs. Bamms car either. Admittedly I kinda got lost with the car color part.
User avatar
abscate
MVS Moderator
Posts: 22844
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 387 times
Been thanked: 1221 times

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by abscate »

The CANBUS stuff can be tough to troubleshoot. Appreciate that trouble With any unit in the chain can pop a problem in the DIM.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
IdahoBob
Posts: 96
Joined: Sun Jan 16, 2011 9:33 pm
Year and Model: XC70 02, 04 & 08
Location: Whitefish, Montana
Has thanked: 1 time
Been thanked: 2 times

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by IdahoBob »

In case anyone else is reading this, thinking of swapping out a dead DIM, the "650T" on that label IS the critical number to look for on a replacement. If that number is different (600T on several '01's I've seen, 660T on the '02's I've seen), the replacement DIM will probably not work at all.
Idaho Bob
67, 71, 85, 98 wagons (sold)
78 coupe (gave to mechanic, thanks!)
02, 04 (X2) & 08 XC70's
before that: 67 Sunbeam, several pre-68 VW's, '41 Buick, '42 Ford Jeep, and some boring stuff
Bamm
Posts: 10
Joined: Fri Mar 10, 2017 3:41 pm
Year and Model: 2002 V70
Location: Virginia

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by Bamm »

So, I went down to the local pick a part, found a 2002, $16 later installed the cluster in the parking lot. Everything works.......except the odometer and trip part. But at least I now know how fast I am going, engine temp and fuel level. Thanks for all the replies guys. Now to figure out the odometer/trip issue.
chrism
Posts: 1060
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Been thanked: 26 times

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by chrism »

"...Everything works.......except the odometer and trip part..."

Any chance it's just a burned out bulb(s) in that part of the display?
Bamm
Posts: 10
Joined: Fri Mar 10, 2017 3:41 pm
Year and Model: 2002 V70
Location: Virginia

Re: Gauges dead. Matched the part numbers, tried three different clusters. All the same. Help?

Post by Bamm »

Don't think so. Seems to be an issue related to swapping the dash clusters out. Sounding like I am going to have to bite the bullet and take it to a dealer to remedy that and turning off the air bag service light that came on after the swap as well.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post