IPD sale Volvo Parts

Part # Help: fan/blower that cools ECM box

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
Post Reply
carboncow
Posts: 593
Joined: Fri Jun 11, 2010 5:53 pm
Year and Model: 2003 XC70 2018 S60
Location: Central Ohio
Christmas Island

Part # Help: fan/blower that cools ECM box

Post by carboncow » Wed Apr 18, 2018 5:37 pm

I think half the reason our ECM got nuked was I just determined that little fan is not working. Anyone got a part number?


Shawn F.

2001 V70 T5
2003 XC70
1996 Vw Passat Tdi
1999 Porsche Boxster
2004 Chevy Suburban LT 5.3L
2013 & 2015 S60 T5
2008 Vw Touareg T2 V6

1989 Sea Ray 340 Sundander
2007 Sea Doo Challenger 180 SE

User avatar
oragex
Posts: 3498
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 61 times
Been thanked: 77 times
Contact:
Canada

Re: Part # Help: fan/blower that cools ECM box

Post by oragex » Wed Apr 18, 2018 7:07 pm

Do you know why it isn't working? I would not expect this to fail but they do get a little stuck. Try kicking a bit the wheel see if it turns relatively easily. I also think it has a small resistor on it. Finally the wires and electrical connector are easy to check.

Can't tell the part no but it's around $150 at Volvo. Easier to source a used one that spins easily.

This fan should kick in in hot weather after driving for a while. Another way to test is to remove the ECM cover and feel how hot the modules got: if it burns the skin then it's a problem, but they actually do get pretty hot and can withstand some high temps.

I believe there is also a temperature sensor integrated to the ECM that will activate the fan past a certain temperature inside the ECM

As for the ECM, the main reason they go bad on these 2001 and up, it's water ingress at the lower connectors. It's quite easy to remove them from there without the special tool, and inspect the connectors on both sides.



2003 2.4i S60 automatic 125k miles

Free2drive!
Posts: 220
Joined: Tue Oct 24, 2006 3:31 am
Year and Model: 2004 V70
Location: York
Great Britain

Re: Part # Help: fan/blower that cools ECM box

Post by Free2drive! » Thu Apr 19, 2018 7:25 am

That's helpful Orangex.
Apologies for jumping posts. I have a question. My ECU fan runs permanently while the car is in use all year round.
Is this operating correctly?
Thanks
Matt



User avatar
oragex
Posts: 3498
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 61 times
Been thanked: 77 times
Contact:
Canada

Re: Part # Help: fan/blower that cools ECM box

Post by oragex » Thu Apr 19, 2018 7:31 am

Hi Matt, I suspect the weather in your area is not always very warm? My guess is a previous owner may have shorted the wires to the fan so it stays on at all times. Maybe he thought there was an issue with the ECM cooling. On my 2003 non turbo (petrol) the fan only kicks in when the outside temperature is above 15C and I drive the car for more than 30 min. In hot summer days (25C+) it would kick in faster, and also stay on for 1-2 minutes after shutting the engine off

The fan connector is located right near the ECM box on the engine bay wall.


2003 2.4i S60 automatic 125k miles

jonesg
Posts: 829
Joined: Wed Jan 16, 2008 3:25 pm
Year and Model: 2004 V70
Location: Northern maine.
Has thanked: 2 times
Been thanked: 12 times
Wales

Re: Part # Help: fan/blower that cools ECM box

Post by jonesg » Fri Apr 20, 2018 2:11 am

carboncow wrote:
Wed Apr 18, 2018 5:37 pm
I think half the reason our ECM got nuked was I just determined that little fan is not working. Anyone got a part number?
Check the fuse in the engine bay.



Free2drive!
Posts: 220
Joined: Tue Oct 24, 2006 3:31 am
Year and Model: 2004 V70
Location: York
Great Britain

Re: Part # Help: fan/blower that cools ECM box

Post by Free2drive! » Fri Apr 20, 2018 2:25 am

Thanks, got it out looks untouched but might be internal fault.
Here's my other possibly related issue.
If I run around with ECU box unclipped then the car runs fine. When I button down the box by the headlight I get canbus issues: Brake stop safely, transmission service, no speedo, no rev or temp gauge. Eventually no start.

I'm thinking the box is pinching wires or a connector is broken and to be honest I'm fearful of opening it up.
Matt



jonesg
Posts: 829
Joined: Wed Jan 16, 2008 3:25 pm
Year and Model: 2004 V70
Location: Northern maine.
Has thanked: 2 times
Been thanked: 12 times
Wales

Re: Part # Help: fan/blower that cools ECM box

Post by jonesg » Fri Apr 20, 2018 3:37 am

Free2drive! wrote:
Fri Apr 20, 2018 2:25 am
Thanks, got it out looks untouched but might be internal fault.
Here's my other possibly related issue.
If I run around with ECU box unclipped then the car runs fine. When I button down the box by the headlight I get canbus issues: Brake stop safely, transmission service, no speedo, no rev or temp gauge. Eventually no start.

I'm thinking the box is pinching wires or a connector is broken and to be honest I'm fearful of opening it up.
Matt
Power it up, its probably fine.
Sounds like corrosion on the ecm terminal.



Post Reply

Who is online

Users browsing this forum: bojified, justanotherhumanoid, rman and 37 guests