IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

power System Service urgent message

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

adrian22
Posts: 125
Joined: Fri Jul 16, 2004 4:29 pm
Year and Model: s60 2006
Location: florida
Has thanked: 0
Been thanked: 1 time
Aruba
adrian22

power System Service urgent message

Post by adrian22 » Mon May 28, 2018 10:14 am

my car is a 2005 xc70- 120k and
got this message when I start it this morning
Car runs ok -no problems Battery is new and shows 12.6 with engine off in the morning overnight rest
I get 13.5 V when running w/no load voltage stays steady but under load(ac/fog lights/heater/lights) drops to 12.8.if I turn off all electrical load the voltage reading come back to 13.5.
If I let the car run 15 min after the engine is off the battery reads 12.8, meaning the alternator is charging and is working.I am not sure if it has a smart regulator or not-I assume it does since the default 13.5v charge.
My alternator has an exterior plastic box attached to alternator and if I search for Voltage regulator part it shows me that part as a separate part for under $50
Maybe i can just replace that instead the alternator that looks ok

I assume since the battery and alternator is ok the only part left is the voltage regulator defective
I am right-please correct me if wrong?
adrian22

User avatar
oragex
Posts: 4815
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 95 times
Been thanked: 266 times
Contact:
Canada
oragex

Re: power System Service urgent message

Post by oragex » Mon May 28, 2018 10:31 am

In theory 2005 has the smart regulator

The regulator may be good at 13.5 if the battery is fully charged (for a smart one) but 12.8V is weak - is that when the message pops up?

When you discharge a bit the battery then start the car, does the regulator show near 14.4V?

What happened with the old battery, was it weak?

12.8V 15 minutes after shutting the engine is excellent, but not sure why does it drop to 12.6V the next morning (assuming all lights are off including trunk lights, when measuring). From 12.8 to 12.6 it means the battery has lost some 10% of it's charge.
May well indicate a parasitic drain. Under the trunk lid cover, try disconnecting the rear plate lights connector see if the battery has a better charge in the morning.

adrian22
Posts: 125
Joined: Fri Jul 16, 2004 4:29 pm
Year and Model: s60 2006
Location: florida
Has thanked: 0
Been thanked: 1 time
Aruba
adrian22

Re: power System Service urgent message

Post by adrian22 » Mon May 28, 2018 11:59 am

thanks for reply
I am answering to your questions
12.6v BATTERY IS OK -FOR A FULL CHARGED ONE------
The regulator may be good at 13.5 if the battery is fully charged (for a smart one) but 12.8V is weak - is that when the message pops up?
----the VOLTAGE WITH ENGINE ON SHOULD BE 14.2 NOT 13.5 ---THAT IS CONSISTENT DEFAULT CHARGE if the regulator is dead ------------Dropping to 12.8 IS UNDER MAX electrical LOAD-AND COMING BACK TO 13.5 IF LOAD REMOVED and stay consistent

When you discharge a bit the battery then start the car, does the regulator show near 14.4V?
----NO -THIS IS THE PROBLEM-AS SOON I START THE CAR (maybe 15 sec after ) I GOT THE POWER SYSTEM + BATTERY LOGO
MESSAGE

What happened with the old battery, was it weak? -IT WAS 5 YEAR OLD AND VERY WEEK that was replaced 1 year ago
adrian22

Post Reply
  • Similar Topics
    Replies
    Views
    Last post