IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

VIDA faults - Com with 5 control modules signal missing

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

FinReaper
Posts: 3
Joined: Mon Jan 07, 2019 9:17 am
Year and Model: 2001 V70
Location: OR
Has thanked: 0
Been thanked: 0
United States of America
FinReaper

VIDA faults - Com with 5 control modules signal missing

Post by FinReaper » Mon Jan 07, 2019 9:18 am

2001 V70 base 283k miles.

Below are all the faults listed from VIDA. Does this mean my CEM is going bad with all these missing signals?

Steering wheel - no turn signals, no cruise, no bright head lights, no radio controls, wipers only one speed.

UEM - no cabin light control, no sun roof motor control

Image

jimmy57
Posts: 6508
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 3 times
Been thanked: 213 times
jimmy57

Re: VIDA faults - Com with 5 control modules signal missing

Post by jimmy57 » Mon Jan 07, 2019 3:20 pm

GO to the fuebox and relay box under left dash. That is also the CEM in the middle of that box. CHeck that every fuse and relay is pushed in and also that you have no blown fuse. Those modules aren't all on one leg of the comm line but I do think they may all share a power supply point. If that relay is partway out and isn't powering up the list of modules then they can't talk.

FinReaper
Posts: 3
Joined: Mon Jan 07, 2019 9:17 am
Year and Model: 2001 V70
Location: OR
Has thanked: 0
Been thanked: 0
United States of America
FinReaper

Re: VIDA faults - Com with 5 control modules signal missing

Post by FinReaper » Mon Jan 07, 2019 3:44 pm

I should've mentioned that I checked every fuse in the cabin, driver side. I also replace every relay/diode on the CEM with those from my xc70. No change.

FinReaper
Posts: 3
Joined: Mon Jan 07, 2019 9:17 am
Year and Model: 2001 V70
Location: OR
Has thanked: 0
Been thanked: 0
United States of America
FinReaper

Re: VIDA faults - Com with 5 control modules signal missing

Post by FinReaper » Thu Feb 28, 2019 10:51 am

It is fixed! I had the CEM cloned and that didn't change anything. I found a like SWM at the JY and replaced it. No dealer software reload or software needed. Plug and play, which pleasantly surprised me. Now everything is working back as it should. :)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post