IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Dim not responding 2005 V70 2.4 NA

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Rvolvos
Posts: 35
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 21 times
Been thanked: 0
United States of America
Rvolvos

Dim not responding 2005 V70 2.4 NA

Post by Rvolvos » Thu Feb 21, 2019 8:22 pm

Could use some advice on my not responding DIM module.
I have tried to reset the service reminder and got the message 045 on the display.
Then I connected Vida and checked the network tab. Amount others DIM module is showing red and no communication possible . Everything seems to work but can not reset the service minder.
Help much appreciated!
Attachments
DC1AF385-A74F-4645-AB33-AA9E09EB7A1A.jpeg


2006 XC70 2.5T183k
2006 V70 2.5T 142k (son)
2005 V70 2.4NA 140k (son)
Past Volvo 66
Past Volvo 343

User avatar
vtl
Posts: 1447
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 22 times
United States of America
vtl

Re: Dim not responding 2005 V70 2.4 NA

Post by vtl » Thu Feb 21, 2019 9:03 pm

CAN-bus problems. Show us the codes (fault trace tab).


2005 XC70 250k
2016 XC60 40k

Rvolvos
Posts: 35
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 21 times
Been thanked: 0
United States of America
Rvolvos

Re: Dim not responding 2005 V70 2.4 NA

Post by Rvolvos » Thu Feb 21, 2019 9:15 pm

Now photos included:
Attachments
982A977E-4B49-4505-A005-25289C1747DB.jpeg
96AF9B90-2F9C-4A7C-80AA-0E0B6E05F28B.jpeg


2006 XC70 2.5T183k
2006 V70 2.5T 142k (son)
2005 V70 2.4NA 140k (son)
Past Volvo 66
Past Volvo 343

Rvolvos
Posts: 35
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 21 times
Been thanked: 0
United States of America
Rvolvos

Re: Dim not responding 2005 V70 2.4 NA

Post by Rvolvos » Thu Feb 21, 2019 9:17 pm

First picture is before erasing fault codes, second picture after erasing all fault codes and driving 40 miles.


2006 XC70 2.5T183k
2006 V70 2.5T 142k (son)
2005 V70 2.4NA 140k (son)
Past Volvo 66
Past Volvo 343

User avatar
vtl
Posts: 1447
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 22 times
United States of America
vtl

Re: Dim not responding 2005 V70 2.4 NA

Post by vtl » Thu Feb 21, 2019 9:26 pm

Looking at different screenshots, seems that your car has problems both with the high-speed CAN-bus (engine, transmission, brakes) and low-speed as well. Any history on this car? What did you do (semi-)recently, maybe it flooded, etc?

I'd pull CEM just to check water did not leak inside through the plug under the cowl.


2005 XC70 250k
2016 XC60 40k

Rvolvos
Posts: 35
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 21 times
Been thanked: 0
United States of America
Rvolvos

Re: Dim not responding 2005 V70 2.4 NA

Post by Rvolvos » Thu Feb 21, 2019 10:06 pm

Thanks for the suggestion.
Just purchased the car from a 2nd owner. He bought it as a CPO In 2008 from a Volvo dealer. I do have all the service records from 2008 and onwards. It needs a lot of servicing:
transmission, try to cure a hard 3-2 down shift, when transmission gets above 65C degrees, with drain and refills in combination with RA and fluid counter resets. Did the 3rd drain and refill today. Fluid has never been replaced and is dark brown.
pcv leaking, parts on order from FCPEURO
leak in cooling system, solved
dirty coolant, solved
brake fluid fluid on order
Power steering fluid dirty waiting for parts / leaking (solved)
Brake booster vacuum pump not working. Not diagnosed yet.
Due for new spark plugs, on order
all filters needed replacing. Done
Wipers, lightbulbs, done. Had to remove the covers of the eco and tcm to get acces. Could this have to do with it?

It has been neglected last year or so but that it starts and drives well.

I did notice the drains on the Cowel near the windshield where plugged. And it rained a lot lately in Northern California and it had a nasty smell inside the car. I will inspect and report back. May take me a while to get to it with all the other pending issues.


2006 XC70 2.5T183k
2006 V70 2.5T 142k (son)
2005 V70 2.4NA 140k (son)
Past Volvo 66
Past Volvo 343

User avatar
vtl
Posts: 1447
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 22 times
United States of America
vtl

Re: Dim not responding 2005 V70 2.4 NA

Post by vtl » Thu Feb 21, 2019 10:12 pm

Yes, a leak to CEM is a good guess then. Start with that. If you see the leak you may need to find where exactly it enters the cabin and water-proof that place.

You may need to crack CEM open to clean the mess or at least see how it's doing. Use zip ties to fix a bazillion of plastic tabs in place...

ECM and TCM can be taken out, cleaned with electric contact cleaner if you want to be sure there's no oxidation causing troubles.
These users thanked the author vtl for the post:
Rvolvos


2005 XC70 250k
2016 XC60 40k

User avatar
oragex
Posts: 4131
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 77 times
Been thanked: 155 times
Contact:
Canada
oragex

Re: Dim not responding 2005 V70 2.4 NA

Post by oragex » Thu Feb 21, 2019 11:03 pm

How many miles? Same miles on DIM/maintenance papers?

As mentioned, I'd look at the CEM, 2005 has water ingress (Xemodex) and can cause DIM issues

Brake booster vacuum pump not working can be burnt from over running from leaking brake booster pedal seal www.youtube.com/watch?v=jKcDOLIYR3A

Don,t forget this www.youtube.com/watch?v=gOx3Q8vqoz4
These users thanked the author oragex for the post:
Rvolvos


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

User avatar
abscate
MVS Moderator
Posts: 17324
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 185 times
Been thanked: 560 times
Trinidad & Tobago
abscate

Re: Dim not responding 2005 V70 2.4 NA

Post by abscate » Fri Feb 22, 2019 4:55 am

There is a TSB on resealing the CEM harness, see if that’s been done.

The 2005 NA club is the exclusive group of superior people, too, just so you know.
These users thanked the author abscate for the post:
Rvolvos


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

precopster
Posts: 7415
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 3 times
Been thanked: 93 times
Australia
precopster

Re: Dim not responding 2005 V70 2.4 NA

Post by precopster » Fri Feb 22, 2019 6:01 am

So when you say DIM is not responding you're just referring to the service reset?

It lights up and has message display? Speedo/tacho operational?

Is it off the network only after attempting a service reset then comes back to life?
These users thanked the author precopster for the post:
Rvolvos


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

Post Reply