IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Still Crank No Start. Very Strange

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Has thanked: 0
Been thanked: 1 time
Sweden
goldmandan

Re: Still Crank No Start. Very Strange

Post by goldmandan » Tue Jul 09, 2019 7:31 am

would a bad maf or dirty maf cause it not to start, only sometimes?

Dan



User avatar
abscate
MVS Moderator
Posts: 18970
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 224 times
Been thanked: 740 times
Trinidad & Tobago
abscate

Re: Still Crank No Start. Very Strange

Post by abscate » Tue Jul 09, 2019 8:48 am

goldmandan wrote:
Tue Jul 09, 2019 7:31 am
would a bad maf or dirty maf cause it not to start, only sometimes?

Dan
Possible but I would say rarely. You can disconnect it, then try (the car will run on a rmp/fuel map in software if there is no MAF signal)

You will have to clear MAF code after that.

Dont unplug/plug MAF with ignition on, shut everything off.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Has thanked: 0
Been thanked: 1 time
Sweden
goldmandan

Re: Still Crank No Start. Very Strange

Post by goldmandan » Tue Jul 09, 2019 11:19 am

i read ecm2400 is a short to ground in the wire from ecm to cem. Would make sense as the fuel pump relay was replaced already and i just put a new one in. no change. And the CEM does have a yellow wire going to starting/charging system. I think i may have found the culprit as the ecm2400 triggers right after i erase it and crank again.



Post Reply