IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Engine System Service Urgent, from bad to worse

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

User avatar
oragex
Posts: 4612
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 233 times
Contact:
Canada
oragex

Re: Engine System Service Urgent, from bad to worse

Post by oragex » Mon Jan 06, 2020 7:27 pm

Looks like a similar issue (see last post) viewtopic.php?t=71635
These users thanked the author oragex for the post:
SVO LOU

User avatar
SuperHerman
Posts: 1341
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: Engine System Service Urgent, from bad to worse

Post by SuperHerman » Mon Jan 06, 2020 8:11 pm

I am not very proficient in VIDA, but the software is very powerful and will provide the answers.- at least a fault trace path to go through. There are numerous videos on the internet - pick one that goes through the steps, it doesn't have to be for your problem, but it will show you how it works and how to navigate the interface. Good luck.
These users thanked the author SuperHerman for the post:
SVO LOU

SVO LOU
Posts: 21
Joined: Sun Dec 18, 2016 12:50 pm
Year and Model: 01 V70 XC, 06 V70
Location: Greenville, SC
Has thanked: 11 times
Been thanked: 0
United States of America
SVO LOU

Re: Engine System Service Urgent, from bad to worse

Post by SVO LOU » Tue Jan 07, 2020 6:02 pm

oragex wrote:
Mon Jan 06, 2020 7:27 pm
Looks like a similar issue (see last post) viewtopic.php?t=71635
As I scrolled the post my hopes were growing and growing until I read his solution...My fuse is in place, and tests good.
Thanks for the heads up.
Didn't have anything to lose so I tried the accelerator pedal assy from the donor and it didn't make a difference. :(
I let it idle, hooked up VIDA again and the same codes showed up, and clearing still doesn't help.
Thanks for the help everyone.

User avatar
SuperHerman
Posts: 1341
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: Engine System Service Urgent, from bad to worse

Post by SuperHerman » Tue Jan 07, 2020 7:52 pm

Not the fuse, but the relay was what failed. Did you check the relay?

SVO LOU
Posts: 21
Joined: Sun Dec 18, 2016 12:50 pm
Year and Model: 01 V70 XC, 06 V70
Location: Greenville, SC
Has thanked: 11 times
Been thanked: 0
United States of America
SVO LOU

Re: Engine System Service Urgent, from bad to worse

Post by SVO LOU » Tue Jan 07, 2020 8:20 pm

SuperHerman wrote:
Tue Jan 07, 2020 7:52 pm
Not the fuse, but the relay was what failed. Did you check the relay?
Didn't check a relay, had to button it up, clean up, and make dinner. Looks like the FMI1 relay is the next step. Thanks.

SVO LOU
Posts: 21
Joined: Sun Dec 18, 2016 12:50 pm
Year and Model: 01 V70 XC, 06 V70
Location: Greenville, SC
Has thanked: 11 times
Been thanked: 0
United States of America
SVO LOU

Re: Engine System Service Urgent, from bad to worse

Post by SVO LOU » Wed Jan 08, 2020 6:41 pm

Tried the relay today although I didn't have the FMI1 relay, so I replaced the one that was where FMI1 would've been, and the bottom side of the fuse cover said AC, and it made no difference. Maybe that's not the relay you meant, though, Superherman.
I'd really like to un-seat the ECU and take a look at the pins but I don't have that special ecu tool. Under communications>ECM I get
ECM-Accelerator pedal sensor, PWM 0%
ECM-Accelerator pedal, PWM (via ETM) 0%
Both of the above show no change when I press on the pedal but these do...
ECM-throttle angle
ECM-Accelerator pedal, analogue input
Last edited by SVO LOU on Wed Jan 08, 2020 7:14 pm, edited 1 time in total.

User avatar
volvolugnut
Posts: 248
Joined: Sun Jan 19, 2014 9:51 am
Year and Model: 2001 V70
Location: Midsouth USA
Has thanked: 2 times
Been thanked: 28 times
United States of America
volvolugnut

Re: Engine System Service Urgent, from bad to worse

Post by volvolugnut » Wed Jan 08, 2020 6:48 pm

The ECU or TCU removal tool is available as loaner here on MVS.
volvolugnut
2001 V70 T5, 1986 244DL, 1983 245DL, 1975 245DL, 1959 PV544, multiple parts cars.

User avatar
SuperHerman
Posts: 1341
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: Engine System Service Urgent, from bad to worse

Post by SuperHerman » Thu Jan 09, 2020 9:39 pm

I don't have VIDA anymore so I cannot provide guidance on which relay you are looking for. Was it in the rear of the car or the front? There is suppose to be a relay there - so you may still need further testing.

Maybe RickHaleParker will chime in and point you to the correct relay and its location.

Can you link a picture of the relevant wiring diagram?
These users thanked the author SuperHerman for the post:
SVO LOU

firstv70volvo
Posts: 59
Joined: Sat Mar 06, 2010 8:37 am
Year and Model: V70 T5 2001
Location: Sacramento, CA
Has thanked: 5 times
Been thanked: 4 times
United States of America
firstv70volvo

Re: Engine System Service Urgent, from bad to worse

Post by firstv70volvo » Fri Jan 10, 2020 1:18 pm

SVO LOU wrote:
Wed Jan 08, 2020 6:41 pm
Tried the relay today although I didn't have the FMI1 relay, so I replaced the one that was where FMI1 would've been, and the bottom side of the fuse cover said AC, and it made no difference. Maybe that's not the relay you meant, though, Superherman.
I'd really like to un-seat the ECU and take a look at the pins but I don't have that special ecu tool. Under communications>ECM I get
ECM-Accelerator pedal sensor, PWM 0%
ECM-Accelerator pedal, PWM (via ETM) 0%
Both of the above show no change when I press on the pedal but these do...
ECM-throttle angle
ECM-Accelerator pedal, analogue input
From the 2002 document I have the power path to the accelerator pedal sensor does not go through the FMI1 relay, this relay is for the AC solenoid but does share the same 11B/8 fuse as the pedal sensor. Does your AC work? Please see the attached file for power path to the pedal sensor.
You do not have the required permissions to view the files attached to this post.
These users thanked the author firstv70volvo for the post:
SVO LOU

SVO LOU
Posts: 21
Joined: Sun Dec 18, 2016 12:50 pm
Year and Model: 01 V70 XC, 06 V70
Location: Greenville, SC
Has thanked: 11 times
Been thanked: 0
United States of America
SVO LOU

Re: Engine System Service Urgent, from bad to worse

Post by SVO LOU » Fri Jan 10, 2020 7:43 pm

Thanks for the help guys, especially the pdf.
Yes, the ac works fine, and this is an '01 but hopefully the same as an '02. The relay I changed was in the engine compartment fuse panel, I'm somewhat experienced with wiring diagrams so I'll look deeper.
Thanks again.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post