IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2006 xc70 Handling Issue

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

stoutlogic
Posts: 182
Joined: Tue Jan 03, 2006 7:22 pm
Year and Model: 2006 XC70
Location: NJ
Has thanked: 0
Been thanked: 4 times
United States of America
stoutlogic

2006 xc70 Handling Issue

Post by stoutlogic » Wed Jun 14, 2017 11:35 am

My Xc70 feels like the car is controlling the steering around corners, meaning it feels as if the steering wheel is trying to move itself back and forth when I turn. I notice it mainly on longer sweeping turns. Doesn't feel like anything is loose but feels as if something is powering the steering wheel side to side. Makes the car feel unstable, kind of like driving a boat.

I have installed new inner and out tierod ends, checked the wheel bearings and ball joints, also did a proper 4 wheel alignment. Control arms seem fine. No play in any parts that I can tell. Struts and steering rack appear fine too.

Could this be something electric based that is controlling the steering rack? Maybe something in the steering linkage to the rack?

Thoughts?
These users thanked the author stoutlogic for the post:
Ringo



jonesg
Posts: 855
Joined: Wed Jan 16, 2008 3:25 pm
Year and Model: 2004 V70
Location: Northern maine.
Has thanked: 2 times
Been thanked: 12 times
Wales
jonesg

Re: 2006 XC70 Handling Issue

Post by jonesg » Wed Jun 14, 2017 12:34 pm

on my 04 v70 its the control arms when it feels vague on the steering, slight side to side drift on hiway.
With car raised, weight of the wheel pulling the strut down I can see rips in the rubber bushing.



stoutlogic
Posts: 182
Joined: Tue Jan 03, 2006 7:22 pm
Year and Model: 2006 XC70
Location: NJ
Has thanked: 0
Been thanked: 4 times
United States of America
stoutlogic

Re: 2006 XC70 Handling Issue

Post by stoutlogic » Wed Jun 14, 2017 12:40 pm

Ill give them a second peep but they looked fine when I had the car up on the lift. They were dealer replaced around 100k. 140k on the clock now.



jonesg
Posts: 855
Joined: Wed Jan 16, 2008 3:25 pm
Year and Model: 2004 V70
Location: Northern maine.
Has thanked: 2 times
Been thanked: 12 times
Wales
jonesg

Re: 2006 XC70 Handling Issue

Post by jonesg » Wed Jun 14, 2017 6:34 pm

Yeh so its probably something else. Check tire pressure too, that can do funny things if one is low. Rear wheels too.



stoutlogic
Posts: 182
Joined: Tue Jan 03, 2006 7:22 pm
Year and Model: 2006 XC70
Location: NJ
Has thanked: 0
Been thanked: 4 times
United States of America
stoutlogic

Re: 2006 XC70 Handling Issue

Post by stoutlogic » Thu Jun 15, 2017 6:41 am

IT feels like the car is actively trying to turn the steering wheel. IDK if it could be the steering angle sensor or yaw sensor, or something else?



User avatar
vtl
Posts: 1516
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 23 times
United States of America
vtl

Re: 2006 XC70 Handling Issue

Post by vtl » Thu Jun 15, 2017 1:31 pm

What your proper aligned angles are? It looks like wrong angles are listed in database for Hunter alignment rack.

Also check that rear suspension is in tact too.


2005 XC70 250k
2016 XC60 40k

user17600
Posts: 28
Joined: Mon Jun 14, 2010 6:04 pm
Year and Model: V70A, 04; XC70, 06
Location: New England, USA
Has thanked: 0
Been thanked: 2 times
United States of America
user17600

Re: 2006 XC70 Handling Issue

Post by user17600 » Thu Jun 15, 2017 2:32 pm

The wife's 06 had the same issue. Turns out some PO had changed the fluid and put the wrong kind in.

Had the indie flush it twice and it is 90% better, still pulses a bit most noticeably on long left curves.
These users thanked the author user17600 for the post:
Ringo



stoutlogic
Posts: 182
Joined: Tue Jan 03, 2006 7:22 pm
Year and Model: 2006 XC70
Location: NJ
Has thanked: 0
Been thanked: 4 times
United States of America
stoutlogic

Re: 2006 XC70 Handling Issue

Post by stoutlogic » Thu Jun 15, 2017 8:16 pm

Thanks. Wrong angles in hunter rack database? That's strange. I did check the rear suspension at the time I did the 4 wheel alignment.

By fluid I'm assuming the wrong type of power steering fluid? Ill take a look.

Thanks for everyone input!



stoutlogic
Posts: 182
Joined: Tue Jan 03, 2006 7:22 pm
Year and Model: 2006 XC70
Location: NJ
Has thanked: 0
Been thanked: 4 times
United States of America
stoutlogic

Re: 2006 XC70 Handling Issue

Post by stoutlogic » Mon Jun 19, 2017 7:36 am

Going to flush the power steering rack with new fluid. Current fluid is nasty brown. I'll report back with results



93SCMax
Posts: 228
Joined: Sat Feb 11, 2012 10:41 am
Year and Model: 2001 V70 T5 mt
Location: Lowcountry, SC
Has thanked: 6 times
Been thanked: 13 times
United States of America
93SCMax

Re: 2006 XC70 Handling Issue

Post by 93SCMax » Mon Jun 19, 2017 12:13 pm

Fluid shouldn't be brown, needs to be a clean green. A good flush is needed. Hope this is your solution.
These users thanked the author 93SCMax for the post:
Ringo



Post Reply