IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

passing emissions testing - heated 02 sensor does not heat

How to buy, install and use VIDA, VADIS, DiCE, VMWare and all the questions and answers that come with these tools.
1998-S90-Owner
Posts: 7
Joined: Fri Aug 18, 2017 10:16 am
Year and Model: 1998 S90
Location: Racine, WI, USA
Has thanked: 1 time
Been thanked: 2 times
United States of America
1998-S90-Owner

passing emissions testing - heated 02 sensor does not heat

Post by 1998-S90-Owner » Fri Aug 18, 2017 10:41 am

My 1998 Volvo S90 will not respond to new downstream oxygen sensors. I have tried a Bosc universal and now a Walker specific for my vehicle.

I am not a car mechanic but I have the aptitude to be one. I have been trying to pass Wisconsin emissions testing for 10 weeks more or less.

There is an apparent short in my wiring harness between my downstream oxygen sensor and the power source. I had installed a new, after-market downstream sensor made by Walker complete with an oem connector. It apparently has no power according to the installer. The car throws P0136 and P0141 codes.

Does anyone have the wiring diagram or other insights?
These users thanked the author 1998-S90-Owner for the post:
jsn9839



1998-S90-Owner
Posts: 7
Joined: Fri Aug 18, 2017 10:16 am
Year and Model: 1998 S90
Location: Racine, WI, USA
Has thanked: 1 time
Been thanked: 2 times
United States of America
1998-S90-Owner

Re: passing emissions testing - heated 02 sensor does not heat

Post by 1998-S90-Owner » Sun Aug 20, 2017 11:33 am

Has one ever had a downstream oxygen sensor that will not heat?
These users thanked the author 1998-S90-Owner for the post:
jsn9839



Post Reply