help needed 1998 V70 warm start problem

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Re: help needed 1998 V70 warm start problem

Post by ka0ren »

Coolant temp sensor is new VOLVO O E part.

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

SuperHerman wrote: Wed Apr 18, 2018 2:56 pm Did you check relays for all related systems?
Subbed all relays from nice running S70 [ also 1998] V70 - no start, S70 starts and runs fine

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

ecbsykes wrote: Wed Apr 18, 2018 6:02 pm So it only has trouble starting when warm? Could be the ECT acting up and giving bad signals maybe.
Subbed ECU still crank no start, S70 fires right up , runs perfect.

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

scot850 wrote: Wed Apr 18, 2018 7:19 pm + 1 with ebsykes comments. Based on the symptoms, I would check the resistance values of the ECT (water temp sensor) that is mounted below the thermostat housing. The connector to this is usually mounted on the back of the power steering pump. Also check the connector at that point as the wires and connection can start to fall apart with age and heat from the engine. Somewhere on MVS there are resistance values based on ambient external temperature over a range.

There are aftermarket parts but this is one I would recommend the OE Volvo part. There is I think one aftermarket option some have had luck with but I don't recall the brand.

Neil.
CTS from non- starting V70 is new O E VOLVO . Measures 1,340 ohms at 114 degrees F. engine was run 2 minutes before shutting off. Then cranks, no start. S70 with old CTS measures 1,180 at 104 degrees F.

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

Anyone know where I can get a wiring diagram for the fuel system and ignition system. Hopefully immobilizer system also.

Perhaps checking wire harness can locate fault.

Anyone know what function the large black box at left of steering column and just under L H air duct is for ? It has a connector with LOTS of wires ! ]

User avatar
misha
Posts: 4599
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 71 times
Been thanked: 179 times

Post by misha »

Injectors will not pulse if ecu doesn't send a signal which it gets from crank position sensor(tdc).
Main fuel injection relay is located at cooling fan carrier under the hood...it's a grey one,it powers injectors,coil and iacv valve.
Other than this,you might have a failing fuel pump or transponder in chipped key(if the car is equipped with).
Eu cars have chipped keys from '96.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

misha wrote: Sat May 26, 2018 2:45 pm Injectors will not pulse if ecu doesn't send a signal which it gets from crank position sensor(tdc).
Main fuel injection relay is located at cooling fan carrier under the hood...it's a grey one,it powers injectors,coil and iacv valve.
Other than this,you might have a failing fuel pump or transponder in chipped key(if the car is equipped with).
Eu cars have chipped keys from '96.
Thanks Misha, I will try swapping out the relays ! I will post the results soon.

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

Misha, Several keys, no difference in starting. Could circuit checking key transponder be faulty ? If so, where is it ?? Antenna ring replaced and no difference. Crank position sensor was one of the first components replaced .

User avatar
misha
Posts: 4599
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 71 times
Been thanked: 179 times

Post by misha »

Chipped key is mated with a car,it belongs to corresponding car ONLY.
It communicates with immobiliser via antenna ring and then sending OK signal to ecu.
There is only one chipped key per car,2nd one is "service" key and have no chip in it...3rd is "wallet" key.
U.S market cars didn't had chipped keys untill '99 although EU cars have them from '96.
About relay....there is ONLY one master fuel injection relay and it's grey one with VOLVO letters on it and it's location is at cooling fan carrier under the hood.

Are there any codes stored or pending?
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

ka0ren
Posts: 24
Joined: Wed Jul 25, 2012 11:12 pm
Year and Model: V70 1998 AWD
Location: Missouri
Has thanked: 2 times

Post by ka0ren »

ka0ren wrote: Sun May 27, 2018 7:55 am
misha wrote: Sat May 26, 2018 2:45 pm Injectors will not pulse if ecu doesn't send a signal which it gets from crank position sensor(tdc).
Main fuel injection relay is located at cooling fan carrier under the hood...it's a grey one,it powers injectors,coil and iacv valve.
Other than this,you might have a failing fuel pump or transponder in chipped key(if the car is equipped with).
Eu cars have chipped keys from '96.
Thanks Misha, I will try swapping out the relays ! I will post the results soon.
Bad news, NO grey relay on cooling fan shroud. Only black one for 2 speed fan [ #94 42 934 ]

I did find in fuse/relay box "MAIN RELAY" # 9162300 . switched relays with S70 and S70 starts and runs perfectly. Wiring diagram would be most helpful ! I will check and compare voltages at main relay sockets .

Post Reply
  • Similar Topics
    Replies
    Views
    Last post