IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Cruise Control Intermittently working-- stumped

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

viper69
Posts: 408
Joined: Sat Jun 26, 2004 6:41 pm
Year and Model: 850GLT 1995
Location: USA
Has thanked: 44 times
Been thanked: 1 time
United States of America
viper69

Cruise Control Intermittently working-- stumped

Post by viper69 » Sat Sep 29, 2018 3:25 pm

Here's what I know...

Previous to this week, I haven't used the Cruise Control in maybe 2 years.

A few weeks ago I had the battery changed to a brand new one, no issues. I've driven the car over a 100 miles since then, 30 in town, 70 highway. Oil changed recently too.

A week ago I had spark plugs changed- engine is no longer coughing.

Drove at 65 mph l last week for an hour- used cruise control (CC) no issues.
Driving back on a second day, I engaged the CC at the same speed, no issues, then went over a small bump, the car began to decelerate due to slope of the road, the CC had disengaged.

During this drive it would go on/off at the same rate of speed, not always due to a bump on the road.

Also, following day, the CC wouldn't engage at all. I gave up.

I don't have any engine/dashboard lights on or blinking. Nothing blinked when I went over the few small bumps.

What should I be looking for, suspects causing this error? I'm bringing it to my Volvo mechanic, he's from Sweden this is all he works on, never been wrong before.

Can a computer diagnostic reveal the issues?

It's a 1995 so I venture to guess at some point some things may just break. I'm the only owner too.


Volvo 850 GLT 1995

5 Speed Manual transmission

122,500 miles and barely broken in

Previous:
'82 Volvo DL Wagon, 4 speed manual
'77 Saab 99 EMS, 4 speed manual

User avatar
WhatAmIDoing
Posts: 709
Joined: Sat Jul 30, 2016 1:13 pm
Year and Model: 1998 S70 T5M
Location: North America
Has thanked: 57 times
Been thanked: 54 times
Canada
WhatAmIDoing

Re: Cruise Control Intermittently working-- stumped

Post by WhatAmIDoing » Sat Sep 29, 2018 3:47 pm

Cruise control is vacuum controlled. Would have to test pump (under the battery). Probably need to replace the vacuum lines. There's also a diaphragm that can break. Plus there are switches under the dash near the brake and clutch (tell CC whether you engage brake or clutch) that may need to be adjusted. That's about the extent of my knowledge. This is something I've been meaning to fix for 2 years now.
Last edited by WhatAmIDoing on Sun Sep 30, 2018 12:22 am, edited 1 time in total.


'98 S70 T5M - 270,000+mi - forever a project
'99 S70 "AWD" - 218,000+mi - project
Knows enough to be dangerous :wink:

viper69
Posts: 408
Joined: Sat Jun 26, 2004 6:41 pm
Year and Model: 850GLT 1995
Location: USA
Has thanked: 44 times
Been thanked: 1 time
United States of America
viper69

Re: Cruise Control Intermittently working-- stumped

Post by viper69 » Sat Sep 29, 2018 5:03 pm

I wonder how much this is going to cost..jeez


Volvo 850 GLT 1995

5 Speed Manual transmission

122,500 miles and barely broken in

Previous:
'82 Volvo DL Wagon, 4 speed manual
'77 Saab 99 EMS, 4 speed manual

User avatar
abscate
MVS Moderator
Posts: 18196
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 200 times
Been thanked: 647 times
Trinidad & Tobago
abscate

Re: Cruise Control Intermittently working-- stumped

Post by abscate » Sat Sep 29, 2018 6:58 pm

Very little for old vacuum hose replacement. 20 year old rubber hoses all pretty much need replacing.
These users thanked the author abscate for the post:
viper69


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

JimBee
Posts: 1696
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model: 93 and 2 96 850's
Location: Minneapolis
Has thanked: 9 times
Been thanked: 16 times
United States of America
JimBee

Re: Cruise Control Intermittently working-- stumped

Post by JimBee » Sat Sep 29, 2018 8:13 pm

I looked this up recently, also, due to same symptoms in my 96 base 850. I haven't solved mine but I will explore one suggestion: the control module in the fuse box. Somebody confirm this, I think it's the one next to the headlight module. In that post I think someone suggested cleaning the contacts first. If that doesn't work I don't know if there's a way to test it off the pins.

I just found the link you need to troubleshoot all the parts of the cruise system. I'll be using it too. Read down the thread, erik posted the link:
viewtopic.php?f=1&t=65680
These users thanked the author JimBee for the post:
viper69



precopster
Posts: 7443
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 97 times
Australia
precopster

Re: Cruise Control Intermittently working-- stumped

Post by precopster » Sat Sep 29, 2018 10:45 pm

I had a CC module lying around so I opened it up. Inside there is a relay with contacts. Clean these with sandpaper preferably 400 grit.
You do not have the required permissions to view the files attached to this post.
These users thanked the author precopster for the post:
viper69


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

User avatar
WhatAmIDoing
Posts: 709
Joined: Sat Jul 30, 2016 1:13 pm
Year and Model: 1998 S70 T5M
Location: North America
Has thanked: 57 times
Been thanked: 54 times
Canada
WhatAmIDoing

Re: Cruise Control Intermittently working-- stumped

Post by WhatAmIDoing » Sun Sep 30, 2018 12:29 am

The vacuum lines are a pretty good bet and cheap to replace. The switches for the clutch and brake are also an easy place to start. I don't know if there is any record of the CC pump or relay ever going bad, but those should be easy to test. Also should check the fuse for CC. Some users have reported the wiring for CC failing in the turn signal lever.

Edit:
JimBee wrote:
Sat Sep 29, 2018 8:13 pm
I just found the link you need to troubleshoot all the parts of the cruise system. I'll be using it too. Read down the thread, erik posted the link:
viewtopic.php?f=1&t=65680
This is a good guide. Does anyone know if there are difference for CC between a 95-96 and a 98?
These users thanked the author WhatAmIDoing for the post:
viper69


'98 S70 T5M - 270,000+mi - forever a project
'99 S70 "AWD" - 218,000+mi - project
Knows enough to be dangerous :wink:

User avatar
abscate
MVS Moderator
Posts: 18196
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 200 times
Been thanked: 647 times
Trinidad & Tobago
abscate

Re: Cruise Control Intermittently working-- stumped

Post by abscate » Sun Sep 30, 2018 2:16 am

I think the P80s are all the same, smirks from the 1999- crowd with fully electronic cruise control with no parts to fail notwithstanding...(basking in the warm glow of the ETS light)


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

precopster
Posts: 7443
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 97 times
Australia
precopster

Re: Cruise Control Intermittently working-- stumped

Post by precopster » Sun Sep 30, 2018 2:26 am

Those Cruise modules date back to the early 80s. I had the same one on my 1989 turbo 740; not exactly miniaturization on the board.

The cut-out over a bump suggests an electrical contact problem.


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

markone
Posts: 20
Joined: Thu Sep 06, 2018 2:30 pm
Year and Model: 1997 850
Location: Vermont
Has thanked: 4 times
Been thanked: 5 times
United States of America
markone

Re: Cruise Control Intermittently working-- stumped

Post by markone » Sun Sep 30, 2018 4:42 am

I had a similar issue with my ‘97 850 CC. Turned out it was the battery sitting atop, and pinching, the vacuum line.


1997 850 Sedan NA, manual trans, 268k miles
1998 V70XC AWD, turbo/auto 165k miles
1998 V70, NA/manual trans, 351k miles
2005 BMW X3 3.0i, auto, 135k miles
2010 Toyota Highlander AWD, 91k miles
2007 Malibu Response LXi, Ebony/white, 340 hp, 330 hours

Post Reply