IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

S40 Engine B4204T3 Blue smoke when idle

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.

1996 - 2004 S40
1996 - 2004 V40

jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Thu Sep 06, 2018 5:31 pm

Ended up grinding down a box end wrench. I'm able to get wrench on but can barely get any turns on it. Bad design.



User avatar
RickHaleParker
Posts: 2860
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 317 times
United States of America
RickHaleParker

Re: S40 Engine B4204T3 Blue smoke when idle

Post by RickHaleParker » Thu Sep 06, 2018 5:56 pm

Bad design.

The S40 is a subcompact. Like any compact or subcompact there is not much space for the engineer to work with. Not much space is the nature of compact.

Engineers cannot bend the laws of physics ... tho some do dream of constructions that are bigger on the inside then they are on the outside.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
alschnertz
Posts: 571
Joined: Fri Apr 29, 2011 9:25 am
Year and Model: 1995 854T
Location: Connecticut
Has thanked: 1 time
Been thanked: 7 times
United States of America
alschnertz

Re: S40 Engine B4204T3 Blue smoke when idle

Post by alschnertz » Thu Sep 06, 2018 6:47 pm

So true.
Though I like wrenching on cars, the S40 is not what I'd consider a pleasure.
Everything is just so tight.


'60 PV544, '68 220, '70 145S, '86 745T, '95 854T, '01 S40
'84 Prelude
'06 MPV
'13 Ford Focus SE

jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Sun Oct 07, 2018 2:01 pm

Can a S40 can run without a turbo charger? Thought I'd ask. Ordered a cartridge but didn't sit flush in the turbo chassis. Sent it back and looking at new one just under $300.



User avatar
alschnertz
Posts: 571
Joined: Fri Apr 29, 2011 9:25 am
Year and Model: 1995 854T
Location: Connecticut
Has thanked: 1 time
Been thanked: 7 times
United States of America
alschnertz

Re: S40 Engine B4204T3 Blue smoke when idle

Post by alschnertz » Sun Oct 07, 2018 3:03 pm

I think there were non-turbocharged S40s in other markets. But not sure the 1.9L was used.
North America only received 1.9L turbocharged models.

You've got an interesting question.
My brain says the ECU would have a hard time compensating for a missing turbocharger,
but I've got no empirical evidence to support that.
Your post makes me think that you will remove the turbine. If that's the case, how will you block off the compressor housing?

Post results if you try it.


'60 PV544, '68 220, '70 145S, '86 745T, '95 854T, '01 S40
'84 Prelude
'06 MPV
'13 Ford Focus SE

jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Mon Dec 17, 2018 3:00 pm

The new turbo is in and seems to be running ok. I understood there would be smoke for a while since the exhaust wasn't cleaned so oil build up will have to just burn off. When I first started, I expected smoke, it finally stopped. Feel goods to have it running. Next project is a s60 transmission issue. Hope there's a product that can be used to flush out buildup. Dealer says the oil is lifetime rated so doesn't see how changing fluid would help....Will start a different thread on that issue. Thanks for all the support given.



jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Sat Dec 22, 2018 2:20 pm

As I thought, the smoke eventually stopped. New Turbo seems to be working great. Now, I'm getting P0017 code and put an oscilloscope on the top sensor and it seems to be functioning as designed. Voltages look correct.
I've read where low oil could cause this code. Would any of the vacuum lines cause this code?



jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle (Solved)

Post by jumbicat » Sat Dec 22, 2018 2:28 pm

Updating subject line to reflect solved.



jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Sat Dec 22, 2018 3:04 pm

Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor 'B' is the code.



jumbicat
Posts: 27
Joined: Sun Sep 02, 2018 9:05 am
Year and Model: 2003 S40 2004 S60
Location: Lewisville, Tx
Has thanked: 0
Been thanked: 0
United States of America
jumbicat

Re: S40 Engine B4204T3 Blue smoke when idle

Post by jumbicat » Sun Dec 23, 2018 4:30 pm

Found the oil vent pipe coming off the bottom of turbo housing into block was seated poorly and gasket was passing oil. Had to pull the turbo just to be able to take pipe off turbo. NOT HAPPY. Local Volvo dealer closed so ending up making a make shift gasket out of a rubber grommet. Put it all back together and P0017 code cleared. Getting code P0018 now. (Water Temp)



Post Reply