IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2010 XC60 no power (electricity) after closing car using outside door button

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
raimuosius
Posts: 5
Joined: Fri Feb 18, 2011 11:00 pm
Year and Model: 2009 Volvo V70
Location: Vancouver, BC, Canada
Has thanked: 0
Been thanked: 0
raimuosius

2010 XC60 no power (electricity) after closing car using outside door button

Post by raimuosius » Thu Oct 25, 2018 4:59 pm

Yesterday drove to work, parked our 2010 XC60 T6 and locked it using drivers side door handle button (not a remote control). After work found car non-responsive. First impression - dead battery (XC60 known for that, satellite drain).
Asked friend to jump start our car. Nothing - no sign of any electricity. No lights, absolutely nothing, same as battery would not be there at all. Measured battery - 12.34V.... hmm it's full. Disconnected battery, connected again - lights on, central panel on, car started no problem.
Did a few test closing with remote, closing using button on the handle. Same thing - closing with remote - everything good, closing door with a handle button kills power completely. The only way to get back is by disconnecting battery and connecting it again.

I have no idea where to look for a problem. My best guest would be fuses.
Anybody had this before, any good ideas where to start to troubleshoot this problem

raimuosius
Posts: 5
Joined: Fri Feb 18, 2011 11:00 pm
Year and Model: 2009 Volvo V70
Location: Vancouver, BC, Canada
Has thanked: 0
Been thanked: 0
raimuosius

Re: 2010 XC60 no power (electricity) after closing car using outside door button

Post by raimuosius » Thu Oct 25, 2018 7:11 pm

found somewhere online, that resetting immobilizer might help, so I did:
to reset immobilizer lock and unlock car using remote control 5 times in the row" - so far it's good, problem is gone. I'm able to lock and unlock door by pressing button on the door handle. If it fails - I'll update.

jimmy57
Posts: 6522
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 3 times
Been thanked: 219 times
jimmy57

Re: 2010 XC60 no power (electricity) after closing car using outside door button

Post by jimmy57 » Thu Oct 25, 2018 9:28 pm

No special knowledge of this problem but it fits the scenario of a bad batt cable, bad connection, or corroded connection somewhere. It also fits the scenario of bad battery internal cell connector. That you had 12.34V from battery at some point is not eliminating battery.
To eliminate battery connect voltmeter to terminals of battery with alligator clips and then lock with the keyless button and then grab door handle to attempt entry. Read voltmeter to see if the battery voltage stayed relatively the same. If it falls and then recovers when the batt cable is pulled then get a battery.
If not battery then use voltmeter and check between points on terminals. The cable clamp to power strip in the fusebox in front of driver, the ground terminal to engine block. P3 models have had some issues with acid getting into cables. It doesn't always make the cable swell at the site of problem. If you check at different points on the same cable circuit (+ cable or - cable) the voltage with key on and lights on to give some load should not be more than 0.3V but is usually more like 0.05V

Post Reply
  • Similar Topics
    Replies
    Views
    Last post