IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Xc90 Starting Issue

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Cluelesslyhelpless
Posts: 1
Joined: Mon Jan 07, 2019 7:28 pm
Year and Model: 2009 Xc90
Location: Nebraska
Has thanked: 0
Been thanked: 0
United States of America
Cluelesslyhelpless

Xc90 Starting Issue

Post by Cluelesslyhelpless » Mon Jan 07, 2019 7:58 pm

I purchased my 2009 XC90 in November, it had sat on the lot for a few months. No issues whatsoever with starting. I replaced the battery knowing it was an older batter in early December. Roughly a week and a half ago my wife drove the vehicle to a farm and did chores, when she prepared to head home the car started but had no radio, no lights, no heat, no turn signals, no wipers, it was not a rough start. I read other forums that referenced the ignition switch as this cause.

I purchased a new Volvo ignition switch from FCP Euro and installed it tonight however no changes to my situation. When I open a door, the car beeps like a key is in the ignition. When I place the key in and move to sector l the radio turns on, the wipers and turn signals work. When I move the key to sector ll the radio turns off and will not turn on and near the end of sector ll before turning the car over the car starts while still in ll without ever having had cranked it over in lll. I am assuming it is maybe a bad spring where the key turns? There is a remote starter attached, and I'm not sure if I should take these wires off to have a look. I have tried to troubleshoot and read up on other parts, could the Volvo Ignition Immobilizer be bad and affecting this or could it be a bad tumbler?? Any suggestions? We can drive it in an emergency but it is not ideal. Thanks for thoughts..



User avatar
oragex
Posts: 4263
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 81 times
Been thanked: 177 times
Contact:
Canada
oragex

Re: Xc90 Starting Issue

Post by oragex » Tue Jan 08, 2019 12:21 pm

Not sure it's an immobilizer problem acting this weird. Maybe a barrel problem ? Does the alternator pump a decent 13.8-14.5V ?


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

Post Reply