IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Car won't start - ECM-640C ECM-640D ECM-929D

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Metallo
Posts: 220
Joined: Sun Jan 18, 2004 3:20 pm
Year and Model: XC 70 AWD 2.5 - 2006
Location: Canada
Has thanked: 1 time
Been thanked: 2 times
Canada
Metallo

Car won't start - ECM-640C ECM-640D ECM-929D

Post by Metallo » Tue Jan 22, 2019 6:41 pm

Hi folks,

My XC70 AWD 2006 cannot start, but let me give you some background.

One month ago I noticed that the car was bogging down when I was accelerating on the highway, let's say, it was hesitating before getting up to the speed I wanted.
I thought it was time to replace the spark plugs which were 100K old, so last Saturday, I replaced the original Volvo sparks with the NGK 7092.
The old sparks were really worn, besides #3 #4 and #5 were soaked with oil... #2 and #5 were just worn.
I think the reason why #3 #4 and #5 were soaked with oil is because 6 months ago I realized the PCV hose was broken, I replaced it but there was plenty of oil next to the ignition coils location. I cleaned everything but I guess the oil might have gone down the threads of the sparks.

Image

Anyhow, once the sparks have been replaced, the car started immediately and the engine sounded totally different, very smooth and clean.
Yesterday, after a few minutes I was driving the car (cold start, I am in Canada so well below freezing point right now) the engine almost stopped, as if not enough fuel was getting there, I pulled over, did not touch the throttle pedal, after a few seconds the engine rpm went up to normal again.
This morning, no start at all.

I was convinced something was wrong with the ignition coils, but the VIDA errors say something different.

Image

Image

Image

Image

I was able to start the car again one more time while I was plugged in with VIDA, the engine stayed idle for about 10 minutes, then it stopped.

I understand the meaning of the codes, but I do not know where to start from.

Any chance this is related to the spark plugs or the ignition coils or anything I might involuntarily done during the replacement?
It is difficult for me to think of a pure coincidence.

Many thanks for your advice :)

Alex
Polar 940 Turbo SW - 1997
XC 70 AWD 2.5 - 2005
XC 70 AWD 2.5 - 2006

Metallo
Posts: 220
Joined: Sun Jan 18, 2004 3:20 pm
Year and Model: XC 70 AWD 2.5 - 2006
Location: Canada
Has thanked: 1 time
Been thanked: 2 times
Canada
Metallo

Re: Car won't start - ECM-640C ECM-640D ECM-929D

Post by Metallo » Thu Jan 24, 2019 10:35 am

Has anybody an opinion on this issue?

I think the genuine spark plugs have a 0.28" gap, do you think the gap of platinum spark plugs need to be the same??

Any way those errors can be linked to the spark plugs?

Alex
Polar 940 Turbo SW - 1997
XC 70 AWD 2.5 - 2005
XC 70 AWD 2.5 - 2006

Metallo
Posts: 220
Joined: Sun Jan 18, 2004 3:20 pm
Year and Model: XC 70 AWD 2.5 - 2006
Location: Canada
Has thanked: 1 time
Been thanked: 2 times
Canada
Metallo

Re: Car won't start - ECM-640C ECM-640D ECM-929D

Post by Metallo » Sat Jan 26, 2019 3:55 pm

Hi there,

The reason of the errors was the low compression, due to my negligence, the intercooler pipe was completely disconnected on the back of the engine.

Image

Most likely the reason is because when I tightened the clamp, I did not fully push down the hose in the connector, so it popped out.

Once I realized the issue, I was (and still I am) pissed off with myself, I am always very careful on everything I work on, in addition, I removed/re-hooked that hose multiple times in the past, never an problem... I cannot explain this stupid error.

I removed the spark plugs, made them 0.030", no oil on any on them.

Did a VIDA check, clean.

Well, I hope at least I made you laugh!

Thank you for your time anyhow.

Alex
Polar 940 Turbo SW - 1997
XC 70 AWD 2.5 - 2005
XC 70 AWD 2.5 - 2006

Post Reply
  • Similar Topics
    Replies
    Views
    Last post