IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Engine weird sound - 3.2 - XC90 2011

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 2:14 pm

This is the first video. I am going up an incline. img_8892.MOV
You do not have the required permissions to view the files attached to this post.



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 2:15 pm

...and this is the second. IMG_8893.MOV
I am on a flat surface.

Both shot with an iPhone
You do not have the required permissions to view the files attached to this post.



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 2:19 pm

files uploaded



User avatar
pgill
Posts: 143
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 11 times
Been thanked: 22 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Wed Apr 17, 2019 3:04 pm

I also own two 3.2's

The person on this site with the most 3.2 knowledge is probably Jimmy57 you can send him a P.M. and see if he can help you

If it were me I would do the following (note: if Jimmy suggest a different order or different items for trouble shooting then follow his suggestion not mine, I've only every worked on two 3.2's, he has worked on a lot more, and my 3.2's haven't had the problem that you are describing)

1. Spark-plugs Denso Iridium (5344) IKH20
2. Motor Oil Mobil 1 0W40
3. MAF remove and clean
4. Check LTFT and STFT (Long term fuel trim and short term fuel trim) LTFT should be less than 10 and close to 0
5. Replace fuel rail pressure sensor
6. Replace MAF
7. Replace the PCV cover
8. Drive 500 miles and check condition of spark-plugs
9. Replace the Thermostat (Known failure at about 10 years or 120,000 miles) High engine temperature may cause pinging

Good Luck

Paul
These users thanked the author pgill for the post:
matthew1



User avatar
matthew1
Site Admin
Posts: 9929
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 401 times
Been thanked: 151 times
United States of America
matthew1

Re: Engine weird sound - 3.2 - XC90 2011

Post by matthew1 » Wed Apr 17, 2019 3:11 pm




^ I put them up on the MVS YouTube channel so everybody interested doesn't have to download them.


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
pgill
Posts: 143
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 11 times
Been thanked: 22 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Wed Apr 17, 2019 3:14 pm

The video's help

The check engine light is on what code is stored?

The check engine light didn't flash (the engine management system doesn't think that you have a misfire)

If you shift into manual mode will the engine go to Redline in first gear (it doesn't need to be on the hill)

Goodluck

Paul



Masscomguru
Posts: 96
Joined: Sun Nov 18, 2012 5:41 am
Year and Model: 2008 XC90
Location: Massachusetts
Has thanked: 0
Been thanked: 9 times
Masscomguru

Re: Engine weird sound - 3.2 - XC90 2011

Post by Masscomguru » Thu Apr 18, 2019 6:54 am

Check the upper torque mount for side to side play. When they get loose, they rattle and it gives that metallic sound. The 40 dollar hutchinson from FCP is the volvo one with the volvo part number ground off.



KLR142
Posts: 18
Joined: Tue Sep 08, 2009 10:49 pm
Year and Model: 1991 244
Location: Oregon
Has thanked: 0
Been thanked: 0
United States of America
KLR142

Re: Engine weird sound - 3.2 - XC90 2011

Post by KLR142 » Thu Apr 18, 2019 11:56 pm

Do NOTHING until you replace the worn out upper torque mount. Get a Hutchinson brand or Volvo.



User avatar
pgill
Posts: 143
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 11 times
Been thanked: 22 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Fri Apr 19, 2019 12:28 am

For me personally I didn’t notice any noise due to a failed torque mount on my S80

I do recommend that you change the mount under the torque mount at the same time if it has collapased

See this link for torque mount info

http://www.freel2.com/forum/topic32979.html

Good luck

Paul



KLR142
Posts: 18
Joined: Tue Sep 08, 2009 10:49 pm
Year and Model: 1991 244
Location: Oregon
Has thanked: 0
Been thanked: 0
United States of America
KLR142

Re: Engine weird sound - 3.2 - XC90 2011

Post by KLR142 » Fri Apr 19, 2019 12:54 am

The XC90s don’t have the same setup and when the torque mount is this worn out, it can make some very concerning noises. The P3 chassis cars don’t have the same noise when their mount(s) are worn and that right mount collapses a lot on those, but not the P2 based XC90.



Post Reply