IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2001 Volvo S60 Turn signal issue Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Alexis2929
Posts: 11
Joined: Mon Apr 15, 2019 7:45 pm
Year and Model: 2001 S60
Location: Arizona
Has thanked: 6 times
Been thanked: 0
United States of America
Alexis2929

2001 Volvo S60 Turn signal issue

Post by Alexis2929 » Wed Apr 17, 2019 6:13 pm

Left turn signal doesn’t go on at all outside but blinks rapidly inside. Left hazard also does not work but inside both blink at the same time and pace. When I turn on the left turn signal a left turn signal bulb failure warning comes on. I’ve checked the lights but they’re not burnt. Including the one in the center.

I’ve checked the CEM but the shunts seem to be working fine. I switched them around and none seemed to solve the issue.

All fuses are fine

Any help would be much appreciated I’ve put in lots of time and effort into this.



MDK
Posts: 447
Joined: Sun Apr 08, 2018 5:43 pm
Year and Model: 1998 xc 70
Location: Ohio
Has thanked: 0
Been thanked: 27 times
United States of America
MDK

Re: 2001 Volvo S60 Turn signal issue

Post by MDK » Thu Apr 18, 2019 5:17 am

It's got to be a bulb somewhere...or a bad connection in the rear tail light assy. In the old days ( the 90's) most cars have a thing called a flasher... make the signal flash. I don't know if a 2001 Volvo has that set up...MDK



cn90
Posts: 6442
Joined: Wed Mar 31, 2010 9:54 am
Year and Model: 2004 V70 2.5T
Location: Omaha NE
Has thanked: 0
Been thanked: 82 times
United States of America
cn90

Re: 2001 Volvo S60 Turn signal issue

Post by cn90 » Thu Apr 18, 2019 5:48 am

Probably bad contacts inside the turn signal stalk.

Search for the DIY, where you remove the stalk (two Torx bolts), and clean the contacts with fine sand paper. Then add a bit if grease.

It is a FREE fix.


2004 V70 2.5T 100K+
2005 XC90 2.5T 110K+

93SCMax
Posts: 236
Joined: Sat Feb 11, 2012 10:41 am
Year and Model: 2001 V70 T5 mt
Location: Lowcountry, SC
Has thanked: 9 times
Been thanked: 15 times
United States of America
93SCMax

Re: 2001 Volvo S60 Turn signal issue

Post by 93SCMax » Thu Apr 18, 2019 6:14 am

I'll offer a few hints to hopefully help with your troubleshooting.

You say the bulbs in question on the left side are good. Have you moved them to the right side to see if they work? Have you moved the bulbs from the right side to the left to see if they work? This could help eliminate if it is one of your bulbs. If left side works in the right side, and right side does not work in left side, your issue is elsewhere (socket, stalk, wiring, relay, etc.). Try one bulb at a time, starting with the front bulbs.

Volvo's are very sensitive with the bulbs you use. I've also had "good" bulbs that didn't work. I've learned to only use high quality bulbs, mainly Sylvania/Osram and hopefully manufactured in Germany. They may cost a little more but work well and last longer.

I suspect you have a bulb or socket issue. Share your results. Good luck troubleshooting.
These users thanked the author 93SCMax for the post:
Alexis2929



User avatar
oragex
Posts: 4308
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 82 times
Been thanked: 189 times
Contact:
Canada
oragex

Re: 2001 Volvo S60 Turn signal issue

Post by oragex » Thu Apr 18, 2019 9:38 am

As above, I would venture removing the bulbs and look for corrosion or for a slightly broken bulb filament www.youtube.com/watch?v=Aq0V_anGtUw
You can also undo the stalk and maybe try replacing with used one from 01-03, but I would rather bet on the bulb sockets in the first place www.youtube.com/watch?v=gCSbTSj1THI



chrism
Posts: 951
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Has thanked: 0
Been thanked: 19 times
chrism

Re: 2001 Volvo S60 Turn signal issue

Post by chrism » Fri Apr 19, 2019 8:51 am

Don’t assume a bulb is good by just looking at the filament. They often break down within the base where you can’t see the problem. If the metal bulb base is at all loose on the glass part then toss it.



Alexis2929
Posts: 11
Joined: Mon Apr 15, 2019 7:45 pm
Year and Model: 2001 S60
Location: Arizona
Has thanked: 6 times
Been thanked: 0
United States of America
Alexis2929

Re: 2001 Volvo S60 Turn signal issue

Post by Alexis2929 » Fri Apr 19, 2019 12:17 pm

I’ve moved the bulbs from left to right and still nothing on the left turn signal.

I looked into the CEM and there is no power on the left turn signal shunt
This would ecplain why my hazards also don’t work but could s bad ground not give power to the CEM ?
Or does the CEM distribute it.



93SCMax
Posts: 236
Joined: Sat Feb 11, 2012 10:41 am
Year and Model: 2001 V70 T5 mt
Location: Lowcountry, SC
Has thanked: 9 times
Been thanked: 15 times
United States of America
93SCMax

Re: 2001 Volvo S60 Turn signal issue  Topic is solved

Post by 93SCMax » Fri Apr 19, 2019 3:22 pm

So you've eliminated the bulbs as the problem.

Original post said CEM and shunts were fine, even swapping shunts made no difference. Your last post says you have no power to the left turn signal shunt. So you are confident that you have no power and it is not the shunt for the left circuit?

I'd suspect the CEM, although my original thoughts were a bad socket or ground somewhere. Maybe someone with a strong electrical background on the CEM will chime in. If you have no power at the CEM with both the blinker and the hazards, then it shouldn't be the stalk.
These users thanked the author 93SCMax for the post:
Alexis2929



Post Reply