IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Still Crank No Start. Very Strange

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Still Crank No Start. Very Strange

Post by goldmandan »

Ok so i'm back to battling this weird issue. I have a 2001 S60 2.4T which I put a brand new Volvo battery in. If battery has been disconnected it and I connect it again the engine will crank and I have to "feather" the gas to get it to start. Once started it runs strong with no trouble and I drive it a bit, shut it off and it will start back up. Now, If I leave the car sit for a few days, it will just crank forever and not start, even if feathering the gas. What can this be? Parasitic draw bringing voltage too low to allow for it to start?? I do have a stored "code" but no check engine light on. The code points to fuel relay positive high resistance or something to that matter. I swapped that relay just tonight. have put the battery on charge overnight so let's see what happens tomorrow

Any input is GREATLY appreciated! I'm breaking my head over this!

Dan
Last edited by matthew1 on Thu Jul 04, 2019 5:36 pm, edited 1 time in total.
Reason: improved title
User avatar
oragex
Posts: 5022
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 99 times
Been thanked: 297 times
Contact:

Re: Still Crank No Start........... VERY STRANGE

Post by oragex »

It looks like you don't get gas - or at least not enough pressure. How is the fuel filter ? Would also look at the fuel pressure sensor if there's one (less probable if the car drives fine)

Very possible a current drain - usually the alarm siren will cause that, easy to just remove its fuse. Mind you, the new car battery will get damaged if it's constantly drained when parked. I would leave it disconnected (+ cable off) to preserve it, until you find the issue.

A 10A voltmeter can be used to measure any drain and also the battery. I will soon post a video showing how to measure these on the S60

How is the temp gauge moving once the engine starts, does it climb slowly and steadily to 12 ?
goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Re: Still Crank No Start........... VERY STRANGE

Post by goldmandan »

Temp gauge shows fine, I have a leak in the hose that goes under the intake to the thermostat housing from when I replaced PCV box a "low coolant, stop car soon" message would not keep it from starting would it?
I replaced the ECM from another 2001 S60 assuming it may be the cause. Once I installed it and put the freshly charged "new" battery it almost started but didnt, it smells of gas as if flooding and I pulled all plugs and checked compression 150 all across on all cyls. I cranked engine with all plugs out to air out any flooding.... replaced plugs and coils as well as fuel injector connectors..... still will crank and not start.
I suspect someone has already disconnected the alarm connector as the sunroof works and when I lock the car the lights will not blink

anything I may have overlooked? I have a 2003 that is rough looking but runs fine, am planning to borrow the fuel injectors to see if that may fix the problem....... fuel filter I don't know if it's been replaced on the non starting one.....
goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Re: Still Crank No Start........... VERY STRANGE

Post by goldmandan »

Ok put the old ECM in and now the car starts and runs fine! WTF!?!?!?!?
User avatar
abscate
MVS Moderator
Posts: 22495
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 376 times
Been thanked: 1176 times

Re: Still Crank No Start........... VERY STRANGE

Post by abscate »

Put a fuel pressure gauge on The fuel rail to confirm 50 psi fuel pressure. It needs to be spot on pressure in P2 cars, unlike the earlier ones
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
User avatar
abscate
MVS Moderator
Posts: 22495
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 376 times
Been thanked: 1176 times

Re: Still Crank No Start........... VERY STRANGE

Post by abscate »

When the ecm software andVIN aren’t matched the car will catch and run for a second then stop. It usually won’t fire again until the mismatch code is cleared internally by the ECM
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Re: Still Crank No Start. Very Strange

Post by goldmandan »

ok will check fuel pressure tomorrow!

Dan
goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Re: Still Crank No Start. Very Strange

Post by goldmandan »

Abscate,

Would an immobilizer code trigger if you installed a wrong ECM?
User avatar
abscate
MVS Moderator
Posts: 22495
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 376 times
Been thanked: 1176 times

Re: Still Crank No Start. Very Strange

Post by abscate »

goldmandan wrote: Fri Jul 05, 2019 5:57 am Abscate,

Would an immobilizer code trigger if you installed a wrong ECM?
I don’t think so. Trying to remember the code someone posted here once. I thought it was something like ECM mismatch but I’ll try to search and see.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
goldmandan
Posts: 244
Joined: Wed Jun 05, 2013 8:27 pm
Year and Model: 1999 S 70, 2000 V70
Location: Florida
Been thanked: 1 time

Re: Still Crank No Start. Very Strange

Post by goldmandan »

Abscate,

I had the car running the other day and it would shut off and fire right back up again. Then I disconnected the negative for the weekend as I didn't want a parasitic draw to be the cause of not starting. Just connected battery and it took a while again to get it started..... I did find a coolant leak and fixed that and swapped the after market coils I bought back to the OEM ones. Once it starts it runs fine. It has the "low coolant, stop car asap" message on the dash eventhough the reservoir is full.. Where is the low coolant sensor located on 2001?? It's not in the reservoir! Maybe the thermostat housing? I resealed that also. OH, and when I plugged my scanner in it would not pick up any VIN.... meaning the ECM doesn't respond............... is this an ECM issue maybe????

So confused....
Dan
Post Reply
  • Similar Topics
    Replies
    Views
    Last post