IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

RPM/Shift flares Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Nathan79
Posts: 12
Joined: Thu Dec 28, 2017 12:41 am
Year and Model: 07 XC70
Location: Colorado
Has thanked: 0
Been thanked: 4 times
United States of America
Nathan79

RPM/Shift flares

Post by Nathan79 » Fri Aug 09, 2019 8:27 am

Daily Driver 07 Xc70, 175k symptoms: Driving (keeping rpms under 2500) shifts wonderful, zero issues.
However when getting RPM'S get between 2500/3000 there is a RPM flare, & if Throttle maintains its position the RPM flare will repeat until throttle position is changed... Somewhere in the neighborhood of 300-1000 RPMs flare
When driving (from a stop or already cruising doesn't matter) and throttle is "pressed with conviction" and RPMS get to 3000-3500 before shifting...sounds rowdy and I'm off to the races.
No codes ever... Been driving it this way for about 10k miles...Not getting worse OR better.
Also worth mentioning...ABS module is out, no brake power boost, odometer not functioning (but will momentarily show that its working upon startup sometimes)

Things I've done so far(after symptoms started): tranny fluid flush & b4 servo piston swap. *Charging system tested good... However I'm not sure if it was tested under 3000 rpm load.

Thanks for any help
Nathan

User avatar
SuperHerman
Posts: 1332
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: RPM/Shift flares

Post by SuperHerman » Fri Aug 09, 2019 9:27 am

Try taking a look at the throttle boy. Maybe give it a cleaning.

User avatar
oragex
Posts: 4595
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 232 times
Contact:
Canada
oragex

Re: RPM/Shift flares

Post by oragex » Fri Aug 09, 2019 3:09 pm

I've read on a website with reviews that the throttle body on these late 2007-2009 S60 may have problems (not the same as early 01-02)
Not saying is sure. Maybe ask Xemodex guys, see if they are aware of such issues.
If you go that way, maybe try getting a used one from the junk yard - not sure about programming/compatibility

Nathan79
Posts: 12
Joined: Thu Dec 28, 2017 12:41 am
Year and Model: 07 XC70
Location: Colorado
Has thanked: 0
Been thanked: 4 times
United States of America
Nathan79

Re: RPM/Shift flares  Topic is solved

Post by Nathan79 » Mon Aug 12, 2019 12:41 pm

Thanks for the time & thought! I will pursue ETM...

Nathan79
Posts: 12
Joined: Thu Dec 28, 2017 12:41 am
Year and Model: 07 XC70
Location: Colorado
Has thanked: 0
Been thanked: 4 times
United States of America
Nathan79

Re: RPM/Shift flares

Post by Nathan79 » Tue Aug 27, 2019 6:11 pm

So...what had happened was, about a week ago I went to leave for work after firing & warming up, but pedal was NOT responsive. Figured that it was the ETM, so ordered remaned OEM for about $100... Installed,without any flash and we're back to business

Nathan79
Posts: 12
Joined: Thu Dec 28, 2017 12:41 am
Year and Model: 07 XC70
Location: Colorado
Has thanked: 0
Been thanked: 4 times
United States of America
Nathan79

Re: RPM/Shift flares

Post by Nathan79 » Thu Dec 19, 2019 7:31 am

A follow up... So, yes the ETM failed. But I believe the REAL source of the problem to have been a "thrashed" intake pipe. Even after the ETM replacement there was still "surging" happening @ about 2700 rpms. Once I replaced intake with an upgraded Snaab pipe 😉... ZERO RPM flares.
FYI... Intake pipe was heavily cracked @ turbo connection site.

Fun fun fun
These users thanked the author Nathan79 for the post:
abscate

User avatar
abscate
MVS Moderator
Posts: 19919
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 262 times
Been thanked: 841 times
Trinidad & Tobago
abscate

Re: RPM/Shift flares

Post by abscate » Thu Dec 19, 2019 7:34 am

Thanks for follow up Nathan...it’s typical to have more than one thing wrong. I wonder if the leak in the pipe was fluttering the throttle body and led to early failure. Pure speculation on my part.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Nathan79
Posts: 12
Joined: Thu Dec 28, 2017 12:41 am
Year and Model: 07 XC70
Location: Colorado
Has thanked: 0
Been thanked: 4 times
United States of America
Nathan79

Re: RPM/Shift flares

Post by Nathan79 » Thu Dec 19, 2019 9:06 am

My thoughts exactly abscate. Makes sense at least. As usual... You guys on here ROCK!! I'm on here more often than I'd like to be, but who knows where I'd be WITHOUT you guys... Thank you so much for keeping us Volvo lovers...well...loving our volvos!!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post