Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

02 xc70 help misfire

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive P2 platform cars sold as model years 2001-2007 (North American market year designations).

2001 - 2007 V70
2001 - 2004 V70 XC (Cross Country)
2004 - 2007 XC70 (Cross Country)
2001 - 2009 S60
2003 - 2007 S60 R
2004 - 2007 V70 R

Post Reply
xc70066
Posts: 1
Joined: Sat Mar 03, 2012 3:47 pm
Year and Model: 2002
Location: new jersey

02 xc70 help misfire

Post by xc70066 »

Thank you for reading my post, it is my first time posting here but I have gotten a ton of great info from here.

I recently was driving home and had my oil pressure warning of no pressure come on and found the car was puking oil. I diagnosed it down to clogged pcv which caused (so far) my cam seal to leak oil.
I washed the engine down trying to find the leak and the car started to run rough while leak searching due to what I speculate was from the engine washing. I tore everything down and found the lower pcv port clogged which I cleaned out and fixed. I put it all back together and also replaced the front cam seal.

The leak was fixed from that seal but the car was running terribly rough and was spewing raw fuel out the exhaust. I bought a scanner and got codes 0300, 0301, 0302,0134, I then went and changed the all plugs and the #1 & 2 cylinder coil pack. the car still ran rough but I let it run for a while and the white smoke started to clear and less fuel came out of the exhaust. I cleared the codes and they stayed off for a while but the cel came back on and I am still getting a code for 0302.

I do not know where to go from here.....please help me. The car has 143k miles and I also did the oil pan o rings 5k miles ago.

jking4020
Posts: 83
Joined: Mon Apr 04, 2016 6:48 pm
Year and Model: 1997 850, 2001 v70xc
Location: nebraska

Post by jking4020 »

Did you ever find out about the 0134 code? Its o2 sensor right?

User avatar
RickHaleParker
Posts: 5666
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 4 times
Been thanked: 713 times

Post by RickHaleParker »

xc70066 wrote: Sat Mar 03, 2012 4:08 pm I cleared the codes and they stayed off for a while but the cel came back on and I am still getting a code for 0302.

I do not know where to go from here.....please help me. The car has 143k miles and I also did the oil pan o rings 5k miles ago.
Check for Air leaks at #2 intake.
Do a compression test.
Swamp injector #2 with #3, see if the misfire moves to #3.

Are you sure the smoke was White and not Gray, Blue, Blue-Gray or Black?
White is steam = coolant leaking into combustion chamber.
Gray, Blue or Blue-Gray = Oil.
Black is too much fuel.
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

User avatar
abscate  
MVS Moderator
Posts: 24967
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99: V70s S70s,05 V70
Location: NYC, ALBANY NY
Has thanked: 504 times
Been thanked: 1498 times

Post by abscate »

Ancient 7nyear old thread. The car is a toaster by now.

Time for some pHp code, Matt!
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread

Post Reply