IPD sale XeMODeX - Experts in Volvo Electronics
Marking "Topic Solved" is functional again. It's the green check next to your post. BTW, please do use this when your question is answered and verified. Thanks!
MVS-Amazon link helps MVS!

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

1998 V70 T5; problem hot starting & occasional brief power loss at speed

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

If injectors spray when hot , What could be my next point of focus ? ECU ?
User avatar
abscate
MVS Moderator
Posts: 23770
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 443 times
Been thanked: 1339 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by abscate »

If it fires in ether, and the injectors are delivering fuel, the fuel delivery amount is wrong.

I think you need an oscilloscope to confirm the injector pulse ( more accurately , how long the ECU isnpulling the injectors to ground

An ECU swap is the Mossberg method if you can’t get a scope , but you are getting close, not much else left

Send me your coordinates, TX travel planned soon.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

Dallas. Been busy with work and family . Could injector relay act just like a fuel pump relay ? Meaning , could it stop working or cause a stall when hot ?
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

Also , while doing research, I saw something about air pump relay having the same " value " as the injector relay . I guess this means they are interchangeable ? If so , I have a few relays from a salvage run that I could try . Thoughts and helping opinions always welcomed !
User avatar
misha
Posts: 4577
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 67 times
Been thanked: 176 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by misha »

They are NOT interchangeable and also visualy not the same.
Yes...main fuel injection relay could make problems when it becomes hot....just like any other relay.
Try to swap it with a used one and see if problems go away.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS
User avatar
erikv11
Posts: 10144
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, V70, S60R, XC70
Location: Iowa
Has thanked: 129 times
Been thanked: 364 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by erikv11 »

erikv11 wrote: Tue Sep 17, 2019 5:41 pm There's also the gray fuel injection main relay up under the radiator - or maybe that relay is not used on a 98? My 98 is not here or I would check. Someone else will remember.

It's basically guaranteed to be an electrical/electronic part, that when it heats up the resistance gets too high. V = IR so currrent drops and the component stops working and the car stops working. Could be a relay, sensor, or a critical wire that is thin or poorly connected.
:mrgreen:
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'07 XC70, 170k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

Thanks for the reply .I'll make a salvage run this weekend. You quoted from the same thread I read .
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

Hello ! Today I spoke with local Volvo dealer about price of a injector relay ( local salvage yards are bare of S70s ), and the part number matches main relay in main fuse box. I called back and was emailed a schematic showing the location was in the main fuse box , not under radiator cover . Only thing on radiator cover is cooling fan connections.

From the pic , it seems it goes in slot #2 in fuse box , which is labeled Air Pump on the underside of fuse cover . I have no fuse there , never have . Maybe that was to show general location. I think , maybe my problem is the main relay itself ? I have a matching relay from previous salvage run that I'll put in and see what I get . Any input is welcomed !
clifford06
Posts: 348
Joined: Thu Aug 01, 2013 5:03 pm
Year and Model: 2000 T5
Location: texas
Has thanked: 6 times
Been thanked: 4 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by clifford06 »

Swapped main relay after getting car to temp, and still same result . I'll swap cam sensor next .
User avatar
erikv11
Posts: 10144
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, V70, S60R, XC70
Location: Iowa
Has thanked: 129 times
Been thanked: 364 times

Re: 1998 V70 T5; problem hot starting & occasional brief power loss at speed

Post by erikv11 »

Yeah, I didn't think the 98 had the relay at the radiator. This is a sticky one hang in there ...
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'07 XC70, 170k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k
Post Reply
  • Similar Topics
    Replies
    Views
    Last post