IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Fuel Pump Not Running Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

turboman850
Posts: 33
Joined: Sun Oct 13, 2019 5:36 pm
Year and Model: 1995 Volvo 850 Turbo
Location: Russelville, AR
Has thanked: 0
Been thanked: 0
United States of America
turboman850

Re: Fuel Pump Not Running

Post by turboman850 » Mon Oct 28, 2019 1:55 am

This from 1995 Volvo 850 Review: cartestdrive.com
Standard on the Turbo and a $500 option for the base level 850 and 850 GLT, the side bags join dual front airbags, Volvo’s SIPS (Side Impact Protection System) and new Daytime Running Lights as the most comprehensive passive safety package yet available from any carmaker.
At the top of the line, the Turbo package adds the side-impact airbags, split leather upholstery and electronic climate control.
If you go to Parts Geek search 1995 Fue/Inertial Shut-Off Valve and has for my 850 turbo yrs '92-'96.



turboman850
Posts: 33
Joined: Sun Oct 13, 2019 5:36 pm
Year and Model: 1995 Volvo 850 Turbo
Location: Russelville, AR
Has thanked: 0
Been thanked: 0
United States of America
turboman850

Re: Fuel Pump Not Running

Post by turboman850 » Tue Oct 29, 2019 9:51 pm

checked wiring from pin 87 fuel pump relay with jump box 12v and pump runs.



User avatar
abscate
MVS Moderator
Posts: 19255
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 232 times
Been thanked: 767 times
Trinidad & Tobago
abscate

Re: Fuel Pump Not Running

Post by abscate » Wed Oct 30, 2019 6:31 am

Excellent

Now work your way from the relay and check if the 12V isnt getting to the pump because

either

1 The fuel pump relay isnt getting a 12V feed - check upstream for 12V fault

B The fuel pump relay isnt getting triggered to close, or isnt closing.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

turboman850
Posts: 33
Joined: Sun Oct 13, 2019 5:36 pm
Year and Model: 1995 Volvo 850 Turbo
Location: Russelville, AR
Has thanked: 0
Been thanked: 0
United States of America
turboman850

Re: Fuel Pump Not Running

Post by turboman850 » Wed Oct 30, 2019 4:01 pm

Waiting to receive a checked out used Main Fuel Relay from Mayflower Volvo. She supposed to call back. This will have the connector attached w long enough wies that I can slice it in for good connection at the relay. My connector is gone and broke a brittle wire. So need get and do this before go any farther.
Going to clean MAF Sensor and EGR Valve w carb cleaner tomorrow. Might as well. Cheap fix. Trying to knock out any and all suggested problems while car is down.
After all this if not start I'll start into Timing Belt...UUHHGG!!



turboman850
Posts: 33
Joined: Sun Oct 13, 2019 5:36 pm
Year and Model: 1995 Volvo 850 Turbo
Location: Russelville, AR
Has thanked: 0
Been thanked: 0
United States of America
turboman850

Re: Fuel Pump Not Running

Post by turboman850 » Wed Oct 30, 2019 4:04 pm

Checked on a kit for Fuel Pressure...$120...Nope! Have pressure at back by tank and at injectors where release valves are. Doubt this the problem.



User avatar
erikv11
Posts: 9374
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 72 times
Been thanked: 228 times
United States of America
erikv11

Re: Fuel Pump Not Running

Post by erikv11 » Wed Oct 30, 2019 4:50 pm

turboman850 wrote:
Wed Oct 30, 2019 4:01 pm
... Going to clean MAF Sensor and EGR Valve w carb cleaner tomorrow. Might as well. Cheap fix. ...
Don't use carb cleaner on the MAF!!! It will likely ruin the sensor, and be an expensive non-fix.

I post this over and over again on here: there is no point in cleaning the MAF unless (1) it is visibly dirty or (2) you have tested it and it is known to be bad. Otherwise, 99% of the time, cleaning the MAF does nothing more than sell MAF cleaner.


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

User avatar
abscate
MVS Moderator
Posts: 19255
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 232 times
Been thanked: 767 times
Trinidad & Tobago
abscate

Re: Fuel Pump Not Running

Post by abscate » Wed Oct 30, 2019 5:20 pm

turboman850 wrote:
Wed Oct 30, 2019 4:01 pm
Waiting to receive a checked out used Main Fuel Relay from Mayflower Volvo. She supposed to call back. This will have the connector attached w long enough wies that I can slice it in for good connection at the relay. My connector is gone and broke a brittle wire. So need get and do this before go any farther.
Going to clean MAF Sensor and EGR Valve w carb cleaner tomorrow. Might as well. Cheap fix. Trying to knock out any and all suggested problems while car is down.
After all this if not start I'll start into Timing Belt...UUHHGG!!

Did you find no 12 V supply at the fuel pump relay?

Don’t skip steps!


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

turboman850
Posts: 33
Joined: Sun Oct 13, 2019 5:36 pm
Year and Model: 1995 Volvo 850 Turbo
Location: Russelville, AR
Has thanked: 0
Been thanked: 0
United States of America
turboman850

Re: Fuel Pump Not Running

Post by turboman850 » Wed Nov 06, 2019 5:14 pm

Ok...now still no pump start. Checking voltages Everywhere!! Well...No readings on pin 86 of FPR to the actuator side for pull down switch side and start fuel pump. Put 12v at Main Fuel Relay w jump in FPR...pump runs fine.
Now checking cont. mod for signal/voltage to the pin 86 from pin 27 of Cont. Mod. there is No Pin in 27 and counted out like 5x. This send volts to close switch to pump. Ooww!! Schematic I been using pins not correlate to print!! And no where in the pins give "ohm" reading to pin 86 of FPR!!! So now in a search of "correct" print and schematic of Cont. Module. You got any help out t fellow Volvo there '95 Volvo 850 Turbo Sportwagon????



User avatar
abscate
MVS Moderator
Posts: 19255
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 232 times
Been thanked: 767 times
Trinidad & Tobago
abscate

Re: Fuel Pump Not Running

Post by abscate » Thu Nov 07, 2019 4:28 am

Watch your acronyms. FPR is commonly used for fuel pressure regulator , which doesn’t have electrical connections.

Using the wrong electrical diagram is frustrating indeed. It’s even worse when you find out you have the right one, but it has mistakes, got that T-shirt courtesy of VWOA.

I think right now

Your pump runs with 12V at the main relay and the fuel pump relay jumped...conclusion, fuel pump and wiring from main relay to pump is good.

You aren’t getting 12V to the main relay.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

shegarty
Posts: 262
Joined: Mon Sep 12, 2011 7:38 am
Year and Model: 1998
Location: port hope
Has thanked: 7 times
Been thanked: 2 times
Canada
shegarty

Re: Fuel Pump Not Running

Post by shegarty » Thu Nov 07, 2019 6:11 am

abscate wrote:
Thu Nov 07, 2019 4:28 am
Your pump runs with 12V at the main relay and the fuel pump relay jumped...conclusion, fuel pump and wiring from main relay to pump is good.

You aren’t getting 12V to the main relay.
+1 - check all wiring (power AND ground) to and from the main fuel system relay. Ditch the wiring diagram if its giving you that much trouble and manually trace each wire using a continuity test. Check all the connections, especially any pins inside the connectors. You can back probe both sides of a two part connection to make sure the pins inside are making contact. Be sure to use a small piece of wire (or a paperclip) so that you don't disturb the connector.


current - 98 S70 T5 SE (255k km)
previous - 90 745T (400k km - sold); 94 855 T5 - (206k km - blown timing idler bearing)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post