IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

S70 2.5t misfire

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

radek93
Posts: 26
Joined: Sat Dec 07, 2019 2:43 pm
Year and Model: S70 98
Location: Home
Has thanked: 0
Been thanked: 0
Poland
radek93

S70 2.5t misfire

Post by radek93 » Fri Jan 31, 2020 3:41 pm

I have S70 2.5t 98r B5254t and I have no idea. I replaced:
Spark plug
Ingition cable
Rotor
Cap
Ingition coil
Crankshaft sensor
Camshaft sensor
TPS
O2 sensor
Coolant sensor
Compresion is ok. No air leak i thing. No fault code.
When I drive, car have 1s misfire on 20 kilometers. Sometimes more often, sometimes less often. Sometime when engine working on idle, rotation degrese to 500 a grow up back to 900 in one sec.
I have idea that a ecu is broken.

User avatar
misha
Posts: 4204
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 54 times
Been thanked: 117 times
Serbia
misha

Re: S70 2.5t misfire

Post by misha » Fri Jan 31, 2020 3:48 pm

Parts that had been replaced....are they OE,OEM or aftermarket?
Which spark plugs are used?
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

radek93
Posts: 26
Joined: Sat Dec 07, 2019 2:43 pm
Year and Model: S70 98
Location: Home
Has thanked: 0
Been thanked: 0
Poland
radek93

Re: S70 2.5t misfire

Post by radek93 » Fri Jan 31, 2020 3:59 pm

I used oem cable, tps. Other parts aftermarket. I used three brand of spark plug. First on oem. I forgot to add, car have LPG. On LPG or petrol is that same.

User avatar
misha
Posts: 4204
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 54 times
Been thanked: 117 times
Serbia
misha

Re: S70 2.5t misfire

Post by misha » Fri Jan 31, 2020 5:17 pm

Rotor & cap,o2 sensor,crankshaft,camshaft sensors...coil MUST be OEM Bosch.
ECT especially MUST be OE Volvo or at least Vernet.

Since almost all parts are aftermarket it's hard to diagnose the problem.

LPG could also make problems.

Spark plugs should be OE Volvo for turbo engines or cheap copper ones (NGK or Bosch)gapped properly because gap is critical for turbo engines.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
RickHaleParker
Posts: 3972
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 492 times
United States of America
RickHaleParker

Re: S70 2.5t misfire

Post by RickHaleParker » Fri Jan 31, 2020 9:31 pm

radek93 wrote:
Fri Jan 31, 2020 3:41 pm
When I drive, car have 1s misfire on 20 kilometers. Sometimes more often, sometimes less often. Sometime when engine working on idle, rotation degrese to 500 a grow up back to 900 in one sec.
Sounds more like something dragging the engine down but it is intermittent, like an Alternator bearing starting to go or a A/C compressor clutch going out and binding. Check everything on the Timing belt and the Auxiliary belt.
Last edited by RickHaleParker on Fri Jan 31, 2020 9:39 pm, edited 1 time in total.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

User avatar
wizechatmgr
Posts: 1344
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 23 times
Been thanked: 56 times
Contact:
United States of America
wizechatmgr

Re: S70 2.5t misfire

Post by wizechatmgr » Fri Jan 31, 2020 9:34 pm

Put the old plugs back in. I know someone recently that got a plug that went bad after a week or two. Drove the guy nuts...
Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~187k miles

radek93
Posts: 26
Joined: Sat Dec 07, 2019 2:43 pm
Year and Model: S70 98
Location: Home
Has thanked: 0
Been thanked: 0
Poland
radek93

Re: S70 2.5t misfire

Post by radek93 » Fri Jan 31, 2020 11:10 pm

wizechatmgr wrote:
Fri Jan 31, 2020 9:34 pm
Put the old plugs back in. I know someone recently that got a plug that went bad after a week or two. Drove the guy nuts...
I have this problem since four years. Oem volvo plugs. Ngk plugs. Brisk plugs. All that same problem.

User avatar
misha
Posts: 4204
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 54 times
Been thanked: 117 times
Serbia
misha

Re: S70 2.5t misfire

Post by misha » Sat Feb 01, 2020 2:13 am

Then...LPG system might be the cause of your problems.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

radek93
Posts: 26
Joined: Sat Dec 07, 2019 2:43 pm
Year and Model: S70 98
Location: Home
Has thanked: 0
Been thanked: 0
Poland
radek93

Re: S70 2.5t misfire

Post by radek93 » Sat Feb 01, 2020 7:42 am

misha wrote:
Sat Feb 01, 2020 2:13 am
Then...LPG system might be the cause of your problems.
It was like this before lpg assembly

michael8888
Posts: 26
Joined: Tue Dec 03, 2013 10:35 pm
Year and Model: v70 t5m 1998
Location: NYC
Has thanked: 0
Been thanked: 3 times
michael8888

Re: S70 2.5t misfire

Post by michael8888 » Sat Feb 01, 2020 9:18 am

I found after going over a year with the same issue and replaced everything that the culprit was the thermostat sensor that's at the thermostat housing. A $13 part plus a new thermostat while I was there. ECU reads the temp wrong from the sensor and adds more fuel to the mix to cool the temp.
Also, check that all electrical connections are good and clean. use some dielectric grease. Be sure the wires from the cam sensor are not near the ignition wires. that may cause some em feedback.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post