Login Register

Replaced front hub, now ABS, Shifting/Limp mode issues

Third generation Volvo V70 wagon and XC70, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

Post Reply
volvooh
Posts: 364
Joined: 16 Jul 2009, 08:24
Year and Model: '98 S70, '05&'08 V70
Location: OH
Been thanked: 3 times

Replaced front hub, now ABS, Shifting/Limp mode issues

Post by volvooh »

2008 V70 130k miles. I just replaced the front passenger hub along with a new ball joint and tie rod end. Once back together and test driving it was smooth and quiet, no more wheel bearing hub/grind.

I was having an ABS/DTSC issue prior to the hub change. My ICarSoft was showing an issue with the front right tone ring/ sensor and doing live data reads it was indeed not reading correctly and sometimes not at all. I thought the new bearing/hub would correct that.

Fast forward to the test drive, not only am I continuing to get faulty readings from the right front ABS sensor, the car appears to be in either limp mode or just not shifting correctly. I am getting an additional message from the TCM regarding faulty A/B speed correlation. I am acquiring a new ABS sensor and will install it. Should I be looking at any thing else in the process?

User avatar
abscate
MVS Moderator
Posts: 28786
Joined: 17 Feb 2013, 17:54
Year and Model: 99: V70s S70s,05 V70
Location: NYC, ALBANY NY
Has thanked: 785 times
Been thanked: 2142 times

Post by abscate »

I’m not sure where the tone ring is on the 2008 P3 models but on the P2 it’s on the axle, not the hub.

A bad tone ring can cause driveability issues, I fought this on. bMW for a month, no codes!
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread

volvooh
Posts: 364
Joined: 16 Jul 2009, 08:24
Year and Model: '98 S70, '05&'08 V70
Location: OH
Been thanked: 3 times

Post by volvooh »

Thanks and great to hear from you. There is an unfortunate lack of information available for this vehicle. I miss my pre-2005 volvos.

From everything I have read the ABS ring is a magnetic ring located on the rear of the hub itself, which appears to check out as there is a little finger on the sensor that extends through the knuckle and rests behind the hub. I replaced the ABS sensor last night with what I thought was the correct one and I went from getting incorrect readings for the old sensor to none at all from the new one, as if it wasn't even hooked up. Apparently there is a number of different variations of sensors depending on the chassis number.

User avatar
abscate
MVS Moderator
Posts: 28786
Joined: 17 Feb 2013, 17:54
Year and Model: 99: V70s S70s,05 V70
Location: NYC, ALBANY NY
Has thanked: 785 times
Been thanked: 2142 times

Post by abscate »

My friend downstate did a P3 axle recently , I thought he wrote it up here? I’ll check up on that.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread

Post Reply
  • Similar Topics
    Replies
    Views
    Last post