Login Register

Volvo 960 2.5 1995 MAF sensor measurement & engine noises RPM related

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Post Reply
AntoineB
Posts: 5
Joined: 12 Aug 2022, 06:26
Year and Model: 960 1995
Location: Arles

Volvo 960 2.5 1995 MAF sensor measurement & engine noises RPM related

Post by AntoineB »

Hello,

I have a 1995 Volvo 960 2.5 l manual gearbox, 260000 Km, which I am trying to fix when on holiday (it is stored in the countryside). *

1/ Lack of power & torque.

I feel the car is not behaving properly, as if something was wrong with the engine management.
So far I have replaced the camshaft sensor (had a broken angle and was soaked in oil), the ECU thermostat behind the engine block, the ignition wiring harness and the spark plugs (oem Volvo), cleaned the throttle body and the idle valve, changed the air filter, changed the fuel filter, changed one ignition module, cleaned all grounds. Tried to swap other Volvo ignition coils, no difference. Planning to change the PCV system at Christmas, although the glove test is OK, but I can find oil entering the throttle body and inlet manifold.
Voltage output of the alternator is OK at 14.3v if I remember well. I have a doubt with the MAF sensor. If I disconnect it during winter, the engine will almost not start. However, if I disconnect it during summer, the car drives exactly the same, no difference.
The MAF is Bosch 0280213025, 5 wires
I tried to do some measurements at the MAF Sensor plug, connected to the MAF, inserting a small nail, and connecting the positive wire of the multimeter to this nail, and the negative wire to the battery ground, contact on.
On picture, PIN 1 is on the right, PIN 6 on the left.
PIN 1 – Battery Ground, or battery + : 0V
PIN 2– Battery Ground : 12.15 V
PIN 2 – Battery + : 0.18V
PIN 3– Battery Ground : 1.55 V
PIN3 – Battery + : 10.8v
PIN 4– Battery Ground : 12.6 V
PIN 4 – Battery + : 0.2v
PIN 5 – Battery Ground, or battery + : 0V
I tried to do some measurements between PIN 1 and battery ground and PIN 5 and battery ground with engine started : still 0V
I cannot find a way to measure any changing voltage-RPM with the engine running. May someone have some advice on how to measure the MAF sensor?

2/ Engine noises.

In neutral, I can rev up the engine without any parasitic noises.
In first and second gears, during acceleration, I can hear a sort of whining noise, difficult to locate, and not RMP related.
But in third, more in fourth and at maximum in fifth gear, I can hear a grinding noise, quit loud, like worn bearing or resonance between two metal parts, between I would say 1800 RPM and 2200 RPM, nothing below, or above. This sound really seems to be coming from the front, from the engine bay.
I have thought about the gearbox, although the noise seems to be coming from the front of the car, changed its oil with Volvo oil, but they were not metal flakes in the old oil, and also, I have no problem at all changing gears, the gearbox behave well.
I have no idea about the origin of those noises, especially the grinding one, more irritating and worrying. Any idea?

Thanks for your help, as I have a very limited mechanical knowledge (but trying to learn!).

Antoine

AntoineB
Posts: 5
Joined: 12 Aug 2022, 06:26
Year and Model: 960 1995
Location: Arles

Post by AntoineB »

Hello,

Today I opened the air box and noticed the thermostat was gone, and the flap set to 100% hot air. I set the flap to 100% cold air, and the engine is already working better, breathing better, although still not as I expect it to work. I presume that this continuous hot air may have damaged the MAF sensor. What symptoms may I experience with a faulty MAF?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post