IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

lovemy02xc
Posts: 2
Joined: Sun Feb 01, 2009 8:52 am
Year and Model: 02 XC70
Location: Maryland
Has thanked: 0
Been thanked: 0
lovemy02xc

Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by lovemy02xc » Sun Feb 01, 2009 8:59 am

Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' Low XC - my check engine light came in and when the codes were pulled this is what they showed. Sensor was removed, cleaned but check engine light still shows.

Went to the dealer to get a boost sensor and the guy at the parts counter showed us a picture of the sensor where the tube goes into the intercooler. The vehicle has no such sensor in that location, there is however a sensor which the dealer indicated is a map sensor that looks like a picture of the boost sensor. He also said they very rarely, if ever, go bad.

Have heard people refer to three hoses on the boost sensor but have not been able to find a sensor with that description. Where would it be located? Also, the picture we have of the boost sensor is identical to what the dealer says is the map sensor and is in the same location as the map sensor described by the dealer. Very confusing! Any help at all greatly appreciated.

MadeInJapan
MVS Moderator
Posts: 13423
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 20 times
United States of America
MadeInJapan

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by MadeInJapan » Sun Feb 01, 2009 9:10 am

I think you're talking about your turbo control valve (TCV). It is located on the side of the air filter box, windshield side and does have three lines attached to it. One line attaches to the under side of the intake hose, just before the accordion section begins, and past the MAF sensor- take a look, it's on the underside so it's hard to see.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

lovemy02xc
Posts: 2
Joined: Sun Feb 01, 2009 8:52 am
Year and Model: 02 XC70
Location: Maryland
Has thanked: 0
Been thanked: 0
lovemy02xc

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by lovemy02xc » Sun Feb 01, 2009 9:22 am

Would that also be referred to as the turbo boost sensor? The dealer showed me a picture of the sensor locations and the turbo boost sensor is supposed to be in the tube just before it attaches to the inter-cooler. The problem is that between the map sensor and the inter-cooler there isn't any sensor, with or without hoses. The tube is void of any other attachements.

MadeInJapan
MVS Moderator
Posts: 13423
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 20 times
United States of America
MadeInJapan

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by MadeInJapan » Sun Feb 01, 2009 9:41 am

Turbo Control Valve (TCV) or Boost Control Valve- same thing: The rectangular piece on top is a connector for an electrical plug:
Image
The problem you're describing most likely IS NOT your MAP Sensor. The codes you get are for the valve I posted, not the MAP.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

voltagematt
Posts: 2
Joined: Sun Feb 01, 2009 10:01 am
Year and Model: 2001 S60 2.4T
Location: north carolina
Has thanked: 0
Been thanked: 0
voltagematt

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by voltagematt » Sun Feb 01, 2009 10:06 am

Using a MAC code reader I was getting P1237 "Turbo Boost Sensor A Circuit Input Low." Is this the same as P0237, just from a non-Volvo scanner?

Will replacing that sensor remedy the error message? Expensive part? Easy or difficult to access?

MadeInJapan
MVS Moderator
Posts: 13423
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 20 times
United States of America
MadeInJapan

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by MadeInJapan » Sun Feb 01, 2009 10:32 am

Not sure, but both do point to the turbo control valve I suspect that either a hose is loose or has a break in it. One hose (red) goes to the lower section of the turbo (only reached from under the car- a PITA but do-able with some long needle nose pliers), one hose goes to the waste-gate (I believe yellow) at the top of the turbo (much easier to reach) and then the (I believe blue) other hose goes to the under side of the intake hose, past the air filter housing. I changed mine out with IPD's heavy duty TCV this past summer on both of my cars- some smoothing out was noticeable, but nothing that I would call "outstanding" as a performance upgrade.

EDIT: Just found where P1237 could be an "air-metering" code- either way, it's not a Volvo specific code. Some people with this code were having trouble with their MAF sensor. I would take it out and clean it with MAF cleaner for good measure- don't touch the sensor inside as it's very sensitive- just spray it liberally and let it air dry.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

voltagematt
Posts: 2
Joined: Sun Feb 01, 2009 10:01 am
Year and Model: 2001 S60 2.4T
Location: north carolina
Has thanked: 0
Been thanked: 0
voltagematt

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by voltagematt » Mon Feb 09, 2009 8:09 am

Thanks. I was all set to order the IPD sensor because I thought I saw that the Volvo one was $160. I am selling this car (regrettably) and I didn't want to wait for the shipping, so I actually called the local dealer and they had OEM in stock, and for only $80 (less than IPD with no shipping cost or wait) so I picked one up. After replacing the sensor, the car scans "passed" and I can clear the code, but after a couple starts the ENGINE SYSTEM SERVICE REQUIRED comes back on.

How do I get the thing to stay cleared? It's actually still scanning as "passed" so I'm stumped. I know some scanners cannot override the computer—does it have to go to the Volvo shop to get cleared?

Or do I need to start looking at those hoses...I'll also check the MAF.

MadeInJapan
MVS Moderator
Posts: 13423
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 20 times
United States of America
MadeInJapan

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by MadeInJapan » Mon Feb 09, 2009 2:23 pm

Try unhooking the battery for 20 or so minutes and see if that "really" clears the codes.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

rlazelle
Posts: 1
Joined: Sun Mar 31, 2013 9:10 am
Year and Model: S60 AWD 2002
Location: Seattle WA area
Has thanked: 0
Been thanked: 0
Contact:
United States of America
rlazelle

Re: Codes - P0236 - Turbo Sensor and P0237 - Turbo Circuit "A' L

Post by rlazelle » Wed Feb 05, 2020 3:10 pm

I have a high mileage Volvo 2002 S60 AWD with codes P0236 and P0237 "Turbo Boost Sensor A Circuit" on my code reader. This looked like the MAP sensor located on a plastic pipe connecting the bottom of the intake manifold to the inter-cooler output . As a preliminary test, I cleared the codes and then disconnected the 3 wire plug on the MAP sensor. When i started the engine and got only a code P0238 , with a rough idle which confirmed that the MAP sensor was involved. I took a picture of the sensor and found the Bosch number 0 261 230 029 which I ordered. Just put in the new MAP sensor today and my test drive was good, driving 20 miles on the freeway with no codes.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post