IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

440 -95 B18U Problems with cold start + bad idle

Discussion and advice for 440, 460, 480 owners.

1986 - 1997 440
1986 - 1997 460
1986 - 1997 480

Quickie2
Posts: 28
Joined: Thu Feb 19, 2009 2:22 pm
Year and Model: 440 -95 B18U
Location: Sweden
Has thanked: 0
Been thanked: 0
Quickie2

440 -95 B18U Problems with cold start + bad idle

Post by Quickie2 » Thu Feb 19, 2009 2:33 pm

Hello everybody :D
I hope someone of you can help me.
I have a cold start problem with my car. It's impossible to start the car without putting my foot on the gas pedal. And when It starts I't dies instantly If I don't keep It alive with the gas pedal. For the first 3-4 minutes the engines revs up and down from 500-1200 rpm. As soon as I brake at crossing the engine dies. It feels a bit dangerous as my wife uses the car to get to work. :oops:

I have checked for fault codes and I get code 4-1-1 which (from what I understand) means something with my TPS is wrong.

Thanks in advance



User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: 440 -95 B18U Problems with cold start + bad idle

Post by billofdurham » Thu Feb 19, 2009 3:49 pm

Welcome to Matthew's Volvo Site.

4-1-1 is Throttle Position Sensor (TPS) signal error. Possible causes are wiring fault; accelerator cable adjustment; faulty TPS or ECM fault.

Check the wiring to the TPS then, with a voltmeter, check for voltage at the plug.

Values should be as in the attached.
TPSensor check.jpg
Bill.
You do not have the required permissions to view the files attached to this post.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Quickie2
Posts: 28
Joined: Thu Feb 19, 2009 2:22 pm
Year and Model: 440 -95 B18U
Location: Sweden
Has thanked: 0
Been thanked: 0
Quickie2

Re: 440 -95 B18U Problems with cold start + bad idle

Post by Quickie2 » Mon Feb 23, 2009 4:32 am

Hello, Thanks for the quick reply. I'm just wondering if a faulty tps really can give you start up problems.

I'm also wondering how to measure the signals with the connector attached to the tps? I can't reach to measure?



User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: 440 -95 B18U Problems with cold start + bad idle

Post by billofdurham » Mon Feb 23, 2009 11:35 am

The TPS is one of several components which can give you a "no start" situation. As that code was stored that is the place to begin the checks.

The TPS connector should have a rubber cover which can be peeled back to allow you to probe into the rear of the connector.

Bill.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Quickie2
Posts: 28
Joined: Thu Feb 19, 2009 2:22 pm
Year and Model: 440 -95 B18U
Location: Sweden
Has thanked: 0
Been thanked: 0
Quickie2

Re: 440 -95 B18U Problems with cold start + bad idle

Post by Quickie2 » Tue Feb 24, 2009 2:32 pm

Finally, I managed to measure my TPS and here is the result:
Supply voltage:5.05 V
Throttle Closed:0.83V
Throttle fully open: 3.05V

So this means my TPS needs to be changed? :shock:



User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: 440 -95 B18U Problems with cold start + bad idle

Post by billofdurham » Wed Feb 25, 2009 3:45 pm

The supply voltage and throttle closed are near enough but the throttle open is well out of spec which would suggest a TPS is needed.

Bill.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Quickie2
Posts: 28
Joined: Thu Feb 19, 2009 2:22 pm
Year and Model: 440 -95 B18U
Location: Sweden
Has thanked: 0
Been thanked: 0
Quickie2

Re: 440 -95 B18U Problems with cold start + bad idle

Post by Quickie2 » Thu Feb 26, 2009 2:40 am

Crap :?
I am pretty sure that won't cure my problems but anyway, do you know the partnumber and where I can get one?

I am suspecting my inlet/exhaust manifold gasket has gone but that is another question I have raised on the forum :(



User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: 440 -95 B18U Problems with cold start + bad idle

Post by billofdurham » Thu Feb 26, 2009 3:39 pm

Sorry, I don't know the part number but I would wait if the manifold gaskets need replacing as you have to remove the fuel injection assembly to do that and you may find that 'shaking' the TPS will sort it out. It has been known to happen.

EDIT: Pull the plug off the TPS and check for oxidation on the contacts.


Bill.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Quickie2
Posts: 28
Joined: Thu Feb 19, 2009 2:22 pm
Year and Model: 440 -95 B18U
Location: Sweden
Has thanked: 0
Been thanked: 0
Quickie2

Re: 440 -95 B18U Problems with cold start + bad idle

Post by Quickie2 » Tue Mar 03, 2009 12:23 pm

I found the partnumber for the tps. Partnumber is 3437022 but I don't know the manufacturer and I can't find It anywhere except some china copies when I google It :D

I've cleaned the contacts without any luck.
Today I noticed something weird :shock :shock:

While the idle goes up and down, If I press the brakepedal once a second suddently the Idle stabilizes at 1000 rpm :D

So how is this connected to each other and what should I check? 8)



User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: 440 -95 B18U Problems with cold start + bad idle

Post by billofdurham » Wed Mar 04, 2009 3:58 pm

That would indicate that you may have a vacuum problem as the brake servo works on vacuum. Check all the vacuum pipes for leaks or bad connections.

Bill.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Post Reply