Login Register

2012 XC70 AWD 3.2 non turbo B24S- Running rough

Third generation Volvo V70 wagon and XC70, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

Post Reply
wolfstein
Posts: 6
Joined: 29 May 2023, 14:27
Year and Model: 2012 xc70 awd 3.2
Location: states
Has thanked: 1 time

2012 XC70 AWD 3.2 non turbo B24S- Running rough

Post by wolfstein »

The 2012 XC 70 AWD 3.2 non-turbo is running very rough. Volvo Stated a month ago the "4" coil was bad and cleared the error codes. O2 sensor error code has been coming and going away. I decided to replace all the spark plugs and coils. She purred after that.

3 days later low battery light and I could not turn the engine over. I got a jump and headed to the auto store to have them check on the battery (2019 when the other owner of the car replaced it). Dead cell, So I had them replace the battery.. Less than a week later same thing happen again. The battery was faulty. The voltage fluctuated a lot, too. The starter and alternator were checked out through the test, and they were good. The battery was replaced again. That pesky low battery keeps showing up.

So, I will look into a voltage reg. Then she, Last Tuesday, started idle and drive roughly. I could not accelerate. I got home and decided to change the voltage regulator. It needed it.

Cleaned the TB and hooked everything back up. She is worst.

Codes from the last month before the first clear by me today
P0301
P0302
p0303
p0304
p0305
p0306
p0300
p1573
P050b
Reduce engine performance
Error codes today after the clear.
P050B
P0300, 5,4,3,2,1
P1573

When back through everything, check all the connectors, coils, check the bolts and tighten if needed.
P1573
P0507 now.
Reduce engine performance
Cleaned the battery terminal and connectors..

So, What next? Fuel Filter? she is due for an oil change (holding off until she is running). ECM or TCM?


05/30/2023
P1573
throttle position 0.0%
engine rmp 0
barometric pressure 101 KPA
load value 0.0%
Air Flow Rate 0.00 GR/sec
MAP Sensor 101 KPA
Ambient air temperature 68F
Coolant Temp 69F
Intake Air Temp 69F
Ignition Timing Adv -5.6 Degree
Short Term Fuel Trim 1 0.0%
Long term Fuel Trim 0.0%
Short Trim Fuel Trim 2 0.0%
Long term Fuel Trim 0.0%
Short Trim Fuel Trim 3 -100.6%
long trim fuel 3 -100.6%
Short Trim Fuel Trim 4 -100.6%
long trim fuel 4 -100.6%
Vehicle speed 0 mph
Absolute Load Value 0.0%
Fuel rail Pressure (gauge) 198 KPAG
Fuel system 1 n/a
Fuel system 1 n/a
Relative Throttle Position 0.0 %
Commanded Throttle Actuator Control 23.1%
absolute Throttle Position B 0.0 %
Accelerator Pedal Position D 7.4 %
Accelator Pedal Position E 8.2 %
Commanded Evap Purse 0.0 %
Commanded Equivalence Ratio 0.997
Fuel Level input 38.8%
Control Module Voltage 11.928 v

Cylinders 2 and 3 Misfiring.
Last edited by wolfstein on 03 Jun 2023, 07:13, edited 1 time in total.

wolfstein
Posts: 6
Joined: 29 May 2023, 14:27
Year and Model: 2012 xc70 awd 3.2
Location: states
Has thanked: 1 time

Post by wolfstein »

I bit the bullet and took the Volvo to the shop to have the alternator replace, since I was sick this last week.
It did not fix the rough idle. I thought low voltage from the alternator could be throwing bad codes.
If the tech gets it over 2000 RPM, she stops misfiring.

Any ideas?

My husky loves this Volvo as much as I do. I do not want to have to scrap it. It is my daily communter.

wolfstein
Posts: 6
Joined: 29 May 2023, 14:27
Year and Model: 2012 xc70 awd 3.2
Location: states
Has thanked: 1 time

Post by wolfstein »

Since then she is still not working. I rechecked the spark plugs to make sure they were properly tightened. I have been down a hand for the past few weeks.

Moved the data to a spreadsheet.
Hoping someone could help. I am not used to the codes or readings. I am trying to learn.

table below:

Code: Select all

[attachment=0]volvo data.docx[/attachment]
Date 6/18/2023 6/13/2023 6/10/2023 6/10/2023 6/4/2023 5/30/2023
Throttle Position: 13.30% 16.80% 13.70% 11.70% 0.00%
Engine RPM 1155 1043 833 633 1918 0
Barometric Pressure 100 101 101 101 101
Load Value 46.20% 37.20% 41.90% 17.60% 0.00%
Air Flow Rate 12.01 10.14 6.44 2.65 0
MAP Sensor 38 49 41 45 22 101
Ambient Air Temperature 75 86 86 78 68
Coolant Temp 91 127 91 100 69
Intake Air Temp 80 82 78 77 69
Ignition Timing adv 25.5 4.5 37 -5.6
Short Term Fuel Trim 1 21.00% 29.60% 0.00% 0.00% 0.00%
Long Term Fuel Trim 1 0.00% 0.00% 0.00% 0.00% 0.00%
Short Term Fuel Trim 2 -7.70% 0.00% 0.00% 0.00%
Long Term Fuel Trim 2 0.00% 0.00% 0.00% 0.00% 0.00%
Short Term Fuel Trim 3 -100.60% -100.60% -100.60% -100.60%
Long Term Fuel Trim 3 -100.60% -100.60% -100.60%
Short Term Fuel Trim 4 -100.60% -100.60% -100.60%
Long Term Fuel Trim 4 -100.60% -100.60% -100.60% -100.60%
Vehicle speed 0 3 0 0 0
Absolute Load Value 38.00% 30.00% 34.00% 15.00% 0.00%
Fuel Rail Pressure (gauge) 408 408 405 405 198
Fuel System 1 ol-fault Clsd clsd open open n/a
Fuel System 2 ol-fault Clsd clsd open open n/a
Relative Throttle Position 3.10% 8.2 2.70% 0.00% 0.00%
Command Throttle Actuator Control 16.80% 25.4 21.50% 17.60% 23.10%
Absolute Throttle Position B 30.90% 33.3 30.90% 29.40% 0.00%
Accelerator Pedal Position D 11.70% 13.7 7.00% 7.00% 7.40%
Accelerator Pedal Position E 12.90% 8.20% 8.20%
Commanded Evap Purge 0.00% 0 0.00% 0.00% 0.00%
Commanded Equivalence Ratio 0.976 0.977 0.977 1.019 0.997
Fuel Level Input 35.60% 33.7 36.80% 40.00% 38.80%
Control Module Voltage 14.414 13.066 14.35 13.4220 11.928
Time Since Engine Start: 0:00:44 00:14 0:00:47 0:00:25 0:00:00
Erased erased
Attachments
volvo data.docx
(17.64 KiB) Downloaded 20 times

wolfstein
Posts: 6
Joined: 29 May 2023, 14:27
Year and Model: 2012 xc70 awd 3.2
Location: states
Has thanked: 1 time

Post by wolfstein »

Here are the spark plugs before I changed them. Volvo pulled the code and told me it was cylinder 4 misfiring.
received_1391771258055660.jpeg
received_1391771258055660.jpeg (149.74 KiB) Viewed 427 times
received_813364987034056.jpeg
received_813364987034056.jpeg (108.28 KiB) Viewed 427 times
received_942352370206747.jpeg
received_942352370206747.jpeg (178.25 KiB) Viewed 427 times
received_748953427233586.jpeg
received_748953427233586.jpeg (139.13 KiB) Viewed 427 times
received_643039531081822.jpeg
received_643039531081822.jpeg (126.53 KiB) Viewed 427 times
received_281527034260739.jpeg
received_281527034260739.jpeg (150.75 KiB) Viewed 427 times
received_251269474312960.jpeg
received_251269474312960.jpeg (113.48 KiB) Viewed 427 times
received_242253085230381.jpeg
received_242253085230381.jpeg (107.73 KiB) Viewed 427 times

wolfstein
Posts: 6
Joined: 29 May 2023, 14:27
Year and Model: 2012 xc70 awd 3.2
Location: states
Has thanked: 1 time

Post by wolfstein »

So, Check all the gaps on the original Spark plugs. Only two were gapped to .4. The others were .5 or more.

So, under the idea of that misfires could cause the gapping to expand. I pulled all the coils and spark plugs. The ones that were pre-gapped to .44 that I used.
Autolite Iridium XP5325.
Coils are Duralast C1677-6

Check the new spark plugs. left to right order #2 and #4 smelled heavily of gas. #6 was dirty.
I regap the new spark plugs to .4
She seems fine for a few mins and same thing happen again.
o2 sensor code has been coming and going for the last year. So, Ordered the O2 sensors.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post