IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Alpine CD Changer Trouble

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

rubyvette
Posts: 107
Joined: Mon Apr 07, 2008 7:47 pm
Year and Model: 2001 C70
Location: Massachusetts
Has thanked: 0
Been thanked: 0
rubyvette

Alpine CD Changer Trouble

Post by rubyvette » Sat Apr 26, 2008 3:50 pm

I moved my Alpine 5960 cd changer from the glove box to the trunk in my 94 850. It worked fine with my SC-815 head unit. I just wanted to free up some space and the cable was long enough. When I turned it on it played right away from disc 6 track 1. When I tried to change discs it gave me an error code 01 on the head unit. Now it won't do anything, including eject the magazine. Is there an easy fix or is this unit junk?


2007 S60R Magic Blue/
2005 S60 2.5 AWD Silver/Black
2001 C70 Coupe HPT black/black 149000 miles
2000 C70 Coupe HPT 132000 miles...SOLD
1994 850 sedan n/a 230000 miles...SOLD
2003 GMC 2500HD Crew Cab
1993 Corvette 40th Anniv Convertible
1960 Corvette

bockreiter
Posts: 20
Joined: Sat Apr 12, 2008 8:01 pm
Year and Model:
Location: Edwardsville, IL
Has thanked: 0
Been thanked: 0
bockreiter

Post by bockreiter » Sun Apr 27, 2008 6:00 pm

When I bought my 850 Turbo Wagon used, the CD-Changer wasn't working with error 01 on the radio display. Mine is factory installed in the cargo area. Turned out the fuse holder supplying current to the unit had a loose connection. Took me a while to figure it out, but I got 6 CDs from the previous owner in the bargain.
Check to make sure you have a secure power connection. If you used crimp connectors, crimping them again may make all the difference. If you get 12 volts to the unit, check that the unit is properly grounded.
Another problem I encountered once with the changer was a CD got stuck halfway between the cassette and the reader. (different error code though)I had remove the entire unit and take the cover off. Once the back cover was removed, I could forward the disc into the cassette (by spinning the mechanism with my finger) and thus alow the cassette to be ejected. I've had this happen only once, so I don't know how common this is.


'94 850 Turbo Wagon

approx. 200,000 miles.

rubyvette
Posts: 107
Joined: Mon Apr 07, 2008 7:47 pm
Year and Model: 2001 C70
Location: Massachusetts
Has thanked: 0
Been thanked: 0
rubyvette

Post by rubyvette » Sun Apr 27, 2008 7:42 pm

Well, I'm getting closer but don't have it solved yet. I took the unit apart figuring it couldn't get worse. I released a jammed CD and put it back together. I connected it back up in the car and it just shuffles through all 6 CD's continuously. It will now eject the cartridge when you press the button. The error code E-01 only shows after some time of shuffling. I think I may need to seek professional help for it.


2007 S60R Magic Blue/
2005 S60 2.5 AWD Silver/Black
2001 C70 Coupe HPT black/black 149000 miles
2000 C70 Coupe HPT 132000 miles...SOLD
1994 850 sedan n/a 230000 miles...SOLD
2003 GMC 2500HD Crew Cab
1993 Corvette 40th Anniv Convertible
1960 Corvette

User avatar
BEJinFbk
Posts: 3600
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 17 times
Been thanked: 29 times
United States of America
BEJinFbk

Post by BEJinFbk » Sun Apr 27, 2008 9:39 pm

I'd bet you've already figured this out,
but for the benefit of other readers:

It's always a good idea to take the drawers out of a filing cabinet
or remove the CD's from a changer before you move it.

I hate when that happens!
Might be time for an Ipod upgrade?


'98 V70 R - Well Equipped for Life Up North... ;)

bockreiter
Posts: 20
Joined: Sat Apr 12, 2008 8:01 pm
Year and Model:
Location: Edwardsville, IL
Has thanked: 0
Been thanked: 0
bockreiter

Post by bockreiter » Mon Apr 28, 2008 6:11 pm

:idea: I tried to replicate your problem and lo and behold, if I shuffle between discs and do not wait until the current disc is fully loaded (track 1 showing up on the console's display), the current disc will get stuck. I was able to repeat this 3 times in a row. If I wait until the disc is fully loaded, I can no get the disc stuck. Call it a design flaw or a bad unit, on my changer know it's predictable, so I just live with it. I wonder if othe models have the same hickups.


'94 850 Turbo Wagon

approx. 200,000 miles.

rubyvette
Posts: 107
Joined: Mon Apr 07, 2008 7:47 pm
Year and Model: 2001 C70
Location: Massachusetts
Has thanked: 0
Been thanked: 0
rubyvette

Post by rubyvette » Tue Apr 29, 2008 6:01 am

It worked fine in the glove box. While lying on my back in the trunk to mount it under the rear shelf it slipped and dropped into the trunk. I think this may caused the cd to jam and bend something in the transport and pickup system. I was able to release the jam and get my cd's out, but now it just shuffles through and doesn't play any of them. I was hoping to be able to fix it myself before I left on a trip to VA on Thursday, but it seems to be beyond my skill level. I'll just wait and get a replacement when I get back.


2007 S60R Magic Blue/
2005 S60 2.5 AWD Silver/Black
2001 C70 Coupe HPT black/black 149000 miles
2000 C70 Coupe HPT 132000 miles...SOLD
1994 850 sedan n/a 230000 miles...SOLD
2003 GMC 2500HD Crew Cab
1993 Corvette 40th Anniv Convertible
1960 Corvette

rubyvette
Posts: 107
Joined: Mon Apr 07, 2008 7:47 pm
Year and Model: 2001 C70
Location: Massachusetts
Has thanked: 0
Been thanked: 0
rubyvette

Post by rubyvette » Tue May 06, 2008 5:34 pm

OK, now I think I'm stumped. I found a newer Alpine changer in a 97 wagon. I removed it and the connector cable and installed it in my car. When I plug it in it appears to power up correctly and draw the first cd into the player mechanism. When I push the CHGR button on my SC-815 head unit the display reads EEEE. It also reads that way when no changer is plugged in. I have a newer SC-816 head unit that works properly so I tried that, too. Same result, EEEE on the display. Is there some initialization code that needs to be entered for the head unit to recognize this changer?


2007 S60R Magic Blue/
2005 S60 2.5 AWD Silver/Black
2001 C70 Coupe HPT black/black 149000 miles
2000 C70 Coupe HPT 132000 miles...SOLD
1994 850 sedan n/a 230000 miles...SOLD
2003 GMC 2500HD Crew Cab
1993 Corvette 40th Anniv Convertible
1960 Corvette

Post Reply