IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

XC70 00MY P0014 Cam Position Code

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

db130
Posts: 308
Joined: Tue Mar 18, 2008 12:58 pm
Year and Model: 2002 V70 T5
Location: MA
Has thanked: 0
Been thanked: 0
United States of America
db130

Re: XC70 00MY P0014 Cam Position Code

Post by db130 » Thu Mar 12, 2009 12:49 pm

yes, i ended up changing the camshaft position sensor which at the time cost me about $150. i see that the price has gone up to around $200 from online wholesalers(dealer retail is ~$246)..

i have to tell you though that the code came back 8 days after i installed the camshaft position sensor, although the camshaft position sensor did fix the intermittent hard start problem. i changed the oil shortly thereafter and and have been keeping tabs on the oil level. Before the new camshaft position sensor, I'd get the P0014 every two weeks or so. After the new camshaft position sensor+oil change, the interval started to grow longer. I last had the P0014 back on 01/05/2009.

By the way, when was the last time you had the oil changed?
2002 V70 T5 169k
2002 V70 NA 249k
2006 Mini Cooper S 90k

larryh
Posts: 256
Joined: Tue Mar 28, 2006 7:27 pm
Year and Model:
Location:
Has thanked: 0
Been thanked: 0
larryh

Re: XC70 00MY P0014 Cam Position Code

Post by larryh » Thu Mar 12, 2009 2:05 pm

I still think you (both now) have the timing off. Shops can, and do get the timing off when they change the belts on the vvt cars. it is tricky to keep things positioned and the crank mark is invisible. as was the case in my car (only it was me that did it the crappy work as soon as I purchased the car) the car ran fine..mine was a tiny bit sluggish but i didn't even notice that until it was corrected. The code can be very intermittant.
Good luck

[email protected]
Posts: 9
Joined: Fri Sep 26, 2008 5:44 pm
Year and Model:
Location:
Has thanked: 0
Been thanked: 0
[email protected]

Re: XC70 00MY P0014 Cam Position Code

Post by [email protected] » Thu Mar 12, 2009 5:23 pm

db130 - I changed the oil about 4k miles ago. I use Mobil1 and she burns very little oil. The oil still looks good too. I'm going to change it soon, but even after I've changed it in the past the light comes on so it doesn't seem to make a difference.

larryh - do you have any tips on how to best check the timing?

thanks in advance.

db130
Posts: 308
Joined: Tue Mar 18, 2008 12:58 pm
Year and Model: 2002 V70 T5
Location: MA
Has thanked: 0
Been thanked: 0
United States of America
db130

Re: XC70 00MY P0014 Cam Position Code

Post by db130 » Wed Apr 15, 2009 8:52 am

Just a quick update... It is now 14 weeks and counting since I last saw the P0014 code. Proper oil pressure/quality+new camshaft position sensor apparently was the cure.

I going to have to dispute the assertion that the timing belt is off by one tooth on my car. I have an aftermarket vacuum/boost gauge on the a-pillar and the vacuum/boost readings during idle/acceleration/deceleration are all spot-on for "factory spec."
2002 V70 T5 169k
2002 V70 NA 249k
2006 Mini Cooper S 90k

Jbw99v70t5
Posts: 3
Joined: Tue Feb 04, 2020 12:43 pm
Year and Model: V70t5 1999
Location: Portland OR
Has thanked: 0
Been thanked: 0
United States of America
Jbw99v70t5

Re: XC70 00MY P0014 Cam Position Code

Post by Jbw99v70t5 » Sun Feb 09, 2020 8:39 am

Ok so i had same problem only my timeing belt was done 20 k ago and had no problems until i was geting on to freeway stood on the gas real hard to get out in to a lane and all was good car was running fine no check light got to wear i was going turned off the car went in to store vame back out started car .....fucking check light comes on ahhhhhhahhhh !!!!!!!!! Iam shure you know what i mean so i run codes ...erase codes start car no light turn it off and start it right back up ...light comes back on so i think i will just turn the camshaft gear a little and see if that works ...no luck .....so here is what i did
.i took the cover plug off the exhaust vcct pulley watch out and be reddy for oil to come out of it then i took off the solenoid that controls it put some WD-40 and some carb cleaner down the Halls. But my Torx socket inside the point. And rock the camshaft back and forth number of times. This helps flush the wall out. And release the cam from being advanced. I put it all back together and no engine codes. I would just have to be careful when standing on the freeway until I get a new pulley. I hope this helps.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post