IPD sale Volvo Parts Volvo Parts guaranteed for life Volvo Parts

How to Repair Brake Pedal Position Sensor or Engine service

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
dod
Posts: 4
Joined: Thu Apr 23, 2009 1:34 am
Year and Model: S80 T6, y.2000
Location: Slovakia

How to Repair Brake Pedal Position Sensor or Engine service

Post by dod » Thu Apr 23, 2009 1:37 am

hi! I was repairing brake pedal position sensor on my S80 T6 y.2000, but I think is the same in all S80, S60,V70 etc. Here is link how to repair (clean) brake position sensor with photo instructions, exactly to CLEAN CARBON ROADS AND EVERYTHING FROM USED CARBON INSIDE WITH ALCOHOL ...is in Slovak but from photos easy to do. click here http://www.volvoklub.sk/viewtopic.php?f ... 7&start=10



mvsuzr
Posts: 108
Joined: Thu Mar 19, 2009 10:30 pm
Year and Model: S80 T6 2001
Location: California

Re: How to Repair Brake Pedal Position Sensor or Engine service

Post by mvsuzr » Thu Apr 23, 2009 7:11 am

Thanks for the great photos. This will really help if I ever have to do this.

Couldn't help noticing the dreaded carbon film strips. Though they don't get the wear the ETM seems to get, you could definitely see the carbon was starting to tear.

Also looked like you might be indicating poor solder joints on the PCB board? Seems to be a common failure point on other parts, like the ABS modules.

Couldn't quite puzzle out the Slavic, though. What kind of symptoms were you getting that lead you to the position sensor?

Again, thanks for the info.



dod
Posts: 4
Joined: Thu Apr 23, 2009 1:34 am
Year and Model: S80 T6, y.2000
Location: Slovakia

Re: How to Repair Brake Pedal Position Sensor or Engine service

Post by dod » Thu Apr 23, 2009 9:03 am

ok, I will try to translate it to english}but with mz english?:)) ... symptoms were: cruise control don't want to enable, and in last month error message: Enginesystem need service but without DTC errors stored... and sometimes was showing me message DSTC need service ... after this repair I didn't saw dstc message almost 3 weeks...we will see...



evolve
Posts: 4
Joined: Thu Sep 27, 2007 3:30 pm
Year and Model:
Location: Canada

Re: How to Repair Brake Pedal Position Sensor or Engine service

Post by evolve » Fri May 29, 2009 3:06 pm

BRAKE PEDAL POSITION SENSOR!
Just finished repair of this stuff.
Problem:1994 Volvo 850 N/A had a periodical flashing of ABS signal with ABS shutting off in unpredictable pattern. Codes were 141, 142. Tried to find the new sensor unsuccessfully. Option- replacement of the booster with the sensor. Found tread http://au.geocities.com/ozbrick850/abs-141142.html and did it. The half an hour job if you have a soldering tool handy. BTW What a poor soldering it was in a first place! Main problem is to open the plastic casing with minimal damage. Put it together and sealed with FIX ALL.
Happy volving!



NothinToReport
Posts: 1
Joined: Wed Feb 02, 2011 1:49 pm
Year and Model: Volvo 850, 1993
Location: Home

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by NothinToReport » Wed Feb 02, 2011 1:54 pm

My own updated and ENGLISH 'how to':

http://www.volvoforums.org.uk/showthrea ... 192&page=5

Thanks.



zerdas
Posts: 10
Joined: Fri Sep 03, 2010 11:17 am
Year and Model: V70 2004
Location: chicago

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by zerdas » Wed Feb 02, 2011 2:11 pm

If you ever neeed to translate original slovak version use this link:
http://translate.google.com
Comes in handy, many times.



Gunny100
Posts: 2
Joined: Mon Jun 20, 2011 10:42 am
Year and Model: 2000 S80
Location: Boston

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by Gunny100 » Mon Jun 20, 2011 10:44 am

How do you remove the Brake Pedal Position Sensor after you disconnect the electrical plug? I didn't see any other clips. Thanks.



donis222
Posts: 41
Joined: Sat Feb 02, 2013 12:24 pm
Year and Model: S70 T5 1998
Location: 95811

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by donis222 » Wed Mar 13, 2013 12:44 pm

I had a time with removing the sensor as well. There is a cir-clip that locks the unit in. The lock for the clip is on the master cylinder side.Lift it off of the lock.



shea44
Posts: 22
Joined: Wed Jan 08, 2014 9:47 am
Year and Model: S80 1999
Location: Hampton

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by shea44 » Wed Jan 08, 2014 1:21 pm

Are we talking the sensor on the brake pedal. I removed the blue clip but cannot see where it is clipped to the pedal? to remove it so I can remove the heater core.



Volodymyr20
Posts: 1
Joined: Thu Sep 17, 2015 4:39 pm
Year and Model: V70xc 2001
Location: Orlando Fl

Re: How to Repair Brake Pedal Position Sensor or Engine serv

Post by Volodymyr20 » Thu Sep 17, 2015 5:05 pm

Hi guys, thank you all so much for being here this forum saved me a few bucks)
I am in deep confusion so asking for help
I had this message pop up on dash ENGINE SYS SERV REQUIRED after i have had a baby in hospital for 3 months and before my wife was pregnant car didnt drive a lot, i asked my dad to drive it from time to time he informed me bout that, had no time to do nothing now wife needs the car i started to figure out whats going on cant understand,now it sais URGENT but triangle is still Orange??
Now Abs and Traction light are on???
What am I looking at?
I tested the alternator it gives 13,6 -13,7 with full ac n stereo and fog lights, is it abs module or is it the SENSOR??
I NEED urgent help it refused to Start a few times in a row At All??
Is Abs blocking start???
Is sensor send some faults to abs??
Or im looking at smth else?
I rebuilt throtle body with BBA REMAN so i dont think its throtle related,
I do have a sound like grasshoppers are in my engine after i shot it down for a few seconds,???
Then a click?
But it was always like that i know?? Is it abs pump pumping by fault or error?
I never had no lights for years
That noise does sound louder but again i didnt drive it a long time
PRE STORY code on dash is 44 i dont have any power loss or function los
Speedo and odo both worked before i pulled fuse #19 than odo is black?? Nothing there blank?
Speedo works,,, should i replace Sensor or Rebuilt ABS or both both???
Please please please help
Im so broke from life have 0$ for this so every $ saved is big
Thanks everybody



Post Reply

Return to “Volvo S80 Forum”

Who is online

Users browsing this forum: No registered users and 10 guests