IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Air Con condenser not cutting in...

Discussion and advice for 440, 460, 480 owners.

1986 - 1997 440
1986 - 1997 460
1986 - 1997 480

wig
Posts: 26
Joined: Sat Jan 02, 2010 7:06 am
Year and Model: 850 T5, 1994
Location: Birmingham, UK
Has thanked: 0
Been thanked: 0
wig

Air Con condenser not cutting in...

Post by wig » Thu Apr 15, 2010 1:18 pm

Hi all! Still got the 440 2.0i '96 plate, the air con was working fine last year, ice cold. I put it on the other day and it wasn't cold at all. I thought maybe the gas had gone weak, so I've just tested it, and it is up to pressure, put a bit more in anyway seeing as it was there, and still nothing. Then looked down and saw the condenser wasn't cutting in and out like it should do. I have checked the fuse, and that is fine, so has anyone got any idea's what it may be?

I can't see it seizing up just over a few months, afterall I was using all the time, only up to a few months ago when it went really cold, as I do like to be cold rather than warm on a long journey. Is there any common problem on this happening?

Blowers work fine on all speeds and the blue light comes on when the A/C button is depressed. Is there a relay somewhere on it??? As I don't hear it click when pressed like I used to before!

Any help would be greatly appreciated, I go on holiday in it the end of the month and if it ain't fixed, the wife is making us go in her Vauxhall Corsa, and that is nowhere as comfortable as my trusty 'ol Volvo!

Kind Regards,

Craig!


'94 850 T5 GLE
'95 440 GS 2.0i

Some do, Some don't, I might!

User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: Air Con condenser not cutting in...

Post by billofdurham » Fri Apr 16, 2010 12:34 pm

Craig,

It is the compressor that doesn't cut in. The condenser is in front of the radiator and just sits there sort of.....condensing. :)

The relay is at position 10 in the relay box:
440 relays.pdf
Bill.
You do not have the required permissions to view the files attached to this post.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

wig
Posts: 26
Joined: Sat Jan 02, 2010 7:06 am
Year and Model: 850 T5, 1994
Location: Birmingham, UK
Has thanked: 0
Been thanked: 0
wig

Re: Air Con condenser not cutting in...

Post by wig » Mon Apr 19, 2010 12:25 am

Hi Bill, I knew what I was on about, hehe! Cheers for that, but I found it to be the switch inside the car, I messed with it and pressed it in a different way and it come on, thank god! So I've just got to get the board out and find which part is not connecting properly, and correct that! All gassed up now again, and it's better than ever, and it only cost me £10, and it's done my mates 850 T5 aswell!

Any how, thanks again!

Craig!


'94 850 T5 GLE
'95 440 GS 2.0i

Some do, Some don't, I might!

User avatar
billofdurham
MVS Moderator
Posts: 6507
Joined: Thu Feb 02, 2006 3:31 pm
Year and Model: 855, 1995
Location: Durham, England
Has thanked: 0
Been thanked: 3 times
billofdurham

Re: Air Con condenser not cutting in...

Post by billofdurham » Mon Apr 19, 2010 12:37 pm

I knew what you were talking about as well. Thank you for the update.

Bill.


Work was good - retirement is better.

1996 850GLT 2.5 20v Estate Manual.
1995 Peugeot Boxer 2.5Tdi Autosleeper.
Previously:
1984 244DL, Manual, Beige.
1987 744GLE, Manual, Green.
1991 960 3.0 24v, Auto, Silver.
1994 940T Wentworth, Auto, Blue.

Post Reply