IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Cruise Control not working? Try this!

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

FUBAR
Posts: 97
Joined: Thu Jul 06, 2006 11:19 am
Year and Model:
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
FUBAR

Cruise Control not working? Try this!

Post by FUBAR » Mon Oct 25, 2010 6:32 pm

I haven't had my cruise control for a while now. There is an "ENGINE SYSTEM SERVICE REQUIRED" message that looks scary, but really means that there is a code being thrown ***not a CEL code which you could translate with a scan-gauge!!!! However, after every time I try to trade my car in at countless dealers I get the same response: "You got a check engine light on, we'll just deduct that from your trade-in value..." anyway I decided to go to a junk yard and get one of these off of a dead s60 and swap it for my bad unit. It's called a "brake pedal position sensor" and any shop (especially dealerships!) would love it if you came in and let them charge you $200 to replace one of these. Go to junkyard, spend $10-$15 and then come home and follow these instructions. Should take 5-10min in your garage. No special tools required.

FYI: The region which these photos refer to is on the driver side, directly under the brake fluid reservoir.

http://i245.photobucket.com/albums/gg50 ... /pps01.jpg
---
http://i245.photobucket.com/albums/gg50 ... /pps02.jpg


2001 V70T5 White Exterior/Taupe,Oak Interior, 18" Pegs, Bilstein HD, USA-Spec, volvo coolbox, tint and Xtant 1700watt sub, Blaupunkt components, Kenwood Amp.

BobbyC
Posts: 60
Joined: Sun Jun 13, 2010 3:00 pm
Year and Model: 2001 S60
Location: Texas, USA
Has thanked: 0
Been thanked: 0
BobbyC

Re: Cruise Control not working? Try this!

Post by BobbyC » Thu Oct 28, 2010 8:30 pm

I thought "Engine System Service Required" was a reminder for routine oil service every 5000mi?

Any way, my cruise has been very flaky, and intermittent. Maybe this is my problem-I will try it.

Thanks-
Bob



FUBAR
Posts: 97
Joined: Thu Jul 06, 2006 11:19 am
Year and Model:
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
FUBAR

Re: Cruise Control not working? Try this!

Post by FUBAR » Thu Oct 28, 2010 11:44 pm

Nah, there is a separate light that's in the right-hand side of the cluster under the fuel gauge. It actually reads "SERVICE". The "ENGINE SYSTEM SERVICE REQUIRED" message can often yield OBD2 codes, usually for O2 or MAF problems. This message went away about 50mi after I replaced the brake pedal position sensor.


2001 V70T5 White Exterior/Taupe,Oak Interior, 18" Pegs, Bilstein HD, USA-Spec, volvo coolbox, tint and Xtant 1700watt sub, Blaupunkt components, Kenwood Amp.

Post Reply