IPD sale Volvo Parts

2000 C70 Blower Motor

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70
Post Reply
johnmc825
Posts: 1
Joined: Fri Nov 05, 2010 10:30 am
Year and Model: c70 2000
Location: pa.

2000 C70 Blower Motor

Post by johnmc825 » Fri Nov 05, 2010 12:10 pm

Have a C70 - A/C - Heater blower starts, stops, lights flash. replaced resistor, blower seems ok (no noise) - but for only a couple of seconds then stops, lights flash.. looking for the next step.

Ozark Lee
MVS Moderator
Posts: 14669
Joined: Thu Sep 07, 2006 8:24 am
Year and Model: Many Volvos
Location: USA Midwest
Been thanked: 22 times
United States of America

Re: 2000 C70 Blower Motor

Post by Ozark Lee » Sat Nov 06, 2010 3:05 pm

Welcome to MVS,

The flashing lights mean that the system is mad about something but without codes I can't tell you what that is. The real bummer is that you need to have the codes scanned at a shop that has a Volvo scan tool or its equivalent. A standard OBD-II scanner won't read climate unit codes.

If you can come up with the codes we can proceed from there.

...Lee
'94 850 N/A 5 speed
'96 Platinum Edition Turbo
'99 V70XC - Nautic Blue
Previous:
1999 V70XC - RIP - Wrecked Parts Car.
1998 S70 T5
1996 850 N/A
1989 740 GLT
1986 740 GLT
1972 142 Grand Luxe

Jepc
Posts: 3
Joined: Sun Jul 08, 2018 5:06 am
Year and Model: C70 2006
Location: Melbourne
Australia

Re: 2000 C70 Blower Motor

Post by Jepc » Sun Jul 08, 2018 5:29 am

Hi. Any luck fixing this issue? I have the same. Fan starts for 1 second then stops and lights flash. Help needed please. Cheers.

User avatar
erikv11
Posts: 8485
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 34 times
Been thanked: 94 times
United States of America

Re: 2000 C70 Blower Motor

Post by erikv11 » Sun Jul 08, 2018 6:17 am

Jepc wrote:
Sun Jul 08, 2018 5:29 am
Hi. Any luck fixing this issue? I have the same. Fan starts for 1 second then stops and lights flash. Help needed please. Cheers.
Same fix - if you pull and report the codes, then we will know where to start.

Is this for your 2006 C70?
'95 854 T5-R || m4.4 || 185k
'96 855 NA || 140k
'98 V70 || T5 tune-injectors-turbo, LPT engine || 275k
'06 S60 R || 145k
gone: '96 NA 850 210k, '98 NA V70 182k, '98 NA S70 174k

Jepc
Posts: 3
Joined: Sun Jul 08, 2018 5:06 am
Year and Model: C70 2006
Location: Melbourne
Australia

Re: 2000 C70 Blower Motor

Post by Jepc » Sun Jul 08, 2018 11:07 pm

Hi. Yes it’s a c70. How do I pull / get the error codes? Cheers. J.

User avatar
erikv11
Posts: 8485
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 34 times
Been thanked: 94 times
United States of America

Re: 2000 C70 Blower Motor

Post by erikv11 » Mon Jul 09, 2018 5:35 pm

A 2006 C70 is a very different car from a 2000 C70. You will need a VIDA setup to get the codes. It isn't hard to run VIDA on a Windows laptop but it requires some investment. Or take it to a shop that has VIDA, but getting the codes will likely cost you.

Your best bet is start a new thread over in the forum that includes your C70 viewforum.php?f=25
'95 854 T5-R || m4.4 || 185k
'96 855 NA || 140k
'98 V70 || T5 tune-injectors-turbo, LPT engine || 275k
'06 S60 R || 145k
gone: '96 NA 850 210k, '98 NA V70 182k, '98 NA S70 174k

Post Reply

Who is online

Users browsing this forum: JuliusC, rspi, ToriWhite and 55 guests