IPD sale Volvo Parts

2000 S40 Turbo 10a engine fuse keeps blowing

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.
1996 - 2004 S40
1996 - 2004 V40
Post Reply
midimykeys
Posts: 96
Joined: Sun Feb 19, 2012 2:12 pm
Year and Model: 1994 Volvo 850
Location: St. Louis, MO

2000 S40 Turbo 10a engine fuse keeps blowing

Post by midimykeys » Mon Sep 02, 2013 11:54 am

I purchased this car a week ago, and it's been through multiple 10 amp engine fuses. Is this a common problem? I search a bit, and it didn't seem like it. What are the steps to take from the least expensive to the most expensive. Other than this problem, the car is great!
2001 S80 2.9
2001 S60T
3 850s
1985 240 DL

jimmy57
Posts: 6123
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 120 times

Re: 2000 S40 Turbo 10a engine fuse keeps blowing

Post by jimmy57 » Mon Sep 02, 2013 12:09 pm

The heated nipple on inlet hose to turbo is known for shorting and blowing fuses. Disconnect its electrical connector and see if that stops the blown fuse problem.

midimykeys
Posts: 96
Joined: Sun Feb 19, 2012 2:12 pm
Year and Model: 1994 Volvo 850
Location: St. Louis, MO

Re: 2000 S40 Turbo 10a engine fuse keeps blowing

Post by midimykeys » Mon Sep 02, 2013 1:47 pm

Ok I'll try that. I took it to get the check engine code reading, and 7 appeared. In all of the reported solutions for each code, replacing the crankcase vent heater was among them, telling me that I probably needed to do that. I could find a lot of info online, is it a bear to do?
2001 S80 2.9
2001 S60T
3 850s
1985 240 DL

Volvolove90
Posts: 2
Joined: Fri Nov 02, 2018 11:05 am
Year and Model: 2000 s40
Location: PA
United States of America

Re: 2000 S40 Turbo 10a engine fuse keeps blowing

Post by Volvolove90 » Fri Nov 02, 2018 11:07 am

Hey I'm having the same problem is you with your S40 did you ever figure your problem out

Volvolove90
Posts: 2
Joined: Fri Nov 02, 2018 11:05 am
Year and Model: 2000 s40
Location: PA
United States of America

Re: 2000 S40 Turbo 10a engine fuse keeps blowing

Post by Volvolove90 » Fri Nov 02, 2018 11:13 am

My 2000 Volvo S40 keeps blowing the 10 amp engine fuse and the car won't start unless my foot is on the gas

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests